Android 安全公告 - 2018 年 4 月

发布时间:2018 年 4 月 2 日

本 Android 安全公告详细介绍了会影响 Android 设备的安全漏洞。安全补丁程序级别为 2018 年 4 月 5 日或更新的版本都已解决本公告中所述的问题。请参阅查看并更新 Android 版本,了解如何查看设备的安全补丁程序级别。

Android 合作伙伴在本公告发布前至少一个月就已收到所有问题的相关通知。我们已将针对这些问题的源代码补丁程序发布到 Android 开源项目 (AOSP) 代码库中,并在本公告中提供了相应链接。本公告还提供了 AOSP 之外的补丁程序的链接。

这些问题中危险性最高的是媒体框架中的一个严重程度为“严重”的安全漏洞,该漏洞可让远程攻击者利用专门制作的文件通过特权进程执行任意代码。严重程度评估的依据是漏洞被利用后可能会对受影响的设备造成的影响(假设相关平台和服务缓解措施被成功规避或出于开发目的而被停用)。

尚未有人向我们举报过有用户主动利用或滥用这些新报告的问题。请参阅 Android 和 Google Play 保护机制提供的缓解措施部分,详细了解有助于提高 Android 平台安全性的 Android 安全平台防护功能和 Google Play 保护机制。

注意:如需了解与适用于 Google 设备的最新无线下载更新 (OTA) 和固件映像相关的信息,请参阅 2018 年 4 月 Pixel/Nexus 安全公告

通告

我们衷心感谢 Qualcomm 为改进移动设备做出的贡献:2018-04-05 SPL 包含了 Qualcomm 2014-2016 年合作伙伴关注公告中已解决的安全问题的累积清单,反映了他们对持续努力和改进的承诺。

Android 和 Google 服务缓解措施

这一部分总结了 Android 安全平台和服务防护功能(如 Google Play 保护机制)提供的缓解措施。这些功能可降低 Android 上的安全漏洞被成功利用的可能性。

  • 较高版本的 Android 平台中提供的增强功能让攻击者更加难以利用 Android 上存在的许多问题。我们建议所有用户都尽可能更新到最新版 Android。
  • Android 安全团队会积极利用 Google Play 保护机制监控滥用行为,并会在发现可能有害的应用时向用户发出警告。在安装有 Google 移动服务的设备上,Google Play 保护机制会默认处于启用状态,对于从 Google Play 以外的来源安装应用的用户来说,该功能尤为重要。

2018-04-01 安全补丁程序级别 - 漏洞详情

我们在下面提供了 2018-04-01 补丁程序级别涵盖的每个安全漏洞的详细信息,漏洞列在所影响的组件下,其中包括问题描述和一个表,该表中包含 CVE、相关参考内容、漏洞类型严重程度和已更新的 AOSP 版本(如果适用)。如果有解决相应问题的公开更改记录(例如 AOSP 代码更改列表),我们会将 Bug ID 链接到该记录。如果某个 Bug 有多条相关的代码更改记录,我们还会通过 Bug ID 后面的数字链接到更多参考内容。

Android 运行时

这一部分中最严重的漏洞可让远程攻击者绕过用户互动要求来获得额外的权限。

CVE 参考内容 类型 严重程度 已更新的 AOSP 版本
CVE-2017-13274 A-71360761 EoP 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1

框架

这一部分中涉及的最严重的漏洞可能使本地恶意应用绕过将应用数据与其它应用隔离的操作系统保护措施。

CVE 参考内容 类型 严重程度 已更新的 AOSP 版本
CVE-2017-13275 A-70808908 ID 8.0、8.1

媒体框架

这一部分中最严重的漏洞可让远程攻击者利用专门制作的文件通过特权进程执行任意代码。

CVE 参考内容 类型 严重程度 已更新的 AOSP 版本
CVE-2017-13276 A-70637599 RCE 严重 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13277 A-72165027 RCE 严重 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13278 A-70546581 EoP 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13279 A-68399439 DoS 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13280 A-71361451 DoS 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1

系统

这一部分中最严重的漏洞可让远程攻击者利用专门制作的文件通过特权进程执行任意代码。

CVE 参考内容 类型 严重程度 已更新的 AOSP 版本
CVE-2017-13281 A-71603262 RCE 严重 8.0、8.1
CVE-2017-13282 A-71603315 RCE 严重 7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13283 A-71603410 RCE 严重 7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13267 A-69479009 RCE 严重 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13284 A-70808273 EoP 严重 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13285 A-69177126 RCE 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13286 A-69683251 EoP 8.0、8.1
CVE-2017-13287 A-71714464 EoP 6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13288 A-69634768 EoP 8.0、8.1
CVE-2017-13289 A-70398564 EoP 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13290 A-69384124 ID 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0、8.1
CVE-2017-13291 A-71603553 DoS 7.0、7.1.1、7.1.2、8.0、8.1

2018-04-05 安全补丁程序级别 - 漏洞详情

我们在下面提供了 2018-04-05 补丁程序级别涵盖的每个安全漏洞的详细信息,漏洞列在受其影响的组件下,其中包括 CVE、相关参考内容、漏洞类型严重程度、组件(如果适用)和已更新的 AOSP 版本(如果适用)等详细信息。在适用的情况下,我们会将 Bug ID 链接到解决相应问题的公开更改记录(如 AOSP 代码更改列表)。

如果某个 Bug 有多项相关的代码更改,我们还会通过 Bug ID 后面的数字链接到更多参考内容。

Broadcom 组件

这一部分中最严重的漏洞可让邻近区域内的攻击者利用专门制作的文件通过特权进程执行任意代码。

CVE 参考内容 类型 严重程度 组件
CVE-2017-13292 A-70722061*
B-V2018010201
RCE 严重 Bcmdhd 驱动程序

内核组件

这一部分中最严重的漏洞可让本地恶意应用通过特权进程执行任意代码。

CVE 参考内容 类型 严重程度 组件
CVE-2017-13293 A-62679701* EoP NFC 驱动程序
CVE-2017-5754 A-69856074* ID 内存映射
CVE-2017-1653 A-69052594
上游内核
ID USB

Qualcomm 组件

这一部分中最严重的漏洞可让邻近区域内的攻击者利用专门制作的文件通过特权进程执行任意代码。

CVE 参考内容 类型 严重程度 组件
CVE-2017-15822 A-71501534
QC-CR#2123807
RCE 严重 WLAN
CVE-2017-17770 A-70237684
QC-CR#2103199 [2]
EoP Binder
CVE-2018-3566 A-72957177
QC-CR#2143847
EoP WLAN
CVE-2018-3563 A-72956842
QC-CR#2143207[2][3]
EoP 音频驱动程序
CVE-2017-13077 A-72957017
QC-CR#2129237
ID WLAN

Qualcomm 闭源组件

下列漏洞会影响 Qualcomm 组件;相关 Qualcomm AMSS 安全公告或安全提醒对这些漏洞进行了更详细的说明。这些问题的严重程度评估由 Qualcomm 直接提供。

CVE 参考内容 类型 严重程度 组件
CVE-2017-18071 A-68326813* 不适用 严重 闭源组件
CVE-2017-8274 A-68141335* 不适用 严重 闭源组件
CVE-2017-18146 A-70221449* 不适用 严重 闭源组件
CVE-2017-18128 A-70221448* 不适用 严重 闭源组件
CVE-2018-3592 A-71501105* 不适用 严重 闭源组件
CVE-2018-3591 A-71501103* 不适用 严重 闭源组件
CVE-2017-18074 A-68326816* 不适用 闭源组件
CVE-2017-18073 A-68326820* 不适用 闭源组件
CVE-2017-18125 A-68326821* 不适用 闭源组件
CVE-2017-8275 A-68141336* 不适用 闭源组件
CVE-2017-11011 A-68326823* 不适用 闭源组件
CVE-2017-18137 A-67712318* 不适用 闭源组件
CVE-2017-18134 A-67712320* 不适用 闭源组件
CVE-2017-18136 A-68989810* 不适用 闭源组件
CVE-2017-18140 A-68989811* 不适用 闭源组件
CVE-2017-18135 A-68989813* 不适用 闭源组件
CVE-2017-18142 A-68989814* 不适用 闭源组件
CVE-2017-18138 A-68989815* 不适用 闭源组件
CVE-2017-18139 A-68989819* 不适用 闭源组件
CVE-2017-18129 A-68989822* 不适用 闭源组件
CVE-2017-18132 A-68989825* 不适用 闭源组件
CVE-2017-18133 A-68989826* 不适用 闭源组件
CVE-2017-18072 A-68989828* 不适用 闭源组件
CVE-2017-18126 A-68989829* 不适用 闭源组件
CVE-2017-18144 A-70221450* 不适用 闭源组件
CVE-2017-18145 A-70221453* 不适用 闭源组件
CVE-2017-18147 A-70221456* 不适用 闭源组件
CVE-2017-18130 A-70221460* 不适用 闭源组件
CVE-2017-18143 A-70221461* 不适用 闭源组件
CVE-2017-18127 A-70221462* 不适用 闭源组件
CVE-2018-3590 A-71501106* 不适用 闭源组件
CVE-2018-3593 A-71501107* 不适用 闭源组件
CVE-2018-3589 A-71501108* 不适用 闭源组件
CVE-2018-3594 A-71501112* 不适用 闭源组件

Qualcomm 闭源组件 2014-2016 年积累更新

下列漏洞影响 Qualcomm 组件,并已通过 Qualcomm AMSS 安全公告或安全警报在 2014 年至 2016 年期间由 Qualcomm 与其合作伙伴共享。此 Android 安全公告中也包含这些漏洞,旨在将其修复方案与 Android 安全补丁程序级别建立关联(许多 Android 设备可能已在之前的更新中解决了这些问题)。这些问题的严重程度评估由 Qualcomm 直接提供。

CVE 参考内容 类型 严重程度 组件
CVE-2014-9996 A-37535090* 不适用 严重 闭源组件
CVE-2014-9971 A-37546253* 不适用 闭源组件
CVE-2014-9972 A-37546853* 不适用 闭源组件
CVE-2014-10063 A-37534948* 不适用 闭源组件
CVE-2014-10057 A-62261099* 不适用 闭源组件
CVE-2014-10059 A-62260706* 不适用 闭源组件
CVE-2014-10053 A-37544066* 不适用 闭源组件
CVE-2014-10054 A-62261100* 不适用 闭源组件
CVE-2014-10052 A-62258372* 不适用 闭源组件
CVE-2014-10050 A-37546901* 不适用 闭源组件
CVE-2014-10055 A-37545605* 不适用 闭源组件
CVE-2014-10051 A-37546302* 不适用 闭源组件
CVE-2014-10048 A-62258088* 不适用 闭源组件
CVE-2014-10062 A-62258373* 不适用 闭源组件
CVE-2014-10058 A-62260741* 不适用 闭源组件
CVE-2014-10047 A-37538492* 不适用 闭源组件
CVE-2014-10045 A-62258536* 不适用 闭源组件
CVE-2014-10056 A-62261338* 不适用 闭源组件
CVE-2014-9976 A-37534895* 不适用 闭源组件
CVE-2014-10043 A-62259947* 不适用 闭源组件
CVE-2014-10044 A-62260777* 不适用 闭源组件
CVE-2014-10046 A-62261408* 不适用 闭源组件
CVE-2014-9981 A-37534949* 不适用 闭源组件
CVE-2014-9993 A-37540928* 不适用 闭源组件
CVE-2014-9986 A-37534645* 不适用 闭源组件
CVE-2014-9994 A-37538493* 不适用 闭源组件
CVE-2014-9995 A-37546303* 不适用 闭源组件
CVE-2014-9997 A-37546854* 不适用 闭源组件
CVE-2014-9988 A-62258089* 不适用 闭源组件
CVE-2014-9990 A-62261216* 不适用 闭源组件
CVE-2014-9987 A-62261293* 不适用 闭源组件
CVE-2014-9989 A-62261380* 不适用 闭源组件
CVE-2014-9991 A-62261409* 不适用 闭源组件
CVE-2014-10039 A-62261608* 不适用 闭源组件
CVE-2014-9985 A-62261609* 不适用 闭源组件
CVE-2015-9204 A-37540929* 不适用 闭源组件
CVE-2015-0574 A-37546304* 不适用 闭源组件
CVE-2015-9205 A-37534696* 不适用 闭源组件
CVE-2015-9221 A-37534796* 不适用 闭源组件
CVE-2015-9212 A-37535795* 不适用 闭源组件
CVE-2015-9210 A-62258538* 不适用 闭源组件
CVE-2015-9211 A-62261217* 不适用 闭源组件
CVE-2015-9207 A-62261410* 不适用 闭源组件
CVE-2015-9202 A-37540473* 不适用 闭源组件
CVE-2015-9213 A-37547700* 不适用 闭源组件
CVE-2015-9209 A-38193247* 不适用 闭源组件
CVE-2015-9203 A-62261218* 不适用 闭源组件
CVE-2015-9206 A-62261294* 不适用 闭源组件
CVE-2015-9215 A-62251854* 不适用 闭源组件
CVE-2015-9216 A-62260780* 不适用 闭源组件
CVE-2015-9169 A-37535098* 不适用 闭源组件
CVE-2015-9173 A-37536244* 不适用 闭源组件
CVE-2015-9179 A-37542567* 不适用 闭源组件
CVE-2015-9177 A-37544075* 不适用 闭源组件
CVE-2015-9187 A-37544109* 不适用 闭源组件
CVE-2015-9162 A-37544110* 不适用 闭源组件
CVE-2015-9172 A-37545607* 不适用 闭源组件
CVE-2015-9181 A-37546754* 不适用 闭源组件
CVE-2015-9219 A-37546859* 不适用 闭源组件
CVE-2015-9183 A-37546860* 不适用 闭源组件
CVE-2015-9182 A-37546904* 不适用 闭源组件
CVE-2015-9185 A-37546952* 不适用 闭源组件
CVE-2015-9184 A-37546953* 不适用 闭源组件
CVE-2015-9170 A-37546954* 不适用 闭源组件
CVE-2015-9175 A-37547404* 不适用 闭源组件
CVE-2015-9171 A-37547405* 不适用 闭源组件
CVE-2015-9192 A-37547750* 不适用 闭源组件
CVE-2015-9208 A-62258540* 不适用 闭源组件
CVE-2015-9224 A-62259949* 不适用 闭源组件
CVE-2015-9201 A-62260711* 不适用 闭源组件
CVE-2015-9200 A-62260779* 不适用 闭源组件
CVE-2015-9198 A-62261219* 不适用 闭源组件
CVE-2015-9196 A-62261339* 不适用 闭源组件
CVE-2015-9199 A-62261411* 不适用 闭源组件
CVE-2015-9174 A-62258090* 不适用 闭源组件
CVE-2015-9178 A-62258541* 不适用 闭源组件
CVE-2015-9180 A-62260712* 不适用 闭源组件
CVE-2015-9176 A-62260713* 不适用 闭源组件
CVE-2015-9189 A-62260820* 不适用 闭源组件
CVE-2015-9188 A-62260821* 不适用 闭源组件
CVE-2015-0576 A-37543715* 不适用 闭源组件
CVE-2015-9156 A-62260743* 不适用 闭源组件
CVE-2015-9195 A-62251855* 不适用 闭源组件
CVE-2015-9197 A-62260742* 不适用 闭源组件
CVE-2015-9218 A-62260781* 不适用 闭源组件
CVE-2015-9217 A-62261295* 不适用 闭源组件
CVE-2015-9166 A-62251856* 不适用 闭源组件
CVE-2015-9164 A-62258542* 不适用 闭源组件
CVE-2015-9190 A-62259744* 不适用 闭源组件
CVE-2015-9159 A-62259745* 不适用 闭源组件
CVE-2015-9167 A-62259950* 不适用 闭源组件
CVE-2015-9191 A-62260394* 不适用 闭源组件
CVE-2015-9161 A-62260462* 不适用 闭源组件
CVE-2015-9163 A-62260822* 不适用 闭源组件
CVE-2015-9158 A-62261381* 不适用 闭源组件
CVE-2015-9152 A-37546305* 不适用 闭源组件
CVE-2015-9144 A-37540474* 不适用 闭源组件
CVE-2015-9165 A-37539224* 不适用 闭源组件
CVE-2015-9223 A-37543718* 不适用 闭源组件
CVE-2015-9222 A-62258374* 不适用 闭源组件
CVE-2015-9193 A-62259951* 不适用 闭源组件
CVE-2015-9194 A-62261296* 不适用 闭源组件
CVE-2015-9153 A-62260395* 不适用 闭源组件
CVE-2015-9151 A-62260396* 不适用 闭源组件
CVE-2015-9148 A-62260463* 不适用 闭源组件
CVE-2015-9149 A-62260744* 不适用 闭源组件
CVE-2015-9146 A-62260745* 不适用 闭源组件
CVE-2015-9186 A-62261340* 不适用 闭源组件
CVE-2015-9150 A-62261341* 不适用 闭源组件
CVE-2015-9147 A-62261488* 不适用 闭源组件
CVE-2015-8593 A-37535091* 不适用 闭源组件
CVE-2015-9160 A-37546254* 不适用 闭源组件
CVE-2015-8594 A-37546855* 不适用 闭源组件
CVE-2015-9145 A-37535099* 不适用 闭源组件
CVE-2015-9143 A-62260900* 不适用 闭源组件
CVE-2015-9157 A-62260934* 不适用 闭源组件
CVE-2015-9141 A-62261297* 不适用 闭源组件
CVE-2015-9140 A-62259746* 不适用 闭源组件
CVE-2015-9135 A-37546950* 不适用 闭源组件
CVE-2015-9138 A-62259952* 不适用 闭源组件
CVE-2015-9136 A-62260823* 不适用 闭源组件
CVE-2015-9137 A-62260975* 不适用 闭源组件
CVE-2015-9131 A-37542272* 不适用 闭源组件
CVE-2015-9139 A-62251857* 不适用 闭源组件
CVE-2015-9130 A-62252820* 不适用 闭源组件
CVE-2015-9129 A-62260397* 不适用 闭源组件
CVE-2015-9133 A-62260464* 不适用 闭源组件
CVE-2015-9127 A-62260824* 不适用 闭源组件
CVE-2015-9132 A-62260976* 不适用 闭源组件
CVE-2015-9134 A-62261382* 不适用 闭源组件
CVE-2015-9128 A-62261610* 不适用 闭源组件
CVE-2015-9065 A-37538494* 不适用 闭源组件
CVE-2015-9064 A-37546801* 不适用 闭源组件
CVE-2015-9063 A-37546802* 不适用 闭源组件
CVE-2015-9126 A-62258375* 不适用 闭源组件
CVE-2015-9124 A-62252821* 不适用 闭源组件
CVE-2015-9142 A-62260901* 不适用 闭源组件
CVE-2015-9066 A-37540467* 不适用 闭源组件
CVE-2014-9998 A-62260398* 不适用 闭源组件
CVE-2015-9220 A-62261299* 不适用 闭源组件
CVE-2015-9122 A-62261611* 不适用 闭源组件
CVE-2015-9123 A-62259953* 不适用 闭源组件
CVE-2015-9118 A-62261220* 不适用 闭源组件
CVE-2015-9120 A-62261298* 不适用 闭源组件
CVE-2015-9119 A-62261489* 不适用 闭源组件
CVE-2015-9116 A-37540934* 不适用 闭源组件
CVE-2015-9115 A-37544076* 不适用 闭源组件
CVE-2015-9113 A-37544077* 不适用 闭源组件
CVE-2015-9112 A-62258091* 不适用 闭源组件
CVE-2015-9114 A-62259954* 不适用 闭源组件
CVE-2015-9111 A-62260465* 不适用 闭源组件
CVE-2015-9108 A-62260714* 不适用 闭源组件
CVE-2015-9109 A-62260977* 不适用 闭源组件
CVE-2015-9110 A-62261383* 不适用 闭源组件
CVE-2016-10492 A-62261300* 不适用 闭源组件
CVE-2016-10482 A-62260978* 不适用 闭源组件
CVE-2016-10483 A-62258092* 不适用 闭源组件
CVE-2016-10489 A-62258093* 不适用 闭源组件
CVE-2016-10487 A-62259955* 不适用 闭源组件
CVE-2016-10477 A-62260399* 不适用 闭源组件
CVE-2016-10485 A-62260902* 不适用 闭源组件
CVE-2016-10478 A-62260979* 不适用 闭源组件
CVE-2016-10476 A-62260980* 不适用 闭源组件
CVE-2016-10475 A-62260981* 不适用 闭源组件
CVE-2016-10474 A-62260982* 不适用 闭源组件
CVE-2016-10494 A-62261102* 不适用 闭源组件
CVE-2016-10484 A-62261342* 不适用 闭源组件
CVE-2016-10491 A-62261490* 不适用 闭源组件
CVE-2016-10486 A-62267788 * 不适用 闭源组件
CVE-2016-10472 A-62259956* 不适用 闭源组件
CVE-2016-10490 A-62260468* 不适用 闭源组件
CVE-2016-10480 A-62261301* 不适用 闭源组件
CVE-2016-10467 A-37526814* 不适用 闭源组件
CVE-2016-10495 A-62261103* 不适用 闭源组件
CVE-2016-10481 A-62260401* 不适用 闭源组件
CVE-2016-10479 A-62261412* 不适用 闭源组件
CVE-2016-10384 A-37536238* 不适用 闭源组件
CVE-2016-10385 A-37544067* 不适用 闭源组件
CVE-2016-10452 A-37523164* 不适用 闭源组件
CVE-2016-10423 A-37534896* 不适用 闭源组件
CVE-2016-10424 A-37540034* 不适用 闭源组件
CVE-2016-10449 A-37546861* 不适用 闭源组件
CVE-2016-10454 A-37544078* 不适用 闭源组件
CVE-2016-10450 A-62260825* 不适用 闭源组件
CVE-2016-10451 A-62267789* 不适用 闭源组件
CVE-2016-10386 A-37534646* 不适用 闭源组件
CVE-2016-10469 A-37542273* 不适用 闭源组件
CVE-2016-10440 A-37535092* 不适用 闭源组件
CVE-2016-10499 A-62259957* 不适用 闭源组件
CVE-2016-10446 A-37547406* 不适用 闭源组件
CVE-2016-10473 A-62260746* 不适用 闭源组件
CVE-2016-10466 A-62260783* 不适用 闭源组件
CVE-2016-10457 A-62260826* 不适用 闭源组件
CVE-2016-10442 A-62267790* 不适用 闭源组件
CVE-2016-10433 A-37540468* 不适用 闭源组件
CVE-2016-10430 A-37540930* 不适用 闭源组件
CVE-2016-10445 A-37545608* 不适用 闭源组件
CVE-2016-10426 A-62252822* 不适用 闭源组件
CVE-2016-10435 A-62260402* 不适用 闭源组件
CVE-2016-10425 A-62260983* 不适用 闭源组件
CVE-2016-10438 A-62261302* 不适用 闭源组件
CVE-2016-10436 A-62261494* 不适用 闭源组件
CVE-2016-10439 A-62263656* 不适用 闭源组件
CVE-2016-10431 A-37540931* 不适用 闭源组件
CVE-2016-10434 A-37540932* 不适用 闭源组件
CVE-2016-10432 A-37546902* 不适用 闭源组件
CVE-2016-10462 A-37539225* 不适用 闭源组件
CVE-2016-10443 A-37540475* 不适用 闭源组件
CVE-2016-10427 A-62261495* 不适用 闭源组件
CVE-2016-10387 A-32583751* 不适用 闭源组件
CVE-2016-10390 A-37536239* 不适用 闭源组件
CVE-2016-10498 A-32582870* 不适用 闭源组件
CVE-2016-10419 A-32577129* 不适用 闭源组件
CVE-2016-10420 A-32579916* 不适用 闭源组件
CVE-2016-10429 A-32579411* 不适用 闭源组件
CVE-2016-10493 A-32574787* 不适用 闭源组件
CVE-2016-10447 A-37542968* 不适用 闭源组件
CVE-2016-10444 A-37544163* 不适用 闭源组件
CVE-2016-5348 A-37546905* 不适用 闭源组件
CVE-2016-10421 A-32579095* 不适用 闭源组件
CVE-2016-10455 A-32580964* 不适用 闭源组件
CVE-2016-10441 A-32582927* 不适用 闭源组件
CVE-2016-10418 A-37547407* 不适用 闭源组件
CVE-2016-10417 A-32576287* 不适用 闭源组件
CVE-2016-10464 A-32580243* 不适用 闭源组件
CVE-2016-10458 A-32583424* 不适用 闭源组件
CVE-2016-10471 A-37539226* 不适用 闭源组件
CVE-2016-10416 A-62259747* 不适用 闭源组件
CVE-2016-10411 A-62260404* 不适用 闭源组件
CVE-2016-10496 A-62260469* 不适用 闭源组件
CVE-2016-10410 A-62260936* 不适用 闭源组件
CVE-2016-10414 A-62260937* 不适用 闭源组件
CVE-2016-10461 A-62263657* 不适用 闭源组件
CVE-2016-10460 A-62271227* 不适用 闭源组件
CVE-2016-10392 A-37544068* 不适用 闭源组件
CVE-2016-10409 A-37544164* 不适用 闭源组件
CVE-2016-10459 A-62260716* 不适用 闭源组件
CVE-2016-10407 A-62261222* 不适用 闭源组件
CVE-2016-10406 A-62267791* 不适用 闭源组件
CVE-2016-10497 A-62271228* 不适用 闭源组件
CVE-2016-10501 A-62261303* 不适用 闭源组件
CVE-2016-10381 A-37539788* 不适用 闭源组件
CVE-2016-10380 A-37541976* 不适用 闭源组件
CVE-2016-10412 A-37536245* 不适用 闭源组件
CVE-2016-10415 A-62260403* 不适用 闭源组件
CVE-2016-10422 A-37542966* 不适用 闭源组件
CVE-2016-10456 A-62261413* 不适用 闭源组件
CVE-2016-10428 A-37534697* 不适用 闭源组件
CVE-2016-10448 A-62261414* 不适用 闭源组件
CVE-2016-10437 A-62260715* 不适用 闭源组件

常见问题和解答

这一部分解答了用户阅读本公告后可能会提出的常见问题。

1. 如何确定我的设备是否已更新到解决了这些问题的版本?

要了解如何查看设备的安全补丁程序级别,请参阅查看并更新 Android 版本

  • 2018-04-01(或之后)的安全补丁程序级别解决了与 2018-01-01 安全补丁程序级别相关的所有问题。
  • 2018-04-05(或之后)的安全补丁程序级别解决了与 2018-04-05 安全补丁程序级别以及之前的所有补丁程序级别相关的所有问题。

预装这些更新的设备制造商应将补丁程序字符串级别设为:

  • [ro.build.version.security_patch]:[2018 年 4 月 1 日]
  • [ro.build.version.security_patch]:[2018 年 4 月 5 日]

2. 为何本公告会有 2 个安全补丁程序级别?

本公告有 2 个安全补丁程序级别,目的是让 Android 合作伙伴能够灵活地、更快速地修复所有 Android 设备上类似的一系列漏洞。我们建议 Android 合作伙伴修复本公告中的所有问题并使用最新的安全补丁程序级别。

  • 使用 2018-04-01 安全补丁程序级别的设备必须包含该安全补丁程序级别对应的所有问题的修复方案,以及针对之前的安全公告中报告的所有问题的修复方案。
  • 使用 2018-04-05 或更新的安全补丁程序级别的设备必须包含此(以及之前的)安全公告中的所有适用补丁程序。

我们建议合作伙伴在一次更新中汇总要解决的所有问题的修复方案。

3.“类型”列中的条目表示什么意思?

漏洞详情表的“类型”列中的条目是安全漏洞的分类。

缩写词 定义
RCE 远程代码执行
EoP 提权
ID 信息披露
DoS 拒绝服务
不适用 没有分类

4. “参考内容”列中的条目表示什么意思?

在漏洞详情表内,“参考内容”列中的条目可能包含用于标识参考值所属组织的前缀。

前缀 参考内容
A- Android Bug ID
QC- Qualcomm 参考编号
M- MediaTek 参考编号
N- NVIDIA 参考编号
B- Broadcom 参考编号

5. 在“参考内容”列中,Android Bug ID 旁边的 * 表示什么意思?

如果问题尚未公开发布,则在“参考内容”列中,相应 Android Bug ID 旁边会显示 *。Google Developers 网站上针对 Nexus 设备提供的最新二进制驱动程序中通常包含旨在解决相应问题的更新。

6. 为什么要将安全漏洞拆分到本公告和设备 / 合作伙伴安全公告(如 Pixel/Nexus 公告)中?

要在 Android 设备上声明最新的安全补丁程序级别,必须修复本安全公告中记录的安全漏洞。但在声明安全补丁程序级别时,并不是必须要修复设备/合作伙伴安全公告中记录的其他安全漏洞。我们建议 Android 设备和芯片组制造商通过自己的安全网站(例如 SamsungLGEPixel/Nexus 安全公告)记录其设备上存在的其他修复程序。

版本

版本 日期 备注
1.0 2018 年 4 月 2 日 发布了本公告。