Android 安全公告 - 2017 年 11 月

发布时间:2017 年 11 月 6 日 | 更新时间:2017 年 11 月 8 日

Android 安全公告详细介绍了会影响 Android 设备的安全漏洞。如果安全补丁级别是 2017-11-06 或更新,就意味着已解决所有这些问题。如需了解如何查看设备的安全补丁级别,请参阅查看并更新 Android 版本

Android 合作伙伴在本公告发布前至少一个月就已收到 2017-11-01 和 2017-11-05 补丁级别中的所有问题的相关通知。Android 合作伙伴在上个月就已收到 2017-11-06 补丁级别中的所有问题的相关通知。我们已将解决这些问题的源代码补丁发布到 Android 开源项目 (AOSP) 代码库中,并在本公告中提供了相应链接。本公告中还提供了指向 AOSP 之外的补丁的链接。

这些问题中危险性最高的是媒体框架中的一个严重程度为“严重”的安全漏洞,该漏洞可让远程攻击者利用蓄意创建的文件在特权进程环境中执行任意代码。严重程度评估的依据是漏洞被利用后可能会对受影响的设备造成的影响(假设相关平台和服务缓解措施被成功规避或出于开发目的而被停用)。

我们尚未收到用户因这些新报告的问题而遭到主动攻击或这些问题遭到滥用的报告。请参阅 Android 和 Google Play 保护机制提供的缓解措施部分,详细了解有助于提高 Android 平台安全性的 Android 安全平台防护功能和 Google Play 保护机制。

注意:如需了解适用于 Google 设备的最新无线下载更新 (OTA) 和固件映像,请参阅 2017 年 11 月的 Pixel/Nexus 安全公告

通告

  • 我们推出了新的 Pixel/Nexus 安全公告,其中介绍了在受支持的 Pixel 和 Nexus 设备上解决的其他安全漏洞和实现的功能改进。Android 设备制造商可以选择在其设备上解决这些问题。如需了解详情,请参阅常见问题和解答
  • 您可以在 2017-11-06 安全补丁程序级别下找到针对 KRACK 漏洞的安全补丁程序。

Android 和 Google 服务缓解措施

这一部分总结了 Android 安全平台和服务防护功能(如 Google Play 保护机制)提供的缓解措施。这些功能有助于降低 Android 上的安全漏洞被成功利用的可能性。

  • 较高版本的 Android 平台中提供的增强功能让攻击者更加难以利用 Android 上存在的许多问题。我们建议所有用户都尽可能更新到最新版 Android。
  • Android 安全团队会积极利用 Google Play 保护机制监控滥用行为,并会在发现潜在有害应用时向用户发出警告。在安装有 Google 移动服务的设备上,Google Play 保护机制在默认情况下处于启用状态,对于从 Google Play 以外的来源安装应用的用户来说,该功能尤为重要。

2017-11-01 安全补丁级别 - 漏洞详情

我们在下面提供了 2017-11-01 补丁级别涵盖的每个安全漏洞的详细信息,漏洞分组列在所影响的组件下,内容包括问题描述和一张表,该表中包含 CVE、相关参考编号、漏洞类型严重程度和已更新的 AOSP 版本(若有)。在适用的情况下,我们会将 bug ID 链接到解决相应问题的公开更改记录(如 AOSP 代码更改列表)。如果某个 bug 有多条相关的代码更改记录,我们还会通过 bug ID 后面的数字链接到更多参考内容。

框架

这一部分中最严重的漏洞可让本地恶意应用绕过用户互动要求来获得额外的权限。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2017-0830 A-62623498 EoP 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-0831 A-37442941 [2] EoP 8.0

媒体框架

这一部分中最严重的漏洞可让远程攻击者利用蓄意创建的文件在特权进程环境中执行任意代码。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2017-0832 A-62887820 RCE 严重 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-0833 A-62896384 RCE 严重 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-0834 A-63125953 RCE 严重 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-0835 A-63316832 RCE 严重 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-0836 A-64893226 RCE 严重 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-0839 A-64478003 ID 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-0840 A-62948670 ID 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0

系统

这一部分中最严重的漏洞可让远程攻击者利用蓄意创建的文件在特权进程环境中执行任意代码。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2017-0841 A-37723026 RCE 严重 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-0842 A-37502513 EoP 6.0、6.0.1、7.0、7.1.1、7.1.2、8.0

2017-11-05 安全补丁级别 - 漏洞详情

我们在下面提供了 2017-11-05 补丁级别涵盖的每个安全漏洞的详细信息,漏洞分组列在所影响的组件下,内容包括 CVE、相关参考编号、漏洞类型严重程度、组件(若有)和已更新的 AOSP 版本(若有)等详细信息。在适用的情况下,我们会将 Bug ID 链接到解决相应问题的公开更改记录(如 AOSP 代码更改列表)。如果某个 Bug 有多条相关的更改记录,我们还将通过 Bug ID 后面的数字链接到更多参考内容。

内核组件

这一部分中最严重的漏洞可让本地恶意应用通过特权进程执行任意代码。

CVE 参考编号 类型 严重程度 组件
CVE-2017-9077 A-62265013
上游内核
EoP 网络子系统
CVE-2017-7541 A-64258073
上游内核
EoP WLAN

MediaTek 组件

这一部分中最严重的漏洞可让本地恶意应用通过特权进程执行任意代码。

CVE 参考编号 类型 严重程度 组件
CVE-2017-0843 A-62670819*
M-ALPS03361488
EoP CCCI

NVIDIA 组件

这一部分中最严重的漏洞可让本地恶意应用通过特权进程执行任意代码。

CVE 参考编号 类型 严重程度 组件
CVE-2017-6264 A-34705430*
N-CVE-2017-6264
EoP GPU 驱动程序

Qualcomm 组件

这一部分中最严重的漏洞可让远程攻击者利用蓄意创建的文件在特权进程环境中执行任意代码。

CVE 参考编号 类型 严重程度 组件
CVE-2017-11013 A-64453535
QC-CR#2058261 [2]
RCE 严重 WLAN
CVE-2017-11015 A-64438728
QC-CR#2060959 [2]
RCE 严重 WLAN
CVE-2017-11014 A-64438727
QC-CR#2060959
RCE 严重 WLAN
CVE-2017-11092 A-62949902*
QC-CR#2077454
EoP GPU 驱动程序
CVE-2017-9690 A-36575870*
QC-CR#2045285
EoP QBT1000 驱动程序
CVE-2017-11017 A-64453575
QC-CR#2055629
EoP Linux 启动
CVE-2017-11028 A-64453533
QC-CR#2008683 [2]
ID 相机

2017-11-06 安全补丁级别 - 漏洞详情

我们在下面提供了 2017-11-06 补丁级别涵盖的每个安全漏洞的详细信息,漏洞分组列在所影响的组件下,内容包括 CVE、相关参考编号、漏洞类型严重程度、组件(若有)和已更新的 AOSP 版本(若有)等详细信息。在适用的情况下,我们会将 Bug ID 链接到解决相应问题的公开更改记录(如 AOSP 代码更改列表)。如果某个 Bug 有多条相关的更改记录,我们还将通过 Bug ID 后面的数字链接到更多参考内容。

系统

这一部分中最严重的漏洞可让邻近区域内的攻击者绕过用户互动要求,直接加入不安全的 Wi-Fi 网络。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2017-13077 A-67737262 EoP 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-13078 A-67737262 EoP 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-13079 A-67737262 EoP 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-13080 A-67737262 EoP 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-13081 A-67737262 EoP 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-13082 A-67737262 EoP 7.0、7.1.1、7.1.2、8.0
CVE-2017-13086 A-67737262 EoP 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-13087 A-67737262 EoP 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0
CVE-2017-13088 A-67737262 EoP 5.0.2、5.1.1、6.0、6.0.1、7.0、7.1.1、7.1.2、8.0

注意:Android 合作伙伴可能还需要从芯片组制造商处获取修复程序(如果适用)。

常见问题和解答

这一部分解答了用户在阅读本公告后可能会提出的常见问题。

1. 如何确定我的设备是否已通过更新解决这些问题?

如需了解如何查看设备的安全补丁级别,请参阅查看并更新 Android 版本

  • 如果安全补丁级别是 2017-11-01 或更新,则意味着已解决 2017-11-01 安全补丁级别涵盖的所有问题。
  • 如果安全补丁级别是 2017-11-05 或更新,则意味着已解决 2017-11-05 以及之前的所有安全补丁级别涵盖的所有问题。
  • 如果安全补丁级别是 2017-11-06 或更新,则意味着已解决 2017-11-06 以及之前的所有安全补丁级别涵盖的所有问题。

预装这些更新的设备制造商应将补丁字符串级别设为:

  • [ro.build.version.security_patch]:[2017-11-01]
  • [ro.build.version.security_patch]:[2017-11-05]
  • [ro.build.version.security_patch]:[2017-11-06]

2. 为何本公告有 3 个安全补丁级别?

本公告之所以有 3 个安全补丁级别,是为了让 Android 合作伙伴能够灵活地、更快速地修复在各种 Android 设备上类似的一系列漏洞。我们建议 Android 合作伙伴修复本公告中的所有问题并使用最新的安全补丁级别。

  • 使用 2017-11-01 安全补丁级别的设备必须包含该安全补丁级别对应的所有问题的修复方案,以及针对之前的安全公告中报告的所有问题的修复方案。
  • 使用 2017-11-05 安全补丁程序级别的设备必须包含该安全补丁程序级别、2017-11-01 安全补丁程序级别对应的所有问题的修复方案,以及针对之前的安全公告中报告的所有问题的修复方案。
  • 使用 2017-11-06 或更新的安全补丁级别的设备必须包含此(以及之前的)安全公告中的所有适用补丁。

我们建议合作伙伴把要解决的全部问题的修复程序打包到一个更新中。

3.“类型”列中的条目表示什么意思?

在漏洞详情表内,“类型”列中的条目是安全漏洞的分类。

缩写词 定义
RCE 远程代码执行
EoP 提权
ID 信息披露
DoS 拒绝服务攻击
N/A 没有分类

4. “参考编号”列中的条目表示什么意思?

在漏洞详情表内,“参考编号”列中的条目可能包含用于标识参考编号值所属组织的前缀。

前缀 参考编号
A- Android bug ID
QC- Qualcomm 参考编号
M- MediaTek 参考编号
N- NVIDIA 参考编号
B- Broadcom 参考编号

5. 在“参考编号”列中,Android bug ID 旁边的 * 表示什么意思?

如果问题尚未公开发布,在“参考编号”列中,相应 Android bug ID 旁边会显示 *。Google Developers 网站上针对 Nexus 设备提供的最新二进制驱动程序中通常包含旨在解决相应问题的更新。

6. 为什么要将安全漏洞拆分到本公告和设备 / 合作伙伴安全公告(如 Pixel / Nexus 公告)中?

要在 Android 设备上声明最新的安全补丁级别,必须修复本安全公告中记录的安全漏洞。 但在声明安全补丁级别时,并不是必须要修复设备/合作伙伴安全公告中记录的其他安全漏洞。 我们建议 Android 设备和芯片组制造商通过自己的安全网站(例如 SamsungLGEPixel/Nexus 安全公告)记录其设备上存在的其他修复程序。

版本

版本 日期 备注
1.0 2017 年 11 月 6 日 发布了本公告。
1.1 2017 年 11 月 8 日 修订了本公告,添加了 AOSP 链接。