Android Güvenlik Bülteni—Mayıs 2022

2 Mayıs 2022'de Yayınlandı | 3 Mayıs 2022'de güncellendi

Android Güvenlik Bülteni, Android cihazlarını etkileyen güvenlik açıklarının ayrıntılarını içerir. 2022-05-05 veya sonraki güvenlik yaması seviyeleri, tüm bu sorunları giderir. Bir cihazın güvenlik düzeltme eki düzeyini nasıl kontrol edeceğinizi öğrenmek için Android sürümünüzü kontrol edin ve güncelleyin bölümüne bakın.

Android iş ortaklarına, tüm sorunlar yayınlanmadan en az bir ay önce bildirilir. Bu sorunlar için kaynak kodu yamaları, önümüzdeki 48 saat içinde Android Açık Kaynak Projesi (AOSP) deposunda yayınlanacaktır. Bu bülteni, mevcut olduklarında AOSP bağlantıları ile revize edeceğiz.

Bu sorunların en şiddetlisi, Çerçeve bileşeninde, gereken Kullanıcı yürütme ayrıcalıklarıyla yerel düzeyde ayrıcalık yükselmesine yol açabilecek bir yüksek güvenlik açığıdır. Önem derecesi değerlendirmesi , platform ve hizmet azaltmalarının geliştirme amacıyla kapatıldığı veya başarılı bir şekilde atlandığı varsayılarak, güvenlik açığından yararlanmanın muhtemelen etkilenen bir cihaz üzerindeki etkisine dayanır.

Android platformunun güvenliğini artıran Android güvenlik platformu korumaları ve Google Play Protect ile ilgili ayrıntılar için Android ve Google Play Protect azaltıcı etkenler bölümüne bakın.

Android ve Google hizmet azaltmaları

Bu, Android güvenlik platformu ve Google Play Protect gibi hizmet korumaları tarafından sağlanan azaltmaların bir özetidir. Bu yetenekler, güvenlik açıklarından Android'de başarıyla yararlanma olasılığını azaltır.

  • Android platformunun daha yeni sürümlerinde yapılan geliştirmeler sayesinde Android'deki birçok sorundan yararlanma daha zor hale getirildi. Tüm kullanıcıları, mümkün olduğunda Android'in en son sürümüne güncellemeye teşvik ediyoruz.
  • Android güvenlik ekibi, Google Play Protect aracılığıyla kötüye kullanımı etkin bir şekilde izler ve kullanıcıları Zararlı Olabilecek Uygulamalar hakkında uyarır. Google Play Protect, Google Mobil Hizmetleri bulunan cihazlarda varsayılan olarak etkindir ve özellikle Google Play dışından uygulama yükleyen kullanıcılar için önemlidir.

2022-05-01 güvenlik yaması düzeyinde güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2022-05-01 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sağlıyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılmıştır. Sorunlar aşağıdaki tablolarda açıklanmıştır ve CVE Kimliği, ilgili referanslar, güvenlik açığı türü , önem derecesi ve güncellenmiş AOSP sürümlerini (varsa) içerir. Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır. Android 10 ve sonraki sürümlere sahip cihazlar, Google Play sistem güncellemelerinin yanı sıra güvenlik güncellemelerini de alabilir.

Çerçeve

Bu bölümdeki en ciddi güvenlik açığı, gereken Kullanıcı yürütme ayrıcalıklarıyla yerel düzeyde ayrıcalık yükselmesine neden olabilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2021-39662 A-197302116 EoP Yüksek 11, 12
CVE-2022-20004 A-179699767 EoP Yüksek 10, 11, 12, 12L
CVE-2022-20005 A-219044664 EoP Yüksek 10, 11, 12, 12L
CVE-2022-20007 A-211481342 EoP Yüksek 10, 11, 12, 12L
CVE-2021-39700 A-201645790 İD Ilıman 10, 11, 12

sistem

Bu bölümdeki en ciddi güvenlik açığı, ek yürütme ayrıcalığına gerek kalmadan yerel ayrıcalığın yükseltilmesine neden olabilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2022-20113 A-205996517 EoP Yüksek 12, 12L
CVE-2022-114 A-211114016 EoP Yüksek 10, 11, 12, 12L
CVE-2022-20116 A-212467440 EoP Yüksek 12, 12L
CVE-2022-20010 A-213519176 İD Yüksek 12, 12L
CVE-2022-20011 A-214999128 İD Yüksek 10, 11, 12, 12L
CVE-2022-115 A-210118427 İD Yüksek 12, 12L
CVE-2021-39670 A-204087139 DoS Yüksek 12, 12L
CVE-2022-20112 A-206987762 DoS Yüksek 10, 11, 12, 12L

Google Play sistem güncellemeleri

Aşağıdaki sorunlar Project Mainline bileşenlerine dahil edilmiştir.

Bileşen CVE
Medya Sağlayıcı CVE-2021-39662

2022-05-05 güvenlik yaması düzeyinde güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2022-05-05 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sağlıyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılmıştır. Sorunlar aşağıdaki tablolarda açıklanmıştır ve CVE Kimliği, ilgili referanslar, güvenlik açığı türü , önem derecesi ve güncellenmiş AOSP sürümlerini (varsa) içerir. Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır.

çekirdek bileşenleri

Bu bölümdeki en ciddi güvenlik açığı, sistem kitaplıklarında ek yürütme ayrıcalıklarına gerek kalmadan yerel ayrıcalık yükselmesine neden olabilir.

CVE Referanslar Tip önem Bileşen
CVE-2022-0847 A-220741611
Yukarı akış çekirdeği [ 2 ] [ 3 ]
EoP Yüksek borular
CVE-2022-20009 A-213172319
Yukarı akış çekirdeği [ 2 ]
EoP Yüksek Linux
CVE-2022-20008 A-216481035
Yukarı akış çekirdeği [ 2 ] [ 3 ]
İD Yüksek SD MMC
CVE-2021-22600 A-213464034
yukarı akış çekirdeği
EoP Ilıman Çekirdek

MediaTek bileşenleri

Bu güvenlik açıkları MediaTek bileşenlerini etkiler ve daha fazla ayrıntı doğrudan MediaTek'ten edinilebilir. Bu sorunların önem derecesi değerlendirmesi doğrudan MediaTek tarafından sağlanır.

CVE Referanslar önem Bileşen
CVE-2022-20084 A-223071148
M-ALPS06498874 *
Yüksek telefon
CVE-2022-109 A-223072269
M-ALPS06399915 *
Yüksek iyon
CVE-2022-20110 A-223071150
M-ALPS06399915 *
Yüksek iyon

Qualcomm bileşenleri

Bu güvenlik açıkları Qualcomm bileşenlerini etkiler ve uygun Qualcomm güvenlik bülteninde veya güvenlik uyarısında daha ayrıntılı olarak açıklanmıştır. Bu sorunların önem derecesi değerlendirmesi doğrudan Qualcomm tarafından sağlanır.

CVE Referanslar önem Bileşen
CVE-2022-22057 A-218337595
QC-CR#3077687
Yüksek Görüntülemek
CVE-2022-22064 A-218338071
QC-CR#3042282
QC-CR#3048959
QC-CR#3056532
QC-CR#3049158 [ 2 ]
Yüksek WLAN
CVE-2022-22065 A-218337597
QC-CR#3042293
QC-CR#3064612
Yüksek WLAN
CVE-2022-22068 A-218337596
QC-CR#3084983 [ 2 ]
Yüksek Çekirdek
CVE-2022-22072 A-218339149
QC-CR#3073345 [ 2 ]
Yüksek WLAN

Qualcomm kapalı kaynak bileşenleri

Bu güvenlik açıkları Qualcomm kapalı kaynak bileşenlerini etkiler ve uygun Qualcomm güvenlik bülteninde veya güvenlik uyarısında daha ayrıntılı olarak açıklanır. Bu sorunların önem derecesi değerlendirmesi doğrudan Qualcomm tarafından sağlanır.

CVE Referanslar önem Bileşen
CVE-2021-35090 A-204905205 ​​* kritik Kapalı kaynak bileşeni
CVE-2021-35072 A-204905110 * Yüksek Kapalı kaynak bileşeni
CVE-2021-35073 A-204905209 * Yüksek Kapalı kaynak bileşeni
CVE-2021-35076 A-204905151 * Yüksek Kapalı kaynak bileşeni
CVE-2021-35078 A-204905326 * Yüksek Kapalı kaynak bileşeni
CVE-2021-35080 A-204905287 * Yüksek Kapalı kaynak bileşeni
CVE-2021-35086 A-204905289 * Yüksek Kapalı kaynak bileşeni
CVE-2021-35087 A-204905111 * Yüksek Kapalı kaynak bileşeni
CVE-2021-35094 A-204905838 * Yüksek Kapalı kaynak bileşeni
CVE-2021-35096 A-204905290 * Yüksek Kapalı kaynak bileşeni
CVE-2021-35116 A-209469826 * Yüksek Kapalı kaynak bileşeni

Çekirdek LTS

Aşağıdaki tablo, Güvenlik Düzeltme Eki Düzeyi uyumluluğu için minimum çekirdek sürümü gereksinimini açıklar. Android Başlatma Sürümü, başlatma sırasında cihazda bulunan Android işletim sisteminin sürümünü ifade eder ve çekirdek sürümü, şu anda cihazda bulunan Linux çekirdeğinin sürümünü ifade eder.

Referanslar Android İşletim Sistemi Başlatma Sürümü Çekirdek sürümü Minimum Güncelleme Sürümü
A-202441831 11 5.4 5.4.147
A-204345773 12 5.4 5.4.147

Sık sorulan sorular ve cevaplar

Bu bölüm, bu bülteni okuduktan sonra ortaya çıkabilecek genel soruları yanıtlamaktadır.

1. Cihazımın bu sorunları gidermek için güncellenip güncellenmediğini nasıl belirleyebilirim?

Bir cihazın güvenlik düzeltme eki düzeyini nasıl kontrol edeceğinizi öğrenmek için Android sürümünüzü kontrol edin ve güncelleyin bölümüne bakın.

  • 2022-05-01 veya sonraki güvenlik yaması seviyeleri, 2022-05-01 güvenlik yaması seviyesiyle ilgili tüm sorunları ele alır.
  • 2022-05-05 veya sonraki güvenlik yaması seviyeleri, 2022-05-05 güvenlik yaması seviyesi ve önceki tüm yama seviyeleri ile ilgili tüm sorunları ele alır.

Bu güncellemeleri içeren cihaz üreticileri, yama dizesi düzeyini şu şekilde ayarlamalıdır:

  • [ro.build.version.security_patch]:[2022-05-01]
  • [ro.build.version.security_patch]:[2022-05-05]

Android 10 veya sonraki sürümlerdeki bazı cihazlar için Google Play sistem güncellemesi, 2022-05-01 güvenlik yaması düzeyiyle eşleşen bir tarih dizisine sahip olacaktır. Güvenlik güncellemelerinin nasıl yükleneceği hakkında daha fazla ayrıntı için lütfen bu makaleye bakın.

2. Bu bültende neden iki güvenlik düzeltme eki düzeyi var?

Bu bültende, Android iş ortaklarının tüm Android cihazlarda benzer olan bir dizi güvenlik açığını daha hızlı düzeltme esnekliğine sahip olması için iki güvenlik düzeltme eki düzeyi vardır. Android iş ortaklarının bu bültendeki tüm sorunları düzeltmeleri ve en son güvenlik düzeltme eki düzeyini kullanmaları önerilir.

  • 2022-05-01 güvenlik yaması düzeyini kullanan cihazlar, bu güvenlik yaması düzeyiyle ilişkili tüm sorunları ve önceki güvenlik bültenlerinde bildirilen tüm sorunlara yönelik düzeltmeleri içermelidir.
  • 2022-05-05 veya daha yeni güvenlik yaması düzeyini kullanan cihazlar, bu (ve önceki) güvenlik bültenlerinde geçerli tüm yamaları içermelidir.

İş ortaklarının, ele aldıkları tüm sorunlara yönelik düzeltmeleri tek bir güncellemede toplamaları önerilir.

3. Tür sütunundaki girişler ne anlama geliyor?

Güvenlik açığı ayrıntıları tablosunun Tür sütunundaki girişler, güvenlik açığının sınıflandırmasına başvurur.

Kısaltma Tanım
RCE Uzaktan kod yürütme
EoP Ayrıcalığın yükseltilmesi
İD Bilgi ifşası
DoS hizmet reddi
Yok Sınıflandırma mevcut değil

4. Referanslar sütunundaki girişler ne anlama geliyor?

Güvenlik açığı ayrıntıları tablosunun Referanslar sütunu altındaki girişler, referans değerinin ait olduğu kuruluşu tanımlayan bir önek içerebilir.

Önek Referans
A- Android hata kimliği
KK- Qualcomm referans numarası
M- MediaTek referans numarası
N- NVIDIA referans numarası
B- Broadcom referans numarası
U- UNISOC referans numarası

5. Referanslar sütunundaki Android hata kimliğinin yanında * işareti ne anlama gelir?

Herkese açık olmayan sorunlarda, ilgili referans kimliğinin yanında * bulunur. Bu soruna ilişkin güncelleme genellikle, Google Developer sitesinde bulunan Pixel cihazları için en son ikili sürücülerinde bulunur.

6. Güvenlik açıkları neden bu bülten ile Pixel bülteni gibi cihaz/iş ortağı güvenlik bültenleri arasında bölünmüştür?

Bu güvenlik bülteninde belgelenen güvenlik açıkları, Android cihazlarda en son güvenlik düzeltme eki düzeyinin bildirilmesi için gereklidir. Cihaz/ortak güvenlik bültenlerinde belgelenen ek güvenlik açıkları, bir güvenlik yaması düzeyi bildirmek için gerekli değildir. Android cihaz ve yonga seti üreticileri de Google , Huawei , LGE , Motorola , Nokia veya Samsung gibi ürünlerine özel güvenlik açığı ayrıntılarını yayınlayabilir.

Sürümler

sürüm Tarih notlar
1.0 2 Mayıs 2022 Bülten Yayınlandı
1.1 3 Mayıs 2022 Bülten, AOSP bağlantılarını içerecek şekilde revize edildi