Android Güvenlik Bülteni—Nisan 2019

1 Nisan 2019'da yayınlandı | 3 Nisan 2019'da güncellendi

Android Güvenlik Bülteni, Android cihazları etkileyen güvenlik açıklarının ayrıntılarını içerir. 2019-04-05 veya sonraki güvenlik düzeltme eki düzeyleri tüm bu sorunları giderir. Bir cihazın güvenlik yaması düzeyini nasıl kontrol edeceğinizi öğrenmek için bkz. Android sürümünüzü kontrol etme ve güncelleme .

Android iş ortaklarına tüm sorunlar yayınlanmadan en az bir ay önce bildirilir. Bu sorunlara ilişkin kaynak kodu yamaları Android Açık Kaynak Projesi (AOSP) deposunda yayımlandı ve bu bültenden bağlantı verildi. Bu bülten aynı zamanda AOSP dışındaki yamalara bağlantılar da içermektedir.

Bu sorunlardan en ciddi olanı, medya çerçevesindeki, uzaktaki bir saldırganın özel hazırlanmış bir dosya kullanarak ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak tanıyan kritik bir güvenlik açığıdır. Önem derecesi değerlendirmesi, platformun ve hizmet azaltımlarının geliştirme amacıyla kapatıldığı veya başarılı bir şekilde atlandığı varsayılarak, güvenlik açığından yararlanmanın etkilenen cihaz üzerinde yaratabileceği etkiye dayanmaktadır.

Yeni bildirilen bu sorunların aktif müşteri istismarına veya kötüye kullanıldığına dair herhangi bir rapor almadık. Android güvenlik platformu korumaları ve Android platformunun güvenliğini artıran Google Play Koruma hakkında ayrıntılar için Android ve Google Play Koruma azaltımları bölümüne bakın.

Not: Google cihazları için en son kablosuz güncelleme (OTA) güncellemesi ve donanım yazılımı görüntülerine ilişkin bilgiler Nisan 2019 Piksel Güncelleme Bülteni'nde mevcuttur.

Android ve Google hizmet azaltımları

Bu, Android güvenlik platformu ve Google Play Koruma gibi hizmet korumaları tarafından sağlanan azaltıcı önlemlerin bir özetidir. Bu yetenekler, Android'de güvenlik açıklarından başarıyla yararlanma olasılığını azaltır.

  • Android platformunun daha yeni sürümlerindeki iyileştirmeler, Android'deki birçok sorundan yararlanmayı daha da zorlaştırıyor. Tüm kullanıcılarımızı mümkün olduğunca Android'in en son sürümüne güncelleme yapmaya teşvik ediyoruz.
  • Android güvenlik ekibi , Google Play Koruma aracılığıyla kötüye kullanımı aktif olarak izler ve kullanıcıları Potansiyel Zararlı Uygulamalar konusunda uyarır. Google Play Koruma, Google Mobil Hizmetleri bulunan cihazlarda varsayılan olarak etkindir ve özellikle Google Play dışından uygulama yükleyen kullanıcılar için önemlidir.

2019-04-01 güvenlik yaması düzeyindeki güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2019-04-01 yama düzeyi için geçerli olan güvenlik açıklarının her birine ilişkin ayrıntılar sağlıyoruz. Güvenlik açıkları etkiledikleri bileşene göre gruplandırılır. Sorunun bir açıklaması ve CVE'yi, ilgili referansları, güvenlik açığı türünü , ciddiyetini ve güncellenmiş AOSP sürümlerini (varsa) içeren bir tablo bulunmaktadır. Mümkün olduğunda, sorunu gideren genel değişikliği, AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, ek referanslar hata kimliğini takip eden numaralara bağlanır.

Çerçeve

Bu bölümdeki güvenlik açığı, yerel bir saldırganın kullanıcı etkileşimi ile ek izinleri atlamasına olanak tanıyabilir.

CVE Referanslar Tip Şiddet Güncellenmiş AOSP sürümleri
CVE-2019-2026 A-120866126 * EoP Yüksek 8.0

Medya çerçevesi

Bu bölümdeki en ciddi güvenlik açığı, uzaktaki bir saldırganın özel hazırlanmış bir dosya kullanarak ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tip Şiddet Güncellenmiş AOSP sürümleri
CVE-2019-2027 A-119120561 RCE Kritik 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2028 A-120644655 RCE Kritik 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9

Sistem

Bu bölümdeki en ciddi güvenlik açığı, yerel kötü amaçlı bir uygulamanın ayrıcalıklı bir işlem bağlamında rastgele kod yürütmesine olanak tanıyabilir.

CVE Referanslar Tip Şiddet Güncellenmiş AOSP sürümleri
CVE-2019-2030 A-119496789 EoP Yüksek 9
CVE-2019-2031 A-120502559 EoP Yüksek 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2033 A-121327565 [ 2 ] EoP Yüksek 9
CVE-2019-2034 A-122035770 EoP Yüksek 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2035 A-122320256 EoP Yüksek 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2038 A-121259048 İD Yüksek 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2039 A-121260197 İD Yüksek 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2040 A-122316913 İD Yüksek 9

2019-04-05 güvenlik yaması düzeyindeki güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2019-04-05 yama düzeyi için geçerli olan güvenlik açıklarının her birine ilişkin ayrıntılar sağlıyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılır ve CVE, ilgili referanslar, güvenlik açığı türü , önem derecesi , bileşen (varsa) ve güncellenmiş AOSP sürümleri (varsa) gibi ayrıntıları içerir. Mümkün olduğunda, sorunu gideren genel değişikliği, AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, ek referanslar hata kimliğini takip eden numaralara bağlanır.

Sistem

Bu bölümdeki en ciddi güvenlik açığı, uzaktaki bir saldırganın özel hazırlanmış bir dosya kullanarak ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tip Şiddet Güncellenmiş AOSP sürümleri
CVE-2019-2029 A-120612744 RCE Kritik 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2032 A-121145627 EoP Yüksek 8.0, 8.1, 9
CVE-2019-2041 A-122034690 [ 2 ] [ 3 ] EoP Yüksek 8.1, 9
CVE-2019-2037 A-119870451 İD Yüksek 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9

Qualcomm bileşenleri

Bu güvenlik açıkları Qualcomm bileşenlerini etkiler ve uygun Qualcomm güvenlik bülteninde veya güvenlik uyarısında daha ayrıntılı olarak açıklanır. Bu düzeltmelerin çoğunluğu 2018'de yayınlanan Qualcomm güvenlik bültenlerinde bulunabilir. Bu sorunların önem derecesi değerlendirmesi doğrudan Qualcomm tarafından sağlanır.

CVE Referanslar Tip Şiddet Bileşen
CVE-2018-11940 A-79377832
QC-CR#2254946
Yok Kritik WLAN SUNUCUSU
CVE-2017-17772 A-72957385
QC-CR#2153003 [ 2 ]
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11294 A-109741680
QC-CR#2197481
Yok Yüksek WLAN SUNUCUSU
CVE-2018-5855 A-77527719
QC-CR#2193421
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11299 A-109741946
QC-CR#2186953
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11826 A-111127853
QC-CR#2205957
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11827 A-111128575
QC-CR#2206569
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11840 A-111126050
QC-CR#2215443
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11851 A-111125792
QC-CR#2221902
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11860 A-111128301
QC-CR#2225113
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11868 A-111128420
QC-CR#2227248
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11869 A-111128838
QC-CR#2227263
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11878 A-111128797
QC-CR#2228608
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11889 A-111128421
QC-CR#2230998
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11891 A-111128578
QC-CR#2231767
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11894 A-111127989
QC-CR#2232358
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11895 A-111128877
QC-CR#2232542
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11897 A-111128841
QC-CR#2233033
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11902 A-111126532
QC-CR#2225604
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11904 A-111125111
QC-CR#2215446
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11905 A-112277221
QC-CR#2146878
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11923 A-112276863
QC-CR#2224443
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11924 A-112278150
QC-CR#2224451
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11925 A-112277910
QC-CR#2226375 [ 2 ]
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11927 A-112277186
QC-CR#2227076
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11930 A-112278861
QC-CR#2231770
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11937 A-112277891
QC-CR#2245944
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11949 A-112278405
QC-CR#2249815
Yok Yüksek WLAN SUNUCUSU
CVE-2018-11953 A-112277852
QC-CR#2235576
Yok Yüksek WLAN SUNUCUSU
CVE-2018-13920 A-120487136 *
QC-CR#2293841
Yok Yüksek Çekirdek

Qualcomm kapalı kaynak bileşenleri

Bu güvenlik açıkları Qualcomm bileşenlerini etkiler ve uygun Qualcomm güvenlik bülteninde veya güvenlik uyarısında daha ayrıntılı olarak açıklanır. Bu sorunların ciddiyet değerlendirmesi doğrudan Qualcomm tarafından sağlanır.

CVE Referanslar Tip Şiddet Bileşen
CVE-2018-11271 A-120487384 * Yok Kritik Kapalı kaynak bileşeni
CVE-2018-11976 A-117119000 * Yok Kritik Kapalı kaynak bileşeni
CVE-2018-12004 A-117118976 * Yok Kritik Kapalı kaynak bileşeni
CVE-2018-13886 A-117118295 * Yok Kritik Kapalı kaynak bileşeni
CVE-2018-13887 A-117119172 * Yok Kritik Kapalı kaynak bileşeni
CVE-2019-2250 A-122473270 * Yok Kritik Kapalı kaynak bileşeni
CVE-2018-11291 A-109678120 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11821 A-111093019 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11822 A-111092813 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11828 A-111089816 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11849 A-111092945 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11850 A-111092919 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11853 A-111091938 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11854 A-111093762 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11856 A-111093242 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11859 A-111090373 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11861 A-111092814 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11862 A-111093763 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11867 A-111093243 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11870 A-111089817 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11871 A-111092400 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11872 A-111090534 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11873 A-111091378 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11874 A-111092946 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11875 A-111093022 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11876 A-111093244 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11877 A-111092888 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11879 A-111093280 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11880 A-111092401 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11882 A-111093259 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11884 A-111090535 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11928 A-112279580 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11936 A-112279127 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11967 A-119049704 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11967 A-119052960 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-11968 A-114042276 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-12005 A-117118499 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-12012 A-117119174 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-12013 A-117119152 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-13885 A-117118789 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-13895 A-122472377 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2018-13925 A-120483842 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2019-2244 A-122472139 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2019-2245 A-122473145 * Yok Yüksek Kapalı kaynak bileşeni

Ortak sorular ve cevaplar

Bu bölüm, bu bülteni okuduktan sonra ortaya çıkabilecek genel soruları yanıtlar.

1. Cihazımın bu sorunları çözecek şekilde güncellenip güncellenmediğini nasıl belirleyebilirim?

Bir cihazın güvenlik yaması düzeyini nasıl kontrol edeceğinizi öğrenmek için bkz. Android sürümünüzü kontrol etme ve güncelleme .

  • 01.04.2019 veya sonraki güvenlik yaması düzeyleri, 01.04.2019 güvenlik yaması düzeyiyle ilişkili tüm sorunları giderir.
  • 05.04.2019 veya üzeri güvenlik yaması düzeyleri, 05.04.2019 güvenlik yaması düzeyi ve önceki tüm yama düzeyleriyle ilişkili tüm sorunları giderir.

Bu güncellemeleri içeren cihaz üreticileri yama dizesi düzeyini şu şekilde ayarlamalıdır:

  • [ro.build.version.security_patch]:[2019-04-01]
  • [ro.build.version.security_patch]:[2019-04-05]

2. Bu bültende neden iki güvenlik yaması düzeyi var?

Bu bültenin iki güvenlik düzeltme eki düzeyi vardır; böylece Android iş ortakları, tüm Android cihazlarda benzer olan bir dizi güvenlik açığını daha hızlı düzeltme esnekliğine sahip olur. Android iş ortaklarının bu bültendeki tüm sorunları düzeltmeleri ve en son güvenlik yaması düzeyini kullanmaları önerilir.

  • 01.04.2019 güvenlik yaması düzeyini kullanan cihazlar, söz konusu güvenlik yaması düzeyiyle ilişkili tüm sorunların yanı sıra önceki güvenlik bültenlerinde bildirilen tüm sorunlara yönelik düzeltmeleri de içermelidir.
  • 2019-04-05 veya daha yeni güvenlik düzeltme eki düzeyini kullanan cihazlar, bu (ve önceki) güvenlik bültenlerinde geçerli tüm düzeltme eklerini içermelidir.

İş ortaklarının, ele aldıkları tüm sorunlara yönelik düzeltmeleri tek bir güncellemede toplamaları önerilir.

3. Tür sütunundaki girişler ne anlama geliyor?

Güvenlik açığı ayrıntıları tablosunun Tür sütunundaki girişler, güvenlik açığının sınıflandırmasına atıfta bulunur.

Kısaltma Tanım
RCE Uzaktan kod yürütme
EoP Ayrıcalığın yükselmesi
İD Bilgi ifşası
DoS Hizmet reddi
Yok Sınıflandırma mevcut değil

4. Referanslar sütunundaki girişler ne anlama geliyor?

Güvenlik açığı ayrıntıları tablosunun Referanslar sütunu altındaki girişler, referans değerinin ait olduğu kuruluşu tanımlayan bir önek içerebilir.

Önek Referans
A- Android hata kimliği
Kalite kontrol- Qualcomm referans numarası
M- MediaTek referans numarası
N- NVIDIA referans numarası
B- Broadcom referans numarası

5. Referanslar sütununda Android hata kimliğinin yanındaki * işareti ne anlama gelir?

Herkese açık olmayan sorunların Referanslar sütununda Android hata kimliğinin yanında * işareti bulunur. Bu soruna ilişkin güncelleme genellikle Google Geliştirici sitesinde bulunan Pixel cihazlara yönelik en son ikili program sürücülerinde bulunur.

6. Güvenlik açıkları neden bu bülten ile Pixel bülteni gibi cihaz/iş ortağı güvenlik bültenleri arasında bölünmüş durumda?

Bu güvenlik bülteninde belgelenen güvenlik açıklarının, Android cihazlarda en son güvenlik yaması düzeyinin bildirilmesi gerekmektedir. Cihaz/iş ortağı güvenlik bültenlerinde belgelenen ek güvenlik açıkları, güvenlik yaması düzeyinin bildirilmesi için gerekli değildir. Android cihaz ve yonga seti üreticilerinin, cihazlarındaki diğer düzeltmelerin varlığını Samsung , LGE veya Pixel güvenlik bültenleri gibi kendi güvenlik web siteleri aracılığıyla belgelemeleri teşvik edilmektedir.

Sürümler

Sürüm Tarih Notlar
1.0 1 Nisan 2019 Bülten yayınlandı
1.1 3 Nisan 2019 Bülten, AOSP bağlantılarını içerecek şekilde revize edildi