بولتن امنیتی اندروید - ژوئن 2019

منتشر شده در 3 ژوئن 2019 | به روز شده در 5 ژوئن 2019

بولتن امنیتی اندروید حاوی جزئیاتی از آسیب پذیری های امنیتی است که بر دستگاه های اندرویدی تأثیر می گذارد. سطوح وصله امنیتی 2019-06-05 یا بالاتر همه این مشکلات را برطرف می کند. برای یادگیری نحوه بررسی سطح وصله امنیتی دستگاه، به نحوه بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

شرکای Android حداقل یک ماه قبل از انتشار از همه مشکلات مطلع می شوند. وصله کد منبع برای این مشکلات در مخزن پروژه منبع باز Android (AOSP) منتشر شده و از این بولتن پیوند داده شده است. این بولتن همچنین شامل پیوندهایی به وصله های خارج از AOSP است.

شدیدترین این مسائل یک آسیب پذیری امنیتی حیاتی در چارچوب Media است که می تواند یک مهاجم راه دور را با استفاده از یک فایل ساخته شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند. ارزیابی شدت بر اساس تأثیری است که بهره‌برداری از آسیب‌پذیری احتمالاً روی دستگاه آسیب‌دیده می‌گذارد، با این فرض که پلت‌فرم و تخفیف‌های سرویس برای اهداف توسعه خاموش شده‌اند یا در صورت دور زدن موفقیت‌آمیز انجام شوند.

ما هیچ گزارشی مبنی بر بهره برداری یا سوء استفاده فعال مشتری از این مشکلات گزارش شده جدید نداشته ایم. برای جزئیات بیشتر در مورد حفاظت های پلتفرم امنیتی اندروید و Google Play Protect که امنیت پلتفرم اندروید را بهبود می بخشد، به بخش تخفیف های خدمات Android و Google مراجعه کنید.

توجه: اطلاعات مربوط به آخرین به‌روزرسانی خارج از هوا (OTA) و تصاویر میان‌افزار دستگاه‌های Google در بولتن به‌روزرسانی پیکسل ژوئن 2019 موجود است.

کاهش خدمات اندروید و گوگل

این خلاصه‌ای از کاهش‌های ارائه شده توسط پلتفرم امنیتی Android و محافظت‌های خدماتی مانند Google Play Protect است. این پیشرفت‌های امنیتی احتمال سوء استفاده موفقیت‌آمیز از آسیب‌پذیری‌های امنیتی در اندروید را کاهش می‌دهد.

  • بهره برداری از بسیاری از مسائل در اندروید با پیشرفت در نسخه های جدیدتر پلتفرم اندروید دشوارتر شده است. ما همه کاربران را تشویق می کنیم تا در صورت امکان به آخرین نسخه اندروید بروزرسانی کنند.
  • تیم امنیتی Android به طور فعال از طریق Google Play Protect برای سوء استفاده نظارت می کند و به کاربران در مورد برنامه های بالقوه مضر هشدار می دهد. Google Play Protect به طور پیش‌فرض در دستگاه‌های دارای سرویس‌های Google Mobile فعال است و به ویژه برای کاربرانی که برنامه‌هایی را از خارج از Google Play نصب می‌کنند، مهم است.

جزئیات آسیب‌پذیری سطح وصله امنیتی 01/06/2019

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی را که در سطح وصله 01-06-2019 اعمال می‌شود، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. شرحی از مشکل و جدولی با CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت و نسخه‌های به‌روزرسانی‌شده AOSP (در صورت لزوم) وجود دارد. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

چارچوب

شدیدترین آسیب پذیری در این بخش می تواند یک برنامه مخرب محلی را قادر سازد تا الزامات تعامل کاربر را برای دسترسی به مجوزهای اضافی دور بزند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2019-2090 الف-128599183 EoP بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-2091 الف-128599660 EoP بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1
CVE-2019-2092 الف-128599668 EoP بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9

چارچوب رسانه ای

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک فایل ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2019-2093 الف-119292397 RCE بحرانی 9
CVE-2019-2094 الف-129068792 RCE بحرانی 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-2095 الف-124232283 RCE بحرانی 9
CVE-2019-2096 A-123237974 [ 2 ] EoP بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک فایل PAC ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2019-2097 الف-117606285 RCE بحرانی 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-2102 الف-128843052 EoP بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-2098 الف-128599467 EoP بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-2099 الف-123583388 EoP بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9

جزئیات آسیب پذیری سطح وصله امنیتی 05/06/2019

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی مربوط به سطح وصله ۰۵-۰۶-۲۰۱۹ را ارائه می‌کنیم. آسیب‌پذیری‌ها تحت مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند و شامل جزئیاتی مانند CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت ، مؤلفه (در صورت لزوم) و نسخه‌های به‌روزشده AOSP (در صورت لزوم) می‌شوند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

چارچوب

آسیب‌پذیری در این بخش می‌تواند منجر به افشای اطلاعات از راه دور بدون نیاز به امتیازات اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2018-9526 A-112159033 [ 2 ] [ 3 ] [ 4 ] شناسه بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9

اجزای هسته

آسیب‌پذیری در این بخش می‌تواند یک برنامه مخرب محلی را قادر سازد تا از حفاظت‌های سیستم عاملی که داده‌های برنامه را از سایر برنامه‌ها جدا می‌کند دور بزند.

CVE منابع تایپ کنید شدت مولفه
CVE-2019-2101 A-111760968 * شناسه بالا درایور UVC

قطعات کوالکام

این آسیب‌پذیری‌ها بر اجزای کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع تایپ کنید شدت مولفه
CVE-2019-2269 الف-123700924
QC-CR#2264429
N/A بحرانی میزبان WLAN
CVE-2019-2287 الف-114399807
QC-CR#2368791 [ 2 ]
N/A بحرانی ویدیو
CVE-2019-2260 الف-123999895
QC-CR#2294824
N/A بالا هسته
CVE-2019-2292 الف-127513046
QC-CR#2327688
QC-CR#2333042
N/A بالا میزبان WLAN

اجزای منبع بسته کوالکام

این آسیب‌پذیری‌ها بر اجزای منبع بسته کوالکام تأثیر می‌گذارند و در بولتن امنیتی یا هشدار امنیتی مناسب کوالکام با جزئیات بیشتر توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع تایپ کنید شدت مولفه
CVE-2018-13924 A-120486477 * N/A بحرانی جزء منبع بسته
CVE-2018-13927 A-120485121 * N/A بحرانی جزء منبع بسته
CVE-2018-13896 A-120487163 * N/A بالا جزء منبع بسته
CVE-2019-2243 الف-122473494 * N/A بالا جزء منبع بسته
CVE-2019-2261 A-123998003 * N/A بالا جزء منبع بسته

پرسش و پاسخ متداول

این بخش به سوالات متداولی که ممکن است پس از خواندن این بولتن رخ دهد پاسخ می دهد.

1. چگونه تشخیص دهم که آیا دستگاه من برای رفع این مشکلات به روز شده است؟

برای یادگیری نحوه بررسی سطح وصله امنیتی دستگاه، به نحوه بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

  • سطوح وصله امنیتی 2019-06-01 یا بالاتر، تمام مسائل مرتبط با سطح وصله امنیتی 2019-06-01 را برطرف می کند.
  • سطوح وصله امنیتی 2019-06-05 یا بالاتر، تمام مسائل مرتبط با سطح وصله امنیتی 2019-06-05 و تمام سطوح وصله قبلی را برطرف می کند.

سازندگان دستگاه‌هایی که شامل این به‌روزرسانی‌ها می‌شوند باید سطح رشته وصله را روی موارد زیر تنظیم کنند:

  • [ro.build.version.security_patch]:[2019-06-01]
  • [ro.build.version.security_patch]:[2019-06-05]

2. چرا این بولتن دارای دو سطح وصله امنیتی است؟

این بولتن دارای دو سطح وصله امنیتی است تا شرکای Android انعطاف پذیری لازم را داشته باشند تا زیرمجموعه ای از آسیب پذیری ها را که در همه دستگاه های اندرویدی مشابه هستند با سرعت بیشتری برطرف کنند. شرکای Android تشویق می شوند تا تمام مشکلات موجود در این بولتن را برطرف کنند و از آخرین سطح وصله امنیتی استفاده کنند.

  • دستگاه‌هایی که از سطح وصله امنیتی 2019-06-01 استفاده می‌کنند باید همه مشکلات مرتبط با آن سطح وصله امنیتی و همچنین رفع تمام مشکلات گزارش‌شده در بولتن‌های امنیتی قبلی را داشته باشند.
  • دستگاه‌هایی که از سطح وصله امنیتی 2019-06-05 یا جدیدتر استفاده می‌کنند، باید همه وصله‌های قابل‌اجرا در این بولتن‌های امنیتی (و قبلی) را شامل شوند.

شرکا تشویق می شوند تا اصلاحات مربوط به همه مشکلاتی را که در حال رفع آنها هستند در یک به روز رسانی واحد جمع کنند.

3. ورودی های ستون Type به چه معناست؟

ورودی های ستون نوع جدول جزئیات آسیب پذیری به طبقه بندی آسیب پذیری امنیتی اشاره دارد.

مخفف تعریف
RCE اجرای کد از راه دور
EoP بالا بردن امتیاز
شناسه افشای اطلاعات
DoS خود داری از خدمات
N/A طبقه بندی در دسترس نیست

4. ورودی های ستون References به چه معناست؟

ورودی‌های زیر ستون مراجع جدول جزئیات آسیب‌پذیری ممکن است حاوی پیشوندی باشد که سازمانی را که مقدار مرجع به آن تعلق دارد، مشخص می‌کند.

پیشوند ارجاع
آ- شناسه باگ اندروید
QC- شماره مرجع کوالکام
M- شماره مرجع مدیاتک
N- شماره مرجع NVIDIA
ب- شماره مرجع Broadcom

5. یک * در کنار شناسه باگ اندروید در ستون References به چه معناست؟

مسائلی که به صورت عمومی در دسترس نیستند دارای یک * در کنار شناسه اشکال Android در ستون References هستند. به‌روزرسانی برای آن مشکل عموماً در آخرین درایورهای باینری دستگاه‌های Pixel موجود در سایت Google Developer موجود است.

6. چرا آسیب‌پذیری‌های امنیتی بین این بولتن و بولتن‌های امنیتی دستگاه/شریک، مانند بولتن Pixel تقسیم می‌شوند؟

آسیب‌پذیری‌های امنیتی که در این بولتن امنیتی مستند شده‌اند برای اعلام آخرین سطح وصله امنیتی در دستگاه‌های اندرویدی مورد نیاز هستند. آسیب‌پذیری‌های امنیتی اضافی که در بولتن‌های امنیتی دستگاه/شریک مستند شده‌اند، برای اعلام سطح وصله امنیتی لازم نیست. سازندگان دستگاه‌ها و چیپ‌ست‌های Android نیز ممکن است جزئیات آسیب‌پذیری امنیتی خاص محصولات خود را منتشر کنند، مانند Google ، Huawei ، LGE ، Motorola ، Nokia یا Samsung .

نسخه ها

نسخه تاریخ یادداشت
1.0 3 ژوئن 2019 بولتن منتشر شد
1.1 5 ژوئن 2019 بولتن اصلاح شد تا شامل پیوندهای AOSP باشد