نشرة أمان Android - فبراير 2019

تم النشر في 4 فبراير 2019

تحتوي نشرة أمان Android على تفاصيل الثغرات الأمنية التي تؤثر على أجهزة Android. تعالج مستويات تصحيح الأمان بتاريخ 05-02-2019 أو الإصدارات الأحدث جميع هذه المشكلات. لمعرفة كيفية التحقق من مستوى تصحيح الأمان الخاص بالجهاز، راجع التحقق من إصدار Android لديك وتحديثه .

يتم إخطار شركاء Android بجميع المشكلات قبل شهر على الأقل من النشر. تم إصدار تصحيحات التعليمات البرمجية المصدر لهذه المشكلات في مستودع Android Open Source Project (AOSP) وتم ربطها من هذه النشرة. تتضمن هذه النشرة أيضًا روابط لتصحيحات خارج AOSP.

أخطر هذه المشكلات هو وجود ثغرة أمنية خطيرة في Framework والتي قد تسمح للمهاجم عن بعد باستخدام ملف PNG معد خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية مميزة. يعتمد تقييم الخطورة على التأثير الذي قد يحدثه استغلال الثغرة الأمنية على الجهاز المتأثر، بافتراض أنه تم إيقاف تشغيل عمليات تخفيف النظام الأساسي والخدمة لأغراض التطوير أو إذا تم تجاوزها بنجاح.

لم تصلنا أي تقارير عن استغلال العملاء النشطين أو إساءة استخدام هذه المشكلات التي تم الإبلاغ عنها حديثًا. راجع قسم عمليات تخفيف Android وGoogle Play Protect للحصول على تفاصيل حول حماية النظام الأساسي لأمان Android وGoogle Play Protect، مما يعمل على تحسين أمان نظام Android الأساسي.

ملاحظة: تتوفر معلومات حول آخر تحديث عبر الهواء (OTA) وصور البرامج الثابتة لأجهزة Google في نشرة Pixel Update لشهر فبراير 2019 .

عمليات تخفيف خدمات Android وGoogle

هذا ملخص لعمليات التخفيف التي يوفرها النظام الأساسي لأمان Android وعمليات حماية الخدمة مثل Google Play Protect . تعمل هذه الإمكانات على تقليل احتمالية استغلال الثغرات الأمنية بنجاح على نظام Android.

  • أصبح استغلال العديد من المشكلات على Android أكثر صعوبة بسبب التحسينات في الإصدارات الأحدث من نظام Android الأساسي. نحن نشجع جميع المستخدمين على التحديث إلى أحدث إصدار من Android حيثما أمكن ذلك.
  • يقوم فريق أمان Android بمراقبة إساءة الاستخدام بشكل نشط من خلال Google Play Protect ويحذر المستخدمين من التطبيقات التي قد تكون ضارة . يتم تمكين Google Play Protect افتراضيًا على الأجهزة المزودة بخدمات Google Mobile Services ، وهو مهم بشكل خاص للمستخدمين الذين يقومون بتثبيت تطبيقات من خارج Google Play.

2019-02-01 تفاصيل الثغرة الأمنية على مستوى التصحيح

في الأقسام أدناه، نقدم تفاصيل لكل من الثغرات الأمنية التي تنطبق على مستوى التصحيح 2019-02-01. يتم تجميع الثغرات الأمنية ضمن المكون الذي تؤثر عليه. يوجد وصف للمشكلة وجدول يتضمن CVE والمراجع المرتبطة ونوع الثغرة الأمنية وخطورتها وإصدارات AOSP المحدثة (حيثما أمكن). عندما يكون ذلك متاحًا، نقوم بربط التغيير العام الذي تناول المشكلة بمعرف الخطأ، مثل قائمة تغيير AOSP. عندما تتعلق تغييرات متعددة بخلل واحد، يتم ربط المراجع الإضافية بالأرقام التي تتبع معرف الخطأ.

نطاق

يمكن أن تؤدي الثغرة الأمنية الأكثر خطورة في هذا القسم إلى تمكين مهاجم عن بعد يستخدم ملف PNG معد خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية مميزة.

مكافحة التطرف العنيف مراجع يكتب خطورة تحديث إصدارات AOSP
CVE-2019-1986 ا-117838472 [ 2 ] آر سي إي شديد الأهمية 9
CVE-2019-1987 ا-118143775 [ 2 ] آر سي إي شديد الأهمية 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-1988 أ-118372692 آر سي إي شديد الأهمية 8.0، 8.1، 9

مكتبة

يمكن أن تؤدي الثغرة الأمنية الأكثر خطورة في هذا القسم إلى تمكين مهاجم عن بعد باستخدام ملف معد خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية لا تتمتع بأي امتيازات.

مكافحة التطرف العنيف مراجع يكتب خطورة تحديث إصدارات AOSP
CVE-2017-17760 أ-78029030 * آر سي إي عالي 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2018-5268 أ-78029634 * آر سي إي عالي 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2018-5269 أ-78029727 * آر سي إي عالي 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2017-18009 أ-78026242 * بطاقة تعريف معتدل 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9

نظام

يمكن أن تؤدي الثغرة الأمنية الأكثر خطورة في هذا القسم إلى تمكين مهاجم عن بعد باستخدام ناقل حركة مصمم خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية مميزة.

مكافحة التطرف العنيف مراجع يكتب خطورة تحديث إصدارات AOSP
CVE-2019-1991 أ-110166268 آر سي إي شديد الأهمية 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-1992 أ-116222069 آر سي إي شديد الأهمية 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-1993 أ-119819889 EOP عالي 8.0، 8.1، 9
CVE-2019-1994 أ-117770924 EOP عالي 8.0، 8.1، 9
CVE-2019-1995 ا-32589229 [ 2 ] بطاقة تعريف عالي 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-1996 أ-111451066 بطاقة تعريف عالي 8.0، 8.1، 9
CVE-2019-1997 أ-117508900 بطاقة تعريف عالي 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2019-1998 ا-116055338 [ 2 ] دوس عالي 9

05-02-2019 تفاصيل الثغرة الأمنية على مستوى التصحيح

في الأقسام أدناه، نقدم تفاصيل لكل من الثغرات الأمنية التي تنطبق على مستوى التصحيح 2019-02-05. يتم تجميع الثغرات الأمنية ضمن المكون الذي تؤثر عليه وتتضمن تفاصيل مثل CVE، والمراجع المرتبطة، ونوع الثغرة الأمنية ، وخطورتها ، والمكون (حيثما ينطبق ذلك)، وإصدارات AOSP المحدثة (حيثما ينطبق ذلك). عندما يكون ذلك متاحًا، نقوم بربط التغيير العام الذي تناول المشكلة بمعرف الخطأ، مثل قائمة تغيير AOSP. عندما تتعلق تغييرات متعددة بخلل واحد، يتم ربط المراجع الإضافية بالأرقام التي تتبع معرف الخطأ.

مكونات النواة

قد تؤدي الثغرة الأمنية الأكثر خطورة في هذا القسم إلى تمكين تطبيق ضار محلي من تنفيذ تعليمات برمجية عشوائية في سياق عملية مميزة.

مكافحة التطرف العنيف مراجع يكتب خطورة عنصر
CVE-2018-10879 أ-116406063
نواة المنبع
EOP عالي نظام الملفات ext4
CVE-2019-1999 أ-120025196 * EOP عالي سائق الموثق
CVE-2019-2000 أ-120025789 * EOP عالي سائق الموثق
CVE-2019-2001 أ-117422211 * بطاقة تعريف عالي iomem

مكونات نفيديا

يمكن أن تؤدي الثغرة الأمنية الأكثر خطورة في هذا القسم إلى تمكين مهاجم عن بعد باستخدام ملف معد خصيصًا لتنفيذ تعليمات برمجية عشوائية في سياق عملية مميزة.

مكافحة التطرف العنيف مراجع يكتب خطورة عنصر
CVE-2018-6271 أ-80198474 * آر سي إي شديد الأهمية libnvomx
CVE-2018-6267 أ-70857947 * EOP عالي libnvomx
CVE-2018-6268 أ-80433161 * EOP عالي libnvomx
CVE-2016-6684 ا-117423758 * بطاقة تعريف عالي سجل النواة

مكونات كوالكوم

تؤثر نقاط الضعف هذه على مكونات Qualcomm ويتم وصفها بمزيد من التفصيل في نشرة Qualcomm الأمنية أو تنبيه الأمان المناسب. يتم توفير تقييم خطورة هذه المشكلات مباشرةً بواسطة شركة Qualcomm.

مكافحة التطرف العنيف مراجع يكتب خطورة عنصر
CVE-2018-11262 أ-76424945
مراقبة الجودة-CR#2221192
لا يوجد شديد الأهمية محمل الإقلاع
CVE-2018-11280 أ-109741776
مراقبة الجودة-CR#2185061
لا يوجد عالي مودم
CVE-2018-11275 أ-74409078
مراقبة الجودة-CR#2221256 [ 2 ]
لا يوجد عالي محمل الإقلاع
CVE-2018-13900 أ-119052051
مراقبة الجودة-CR#2287499
لا يوجد عالي مودم
CVE-2018-13905 أ-119052050
مراقبة الجودة-CR#2225202
لا يوجد عالي الرسومات

مكونات كوالكوم مغلقة المصدر

تؤثر نقاط الضعف هذه على مكونات Qualcomm ويتم وصفها بمزيد من التفصيل في نشرة Qualcomm الأمنية أو تنبيه الأمان المناسب. يتم توفير تقييم خطورة هذه المشكلات مباشرةً بواسطة شركة Qualcomm.

مكافحة التطرف العنيف مراجع يكتب خطورة عنصر
CVE-2018-11289 أ-109678453 * لا يوجد شديد الأهمية مكون مغلق المصدر
CVE-2018-11820 أ-111089815 * لا يوجد شديد الأهمية مكون مغلق المصدر
CVE-2018-11938 أ-112279482 * لا يوجد شديد الأهمية مكون مغلق المصدر
CVE-2018-11945 أ-112278875 * لا يوجد شديد الأهمية مكون مغلق المصدر
CVE-2018-11268 أ-109678259 * لا يوجد عالي مكون مغلق المصدر
CVE-2018-11845 أ-111088838 * لا يوجد عالي مكون مغلق المصدر
CVE-2018-11864 أ-111092944 * لا يوجد عالي مكون مغلق المصدر
CVE-2018-11921 أ-112278972 * لا يوجد عالي مكون مغلق المصدر
CVE-2018-11931 أ-112279521 * لا يوجد عالي مكون مغلق المصدر
CVE-2018-11932 أ-112279426 * لا يوجد عالي مكون مغلق المصدر
CVE-2018-11935 أ-112279483 * لا يوجد عالي مكون مغلق المصدر
CVE-2018-11948 أ-112279144 * لا يوجد عالي مكون مغلق المصدر
CVE-2018-5839 أ-112279544 * لا يوجد عالي مكون مغلق المصدر
CVE-2018-13904 أ-119050566 * لا يوجد عالي مكون مغلق المصدر

الأسئلة والأجوبة الشائعة

يجيب هذا القسم على الأسئلة الشائعة التي قد تطرأ بعد قراءة هذه النشرة.

1. كيف يمكنني تحديد ما إذا كان جهازي قد تم تحديثه لمعالجة هذه المشكلات؟

لمعرفة كيفية التحقق من مستوى تصحيح الأمان الخاص بالجهاز، راجع التحقق من إصدار Android لديك وتحديثه .

  • تعالج مستويات تصحيح الأمان 01-02-2019 أو الأحدث جميع المشكلات المرتبطة بمستوى تصحيح الأمان 01-02-2019.
  • تتناول مستويات تصحيح الأمان 2019-02-05 أو الأحدث جميع المشكلات المرتبطة بمستوى تصحيح الأمان 2019-02-05 وجميع مستويات التصحيح السابقة.

يجب على الشركات المصنعة للأجهزة التي تتضمن هذه التحديثات تعيين مستوى سلسلة التصحيح على:

  • [ro.build.version.security_patch]:[2019-02-01]
  • [ro.build.version.security_patch]:[2019-02-05]

2. لماذا تحتوي هذه النشرة على مستويين من التصحيح الأمني؟

تحتوي هذه النشرة على مستويين من التصحيح الأمني ​​بحيث يتمتع شركاء Android بالمرونة اللازمة لإصلاح مجموعة فرعية من الثغرات الأمنية المتشابهة عبر جميع أجهزة Android بسرعة أكبر. ننصح شركاء Android بإصلاح جميع المشكلات الواردة في هذه النشرة واستخدام أحدث مستوى من التصحيح الأمني.

  • يجب أن تتضمن الأجهزة التي تستخدم مستوى تصحيح الأمان 01-02-2019 جميع المشكلات المرتبطة بمستوى تصحيح الأمان هذا، بالإضافة إلى إصلاحات لجميع المشكلات التي تم الإبلاغ عنها في نشرات الأمان السابقة.
  • يجب أن تتضمن الأجهزة التي تستخدم مستوى تصحيح الأمان 2019-02-05 أو الأحدث جميع التصحيحات القابلة للتطبيق في نشرات الأمان هذه (والسابقة).

يتم تشجيع الشركاء على تجميع الإصلاحات لجميع المشكلات التي يعالجونها في تحديث واحد.

3. ماذا تعني الإدخالات الموجودة في عمود النوع ؟

تشير الإدخالات الموجودة في عمود النوع في جدول تفاصيل الثغرة الأمنية إلى تصنيف الثغرة الأمنية.

اختصار تعريف
آر سي إي تنفيذ التعليمات البرمجية عن بعد
EOP ارتفاع الامتياز
بطاقة تعريف الإفصاح عن المعلومات
دوس الحرمان من الخدمة
لا يوجد التصنيف غير متوفر

4. ماذا تعني الإدخالات الموجودة في عمود "المراجع" ؟

قد تحتوي الإدخالات الموجودة ضمن عمود "المراجع" في جدول تفاصيل الثغرات الأمنية على بادئة تحدد المؤسسة التي تنتمي إليها القيمة المرجعية.

بادئة مرجع
أ- معرف خطأ أندرويد
مراقبة الجودة- الرقم المرجعي لشركة كوالكوم
م- الرقم المرجعي لميديا ​​تيك
ن- الرقم المرجعي لـ NVIDIA
ب- الرقم المرجعي من برودكوم

5. ماذا تعني العلامة * الموجودة بجوار معرّف خطأ Android في عمود "المراجع" ؟

تحتوي المشكلات غير المتاحة للعامة على علامة * بجوار معرف خطأ Android في عمود المراجع . يتم تضمين التحديث الخاص بهذه المشكلة عمومًا في أحدث برامج التشغيل الثنائية لأجهزة Pixel المتوفرة على موقع Google Developer .

6. لماذا يتم تقسيم الثغرات الأمنية بين هذه النشرة والنشرات الأمنية للجهاز/الشريك، مثل نشرة Pixel؟

يلزم وجود ثغرات أمنية موثقة في نشرة الأمان هذه للإعلان عن أحدث مستوى للتصحيح الأمني ​​على أجهزة Android. الثغرات الأمنية الإضافية الموثقة في نشرات أمان الجهاز/الشريك ليست مطلوبة للإعلان عن مستوى تصحيح الأمان. يتم تشجيع الشركات المصنعة لأجهزة Android والشرائح على توثيق وجود إصلاحات أخرى على أجهزتهم من خلال مواقع الويب الأمنية الخاصة بهم، مثل نشرات الأمان الخاصة بـ Samsung أو LGE أو Pixel .

الإصدارات

إصدار تاريخ ملحوظات
1.0 4 فبراير 2019 تم نشر النشرة