Android Security Bulletin – Februar 2017,Android Security Bulletin – Februar 2017

Veröffentlicht am 06.02.2017 | Aktualisiert am 8. Februar 2017

Das Android Security Bulletin enthält Details zu Sicherheitslücken, die Android-Geräte betreffen. Neben dem Bulletin haben wir ein Sicherheitsupdate für Google-Geräte über ein Over-the-Air-Update (OTA) veröffentlicht. Die Google-Geräte-Firmware-Images wurden auch auf der Google Developer-Website veröffentlicht. Sicherheits-Patch-Level vom 5. Februar 2017 oder später adressieren all diese Probleme. Lesen Sie den Aktualisierungszeitplan für Pixel und Nexus , um zu erfahren, wie Sie den Sicherheitspatch-Level eines Geräts überprüfen können.

Die Partner wurden am 3. Januar 2017 oder früher über die im Bulletin beschriebenen Probleme informiert. Quellcode-Patches für diese Probleme wurden im Android Open Source Project (AOSP)-Repository veröffentlicht und von diesem Bulletin verlinkt. Dieses Bulletin enthält auch Links zu Patches außerhalb von AOSP.

Das schwerwiegendste dieser Probleme ist eine kritische Sicherheitslücke, die die Remotecodeausführung auf einem betroffenen Gerät durch mehrere Methoden wie E-Mail, Webbrowsing und MMS bei der Verarbeitung von Mediendateien ermöglichen könnte. Die Bewertung des Schweregrads basiert auf den Auswirkungen, die das Ausnutzen der Schwachstelle möglicherweise auf ein betroffenes Gerät haben würde, vorausgesetzt, die Plattform- und Dienstmitigationen werden zu Entwicklungszwecken deaktiviert oder erfolgreich umgangen.

Wir haben keine Berichte über aktive Ausbeutung oder Missbrauch dieser neu gemeldeten Probleme durch Kunden erhalten. Einzelheiten zum Schutz der Android-Sicherheitsplattform und zum Schutz von Diensten wie SafetyNet , die die Sicherheit der Android-Plattform verbessern, finden Sie im Abschnitt Schadensbegrenzung für Android- und Google-Dienste .

Wir empfehlen allen Kunden, diese Updates für ihre Geräte zu akzeptieren.

Ankündigungen

  • Dieses Bulletin enthält zwei Sicherheits-Patch-Level-Strings, um Android-Partnern die Flexibilität zu geben, eine Teilmenge von Schwachstellen, die auf allen Android-Geräten ähnlich sind, schneller zu beheben. Weitere Informationen finden Sie unter Häufige Fragen und Antworten :
    • 2017-02-01 : Partielle Sicherheits-Patch-Level-Zeichenfolge. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle Probleme im Zusammenhang mit 2017-02-01 (und allen vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben wurden.
    • 2017-02-05 : Vollständiger Sicherheits-Patch-Level-String. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle Probleme im Zusammenhang mit 2017-02-01 und 2017-02-05 (und allen vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben wurden.
  • Unterstützte Google-Geräte erhalten ein einzelnes OTA-Update mit dem Sicherheitspatch vom 5. Februar 2017.

Minderungen für Android- und Google-Dienste

Dies ist eine Zusammenfassung der Schutzmaßnahmen, die von der Android-Sicherheitsplattform und den Dienstschutzmaßnahmen wie SafetyNet bereitgestellt werden. Diese Fähigkeiten verringern die Wahrscheinlichkeit, dass Sicherheitslücken auf Android erfolgreich ausgenutzt werden könnten.

  • Die Nutzung für viele Probleme auf Android wird durch Verbesserungen in neueren Versionen der Android-Plattform erschwert. Wir empfehlen allen Benutzern, nach Möglichkeit auf die neueste Version von Android zu aktualisieren.
  • Das Android-Sicherheitsteam überwacht aktiv auf Missbrauch mit Verify Apps und SafetyNet , die entwickelt wurden, um Benutzer vor potenziell schädlichen Anwendungen zu warnen. Apps überprüfen ist standardmäßig auf Geräten mit Google Mobile Services aktiviert und ist besonders wichtig für Benutzer, die Anwendungen von außerhalb von Google Play installieren. Geräte-Rooting-Tools sind in Google Play verboten, aber Verify Apps warnt Benutzer, wenn sie versuchen, eine erkannte Rooting-Anwendung zu installieren – unabhängig davon, woher sie stammt. Darüber hinaus versucht Verify Apps, die Installation bekannter bösartiger Anwendungen zu identifizieren und zu blockieren, die eine Schwachstelle bei der Rechteausweitung ausnutzen. Wenn eine solche Anwendung bereits installiert wurde, benachrichtigt Verify Apps den Benutzer und versucht, die erkannte Anwendung zu entfernen.
  • Entsprechend übergeben Google Hangouts- und Messenger-Anwendungen Medien nicht automatisch an Prozesse wie Mediaserver.

Danksagungen

Wir möchten diesen Forschern für ihre Beiträge danken:

Wir möchten auch den folgenden Personen für ihre Beiträge zu diesem Bulletin danken:

  • Pengfei Ding (丁鹏飞), Chenfu Bao (包沉浮) und Lenx Wei (韦韬) von Baidu X-Lab (百度安全实验室)

Sicherheits-Patch-Level vom 1. Februar 2017 – Details zur Sicherheitslücke

In den folgenden Abschnitten stellen wir Details für alle Sicherheitsschwachstellen bereit, die für die Patchebene vom 1. Februar 2017 gelten. Es gibt eine Beschreibung des Problems, eine Begründung für den Schweregrad und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad, aktualisierten Google-Geräten, aktualisierten AOSP-Versionen (falls zutreffend) und dem gemeldeten Datum. Wenn verfügbar, werden wir die öffentliche Änderung, die das Problem behebt, mit der Fehler-ID verknüpfen, wie die AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern nach der Fehler-ID verknüpft.

Schwachstelle bezüglich Remotecodeausführung in Surfaceflinger

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Surfaceflinger könnte es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei während der Mediendatei- und Datenverarbeitung eine Speicherbeschädigung zu verursachen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext des Surfaceflinger-Prozesses als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0405 A-31960359 Kritisch Alle 7.0, 7.1.1 4. Oktober 2016

Schwachstelle bezüglich Remotecodeausführung in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Mediaserver könnte es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei während der Mediendatei- und Datenverarbeitung eine Speicherbeschädigung zu verursachen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext des Mediaserver-Prozesses als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0406 A-32915871 [ 2 ] Kritisch Alle 6.0, 6.0.1, 7.0, 7.1.1 14. November 2016
CVE-2017-0407 A-32873375 Kritisch Alle 6.0, 6.0.1, 7.0, 7.1.1 12. November 2016

Schwachstelle bezüglich Remotecodeausführung in libgdx

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in libgdx könnte es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei beliebigen Code im Kontext eines nicht privilegierten Prozesses auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung in einer Anwendung, die diese Bibliothek verwendet, als Hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0408 A-32769670 Hoch Alle 7.1.1 9. November 2016

Schwachstelle bezüglich Remotecodeausführung in libstagefright

Eine Schwachstelle bezüglich Remotecodeausführung in libstagefright könnte es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei beliebigen Code im Kontext eines nicht privilegierten Prozesses auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung in einer Anwendung, die diese Bibliothek verwendet, als Hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0409 A-31999646 Hoch Alle 6.0, 6.0.1, 7.0, 7.1.1 Google-intern

Schwachstelle bezüglich Erhöhung von Berechtigungen in Java.Net

Eine Rechteerweiterung in der Java.Net-Bibliothek könnte es böswilligen Webinhalten ermöglichen, einen Benutzer ohne ausdrückliche Erlaubnis auf eine andere Website umzuleiten. Dieses Problem wird als Hoch eingestuft, da es sich um eine Remoteumgehung der Benutzerinteraktionsanforderungen handelt.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2016-5552 A-31858037 Hoch Alle 7.0, 7.1.1 30. September 2016

Schwachstelle bezüglich Erhöhung von Berechtigungen in Framework-APIs

Eine Schwachstelle bezüglich der Erhöhung von Berechtigungen in den Framework-APIs könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als Hoch eingestuft, da es verwendet werden könnte, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die eine Drittanbieteranwendung normalerweise nicht zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0410 A-31929765 Hoch Alle 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2. Oktober 2016
CVE-2017-0411 A-33042690 [ 2 ] Hoch Alle 7.0, 7.1.1 21. November 2016
CVE-2017-0412 A-33039926 [ 2 ] Hoch Alle 7.0, 7.1.1 21. November 2016

Sicherheitslücke bezüglich Erhöhung von Berechtigungen in Mediaserver

Eine Schwachstelle bezüglich Rechteerweiterungen in Mediaserver könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als Hoch eingestuft, da es verwendet werden könnte, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die eine Drittanbieteranwendung normalerweise nicht zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0415 A-32706020 Hoch Alle 6.0, 6.0.1, 7.0, 7.1.1 4. November 2016

Elevation-of-Privilege-Schwachstelle in Audioserver

Eine Elevation-of-Privilege-Schwachstelle in Audioserver könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als Hoch eingestuft, da es verwendet werden könnte, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die eine Drittanbieteranwendung normalerweise nicht zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0416 A-32886609 [ 2 ] Hoch Alle 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google-intern
CVE-2017-0417 A-32705438 Hoch Alle 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7. November 2016
CVE-2017-0418 A-32703959 [ 2 ] Hoch Alle 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7. November 2016
CVE-2017-0419 A-32220769 Hoch Alle 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 15. Oktober 2016

Schwachstelle bezüglich Offenlegung von Informationen in AOSP Mail

Eine Schwachstelle bezüglich der Offenlegung von Informationen in AOSP Mail könnte es einer lokalen bösartigen Anwendung ermöglichen, den Schutz des Betriebssystems zu umgehen, der Anwendungsdaten von anderen Anwendungen isoliert. Dieses Problem wird als Hoch eingestuft, da es dazu verwendet werden könnte, auf Daten zuzugreifen, auf die die Anwendung keinen Zugriff hat.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0420 A-32615212 Hoch Alle 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 12. September 2016

Schwachstelle bezüglich Offenlegung von Informationen in AOSP Messaging

Eine Schwachstelle bezüglich der Offenlegung von Informationen in AOSP Messaging könnte es einer lokalen schädlichen Anwendung ermöglichen, Betriebssystemschutzmaßnahmen zu umgehen, die Anwendungsdaten von anderen Anwendungen isolieren. Dieses Problem wird als Hoch eingestuft, da es dazu verwendet werden könnte, auf Daten zuzugreifen, auf die die Anwendung keinen Zugriff hat.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0413 A-32161610 Hoch Alle 6.0, 6.0.1, 7.0, 7.1.1 13. Oktober 2016
CVE-2017-0414 A-32807795 Hoch Alle 6.0, 6.0.1, 7.0, 7.1.1 10. November 2016

Schwachstelle bezüglich Offenlegung von Informationen in Framework-APIs

Eine Schwachstelle bezüglich der Offenlegung von Informationen in den Framework-APIs könnte es einer lokalen schädlichen Anwendung ermöglichen, Betriebssystemschutzmaßnahmen zu umgehen, die Anwendungsdaten von anderen Anwendungen isolieren. Dieses Problem wird als Hoch eingestuft, da es dazu verwendet werden könnte, auf Daten zuzugreifen, auf die die Anwendung keinen Zugriff hat.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0421 A-32555637 Hoch Alle 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google-intern

Denial-of-Service-Schwachstelle in Bionic DNS

Eine Denial-of-Service-Schwachstelle in Bionic DNS könnte es einem entfernten Angreifer ermöglichen, ein speziell gestaltetes Netzwerkpaket zu verwenden, um ein Gerät hängen zu lassen oder neu zu starten. Dieses Problem wird aufgrund der Möglichkeit von Remote-Denial-of-Service als Hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0422 A-32322088 Hoch Alle 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20. Oktober 2016

Elevation of Privilege-Schwachstelle in Bluetooth

Eine Schwachstelle bezüglich Rechteerweiterungen in Bluetooth könnte es einem nahen Angreifer ermöglichen, den Zugriff auf Dokumente auf dem Gerät zu verwalten. Dieses Problem wird als moderat eingestuft, da es zunächst die Ausnutzung einer separaten Schwachstelle im Bluetooth-Stack erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0423 A-32612586 Mäßig Alle 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2. November 2016

Schwachstelle bezüglich Offenlegung von Informationen in AOSP Messaging

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in AOSP Messaging könnte es einem entfernten Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei auf Daten außerhalb seiner Berechtigungsstufen zuzugreifen. Dieses Problem wird als moderat eingestuft, da es sich um eine allgemeine Umgehung für eine Tiefenverteidigung auf Benutzerebene oder eine Exploit-Minderungstechnologie in einem privilegierten Prozess handelt.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0424 A-32322450 Mäßig Alle 6.0, 6.0.1, 7.0, 7.1.1 20. Oktober 2016

Schwachstelle bezüglich Offenlegung von Informationen in Audioserver

Eine Schwachstelle zur Offenlegung von Informationen in Audioserver könnte es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es zum unerlaubten Zugriff auf sensible Daten verwendet werden könnte.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0425 A-32720785 Mäßig Alle 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7. November 2016

Schwachstelle bezüglich Offenlegung von Informationen im Dateisystem

Eine Schwachstelle zur Offenlegung von Informationen im Dateisystem könnte es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es zum unerlaubten Zugriff auf sensible Daten verwendet werden könnte.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum gemeldet
CVE-2017-0426 A-32799236 [ 2 ] Mäßig Alle 7.0, 7.1.1 Google-intern

2017-02-05 Sicherheits-Patch-Level – Details zur Sicherheitslücke

In den folgenden Abschnitten stellen wir Details für jede der Sicherheitsschwachstellen bereit, die für das Patch-Level 2017-02-05 gelten. Es gibt eine Beschreibung des Problems, eine Begründung für den Schweregrad und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad, aktualisierten Google-Geräten, aktualisierten AOSP-Versionen (falls zutreffend) und dem gemeldeten Datum. Wenn verfügbar, werden wir die öffentliche Änderung, die das Problem behebt, mit der Fehler-ID verknüpfen, wie die AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern nach der Fehler-ID verknüpft.

Schwachstelle bezüglich Remotecodeausführung im Qualcomm-Kryptotreiber

Eine Schwachstelle bei der Remote-Code-Ausführung im Qualcomm-Krypto-Treiber könnte es einem Remote-Angreifer ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext des Kernels als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2016-8418 A-32652894
QC-CR#1077457
Kritisch Keiner* 10. Oktober 2016

* Unterstützte Google-Geräte mit Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert sind, sind von dieser Schwachstelle nicht betroffen.

Schwachstelle bezüglich Erhöhung von Berechtigungen im Kernel-Dateisystem

Eine Elevation-of-Privilege-Schwachstelle im Kernel-Dateisystem könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit einer lokalen dauerhaften Gerätekompromittierung als Kritisch eingestuft, was möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0427 A-31495866* Kritisch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL 13. September 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Schwachstelle bezüglich Erhöhung von Berechtigungen im NVIDIA-GPU-Treiber

Eine Elevation-of-Privilege-Schwachstelle im NVIDIA-GPU-Treiber könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit einer lokalen dauerhaften Gerätekompromittierung als Kritisch eingestuft, was möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0428 A-32401526*
N-CVE-2017-0428
Kritisch Verbindung 9 25. Oktober 2016
CVE-2017-0429 A-32636619*
N-CVE-2017-0429
Kritisch Verbindung 9 3. November 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Schwachstelle bezüglich Erhöhung von Berechtigungen im Kernel-Netzwerksubsystem

Eine Elevation-of-Privilege-Schwachstelle im Kernel-Netzwerk-Subsystem könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit einer lokalen dauerhaften Gerätekompromittierung als Kritisch eingestuft, was möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2014-9914 A-32882659
Upstream-Kernel
Kritisch Nexus 6, Nexus-Player 9. November 2016

Elevation of Privilege-Schwachstelle im Broadcom Wi-Fi-Treiber

Eine Elevation-of-Privilege-Schwachstelle im Broadcom Wi-Fi-Treiber könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit einer lokalen dauerhaften Gerätekompromittierung als Kritisch eingestuft, was möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0430 A-32838767*
B-RB#107459
Kritisch Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Google-intern

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Schwachstellen in Qualcomm-Komponenten

Die folgende Schwachstelle betrifft Komponenten von Qualcomm und wird ausführlicher im Security Bulletin von Qualcomm AMSS vom September 2016 beschrieben.

CVE Verweise Schwere* Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0431 A-32573899** Kritisch Keiner*** Qualcomm-intern

* Die Bewertung des Schweregrads für diese Schwachstellen wurde vom Anbieter festgelegt.

** Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

*** Unterstützte Google-Geräte mit Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert sind, sind von dieser Schwachstelle nicht betroffen.

Elevation of Privilege-Schwachstelle im MediaTek-Treiber

Eine Elevation-of-Privilege-Schwachstelle im MediaTek-Treiber könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als Hoch eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0432 A-28332719*
M-ALPS02708925
Hoch Keiner** 21. April 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte mit Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert sind, sind von dieser Schwachstelle nicht betroffen.

Elevation of Privilege-Schwachstelle im Synaptics-Touchscreen-Treiber

Eine Elevation-of-Privilege-Schwachstelle im Synaptics-Touchscreen-Treiber könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Touchscreen-Chipsatzes auszuführen. Dieses Problem wird als Hoch eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0433 A-31913571* Hoch Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL 8. September 2016
CVE-2017-0434 A-33001936* Hoch Pixel, Pixel XL 18. November 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of Privilege-Schwachstelle im Qualcomm Secure Execution Environment Communicator-Treiber

Eine Elevation-of-Privilege-Schwachstelle im Qualcomm Secure Execution Environment Communicator-Laufwerk könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als Hoch eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2016-8480 A-31804432
QC-CR#1086186 [ 2 ]
Hoch Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 28. September 2016

Elevation of Privilege-Schwachstelle im Qualcomm-Soundtreiber

Eine Elevation-of-Privilege-Schwachstelle im Qualcomm-Soundtreiber könnte es einer lokalen Schadanwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als Hoch eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2016-8481 A-31906415*
QC-CR#1078000
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL 1. Oktober 2016
CVE-2017-0435 A-31906657*
QC-CR#1078000
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL 1. Oktober 2016
CVE-2017-0436 A-32624661*
QC-CR#1078000
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL 2. November 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of Privilege-Schwachstelle im Qualcomm Wi-Fi-Treiber

Eine Elevation-of-Privilege-Schwachstelle im Qualcomm Wi-Fi-Treiber könnte es einer lokalen Schadanwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als Hoch eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0437 A-32402310
QC-CR#1092497
Hoch Nexus 5X, Pixel, Pixel XL 25. Oktober 2016
CVE-2017-0438 A-32402604
QC-CR#1092497
Hoch Nexus 5X, Pixel, Pixel XL 25. Oktober 2016
CVE-2017-0439 A-32450647
QC-CR#1092059
Hoch Nexus 5X, Pixel, Pixel XL 25. Oktober 2016
CVE-2016-8419 A-32454494
QC-CR#1087209
Hoch Nexus 5X, Pixel, Pixel XL 26. Oktober 2016
CVE-2016-8420 A-32451171
QC-CR#1087807
Hoch Nexus 5X, Pixel, Pixel XL 26. Oktober 2016
CVE-2016-8421 A-32451104
QC-CR#1087797
Hoch Nexus 5X, Pixel, Pixel XL 26. Oktober 2016
CVE-2017-0440 A-33252788
QC-CR#1095770
Hoch Nexus 5X, Pixel, Pixel XL 11. November 2016
CVE-2017-0441 A-32872662
QC-CR#1095009
Hoch Nexus 5X, Pixel, Pixel XL 11. November 2016
CVE-2017-0442 A-32871330
QC-CR#1092497
Hoch Nexus 5X, Pixel, Pixel XL 13. November 2016
CVE-2017-0443 A-32877494
QC-CR#1092497
Hoch Nexus 5X, Pixel, Pixel XL 13. November 2016
CVE-2016-8476 A-32879283
QC-CR#1091940
Hoch Nexus 5X, Pixel, Pixel XL 14. November 2016

Elevation of Privilege-Schwachstelle im Realtek-Soundtreiber

Eine Elevation-of-Privilege-Schwachstelle im Realtek-Soundtreiber könnte es einer lokalen Schadanwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als Hoch eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0444 A-32705232* Hoch Verbindung 9 7. November 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of Privilege-Schwachstelle im HTC-Touchscreen-Treiber

Eine Elevation-of-Privilege-Schwachstelle im HTC-Touchscreen-Treiber könnte es einer lokalen Schadanwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als Hoch eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0445 A-32769717* Hoch Pixel, Pixel XL 9. November 2016
CVE-2017-0446 A-32917445* Hoch Pixel, Pixel XL 15. November 2016
CVE-2017-0447 A-32919560* Hoch Pixel, Pixel XL 15. November 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Schwachstelle bezüglich Offenlegung von Informationen im NVIDIA-Grafiktreiber

Eine Schwachstelle zur Offenlegung von Informationen im NVIDIA-Videotreiber könnte es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als Hoch eingestuft, da es für den Zugriff auf vertrauliche Daten ohne ausdrückliche Benutzererlaubnis verwendet werden könnte.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0448 A-32721029*
N-CVE-2017-0448
Hoch Verbindung 9 7. November 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of Privilege-Schwachstelle im Broadcom Wi-Fi-Treiber

Eine Elevation-of-Privilege-Schwachstelle im Broadcom Wi-Fi-Treiber könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als moderat eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert und durch aktuelle Plattformkonfigurationen gemildert wird.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0449 A-31707909*
B-RB#32094
Mäßig Nexus 6, Nexus 6P 23. September 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation-of-Privilege-Schwachstelle in Audioserver

Eine Elevation-of-Privilege-Schwachstelle in Audioserver könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als moderat eingestuft, da es durch aktuelle Plattformkonfigurationen gemildert wird.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0450 A-32917432* Mäßig Verbindung 9 15. November 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Schwachstelle bezüglich Erhöhung von Berechtigungen im Kernel-Dateisystem

Eine Schwachstelle bezüglich der Erhöhung von Berechtigungen im Kernel-Dateisystem könnte es einer lokalen bösartigen Anwendung ermöglichen, Schutzmaßnahmen zu umgehen, die eine Eskalation von Berechtigungen verhindern. Dieses Problem wird als moderat eingestuft, da es sich um eine allgemeine Umgehung für eine Tiefenverteidigung auf Benutzerebene oder eine Exploit-Minderungstechnologie handelt.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2016-10044 A-31711619* Mäßig Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Google-intern

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Schwachstelle bezüglich Offenlegung von Informationen in Qualcomm Secure Execution Environment Communicator

Eine Schwachstelle bezüglich der Offenlegung von Informationen im Qualcomm Secure Execution Environment Communicator könnte es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als moderat eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2016-8414 A-31704078
QC-CR#1076407
Mäßig Nexus 5X, Nexus 6P, Android One, Pixel, Pixel XL 23. September 2016

Schwachstelle bezüglich Offenlegung von Informationen im Soundtreiber von Qualcomm

Eine Schwachstelle zur Offenlegung von Informationen im Qualcomm-Soundtreiber könnte es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als moderat eingestuft, da es zunächst die Kompromittierung eines privilegierten Prozesses erfordert.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum gemeldet
CVE-2017-0451 A-31796345
QC-CR#1073129 [ 2 ]
Mäßig Nexus 5X, Nexus 6P, Android One, Pixel, Pixel XL 27. September 2016

Häufige Fragen und Antworten

In diesem Abschnitt werden allgemeine Fragen beantwortet, die nach dem Lesen dieses Bulletins auftreten können.

1. Wie kann ich feststellen, ob mein Gerät aktualisiert wurde, um diese Probleme zu beheben?

Um zu erfahren, wie Sie den Sicherheits-Patch-Level eines Geräts überprüfen, lesen Sie die Anweisungen im Aktualisierungszeitplan für Pixel und Nexus .

  • Sicherheits-Patch-Level vom 1. Februar 2017 oder höher beheben alle Probleme im Zusammenhang mit dem Sicherheits-Patch-Level vom 1. Februar 2017.
  • Sicherheits-Patch-Levels vom 05.02.2017 oder höher beheben alle Probleme im Zusammenhang mit dem Sicherheits-Patch-Level vom 05.02.2017 und allen vorherigen Patch-Levels.

Gerätehersteller, die diese Updates enthalten, sollten die Patch-String-Ebene auf Folgendes festlegen:

  • [ro.build.version.security_patch]:[2017-02-01]
  • [ro.build.version.security_patch]:[2017-02-05]

2. Warum enthält dieses Bulletin zwei Sicherheits-Patch-Stufen?

Dieses Bulletin enthält zwei Sicherheits-Patch-Stufen, sodass Android-Partner die Flexibilität haben, eine Teilmenge von Schwachstellen, die auf allen Android-Geräten ähnlich sind, schneller zu beheben. Android-Partner werden ermutigt, alle Probleme in diesem Bulletin zu beheben und das neueste Sicherheitspatch-Level zu verwenden.

  • Geräte, die das Sicherheitspatch-Level vom 1. Februar 2017 verwenden, müssen alle Probleme enthalten, die mit diesem Sicherheitspatch-Level verbunden sind, sowie Korrekturen für alle Probleme, die in früheren Sicherheitsbulletins gemeldet wurden.
  • Geräte, die das Sicherheitspatch-Level vom 5. Februar 2017 oder neuer verwenden, müssen alle anwendbaren Patches in diesem (und früheren) Sicherheitsbulletins enthalten.

Partner werden ermutigt, die Korrekturen für alle Probleme, die sie beheben, in einem einzigen Update zu bündeln.

3. Wie kann ich feststellen, welche Google-Geräte von jedem Problem betroffen sind?

In den Abschnitten mit Details zu Sicherheitslücken vom 01.02.2017 und 05.02.2017 enthält jede Tabelle eine Spalte mit aktualisierten Google-Geräten , die den Bereich der betroffenen Google-Geräte abdeckt, die für jedes Problem aktualisiert wurden. Diese Spalte hat einige Optionen:

  • Alle Google-Geräte : Wenn ein Problem alle und Pixel-Geräte betrifft, wird in der Tabelle in der Spalte „ Aktualisierte Google-Geräte “ „Alle“ angezeigt. „Alle“ umfasst die folgenden unterstützten Geräte : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel und Pixel XL.
  • Einige Google-Geräte : Wenn ein Problem nicht alle Google-Geräte betrifft, werden die betroffenen Google-Geräte in der Spalte „ Aktualisierte Google-Geräte “ aufgeführt.
  • Keine Google-Geräte : Wenn keine Google-Geräte mit Android 7.0 von dem Problem betroffen sind, wird in der Tabelle in der Spalte „ Aktualisierte Google-Geräte “ „Keine“ angezeigt.

4. Worauf beziehen sich die Einträge in der Spalte „Referenzen“?

Einträge in der Spalte „ Referenzen “ der Tabelle mit den Schwachstellendetails können ein Präfix enthalten, das die Organisation angibt, zu der der Referenzwert gehört. Diese Präfixe werden wie folgt zugeordnet:

Präfix Bezug
EIN- Android-Fehler-ID
QC- Qualcomm-Referenznummer
M- MediaTek-Referenznummer
N- NVIDIA-Referenznummer
B- Broadcom-Referenznummer

Revisionen

  • 06. Februar 2017: Bulletin veröffentlicht.
  • 8. Februar 2017: Bulletin überarbeitet, um AOSP-Links aufzunehmen.
,

Veröffentlicht am 06.02.2017 | Aktualisiert am 8. Februar 2017

Das Android Security Bulletin enthält Details zu Sicherheitslücken, die Android-Geräte betreffen. Neben dem Bulletin haben wir ein Sicherheitsupdate für Google-Geräte über ein Over-the-Air-Update (OTA) veröffentlicht. Die Google-Geräte-Firmware-Images wurden auch auf der Google Developer-Website veröffentlicht. Sicherheits-Patch-Level vom 5. Februar 2017 oder später adressieren all diese Probleme. Lesen Sie den Aktualisierungszeitplan für Pixel und Nexus , um zu erfahren, wie Sie den Sicherheitspatch-Level eines Geräts überprüfen können.

Die Partner wurden am 3. Januar 2017 oder früher über die im Bulletin beschriebenen Probleme informiert. Quellcode-Patches für diese Probleme wurden im Android Open Source Project (AOSP)-Repository veröffentlicht und von diesem Bulletin verlinkt. Dieses Bulletin enthält auch Links zu Patches außerhalb von AOSP.

Das schwerwiegendste dieser Probleme ist eine kritische Sicherheitslücke, die die Remotecodeausführung auf einem betroffenen Gerät durch mehrere Methoden wie E-Mail, Webbrowsing und MMS bei der Verarbeitung von Mediendateien ermöglichen könnte. Die Bewertung des Schweregrads basiert auf den Auswirkungen, die das Ausnutzen der Schwachstelle möglicherweise auf ein betroffenes Gerät haben würde, vorausgesetzt, die Plattform- und Dienstmitigationen werden zu Entwicklungszwecken deaktiviert oder erfolgreich umgangen.

Wir haben keine Berichte über aktive Ausbeutung oder Missbrauch dieser neu gemeldeten Probleme durch Kunden erhalten. Einzelheiten zum Schutz der Android-Sicherheitsplattform und zum Schutz von Diensten wie SafetyNet , die die Sicherheit der Android-Plattform verbessern, finden Sie im Abschnitt Schadensbegrenzung für Android- und Google-Dienste .

Wir empfehlen allen Kunden, diese Updates für ihre Geräte zu akzeptieren.

Ankündigungen

  • Dieses Bulletin enthält zwei Sicherheits-Patch-Level-Strings, um Android-Partnern die Flexibilität zu geben, eine Teilmenge von Schwachstellen, die auf allen Android-Geräten ähnlich sind, schneller zu beheben. Weitere Informationen finden Sie unter Häufige Fragen und Antworten :
    • 2017-02-01 : Partielle Sicherheits-Patch-Level-Zeichenfolge. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle Probleme im Zusammenhang mit 2017-02-01 (und allen vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben wurden.
    • 2017-02-05 : Vollständiger Sicherheits-Patch-Level-String. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle Probleme im Zusammenhang mit 2017-02-01 und 2017-02-05 (und allen vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben wurden.
  • Unterstützte Google-Geräte erhalten ein einzelnes OTA-Update mit dem Sicherheitspatch vom 5. Februar 2017.

Minderungen für Android- und Google-Dienste

Dies ist eine Zusammenfassung der Schutzmaßnahmen, die von der Android-Sicherheitsplattform und den Dienstschutzmaßnahmen wie SafetyNet bereitgestellt werden. Diese Fähigkeiten verringern die Wahrscheinlichkeit, dass Sicherheitslücken auf Android erfolgreich ausgenutzt werden könnten.

  • Die Nutzung für viele Probleme auf Android wird durch Verbesserungen in neueren Versionen der Android-Plattform erschwert. Wir empfehlen allen Benutzern, nach Möglichkeit auf die neueste Version von Android zu aktualisieren.
  • Das Android-Sicherheitsteam überwacht aktiv auf Missbrauch mit Verify Apps und SafetyNet , die entwickelt wurden, um Benutzer vor potenziell schädlichen Anwendungen zu warnen. Apps überprüfen ist standardmäßig auf Geräten mit Google Mobile Services aktiviert und ist besonders wichtig für Benutzer, die Anwendungen von außerhalb von Google Play installieren. Device rooting tools are prohibited within Google Play, but Verify Apps warns users when they attempt to install a detected rooting application—no matter where it comes from. Additionally, Verify Apps attempts to identify and block installation of known malicious applications that exploit a privilege escalation vulnerability. If such an application has already been installed, Verify Apps will notify the user and attempt to remove the detected application.
  • As appropriate, Google Hangouts and Messenger applications do not automatically pass media to processes such as Mediaserver.

Danksagungen

Wir möchten diesen Forschern für ihre Beiträge danken:

We would also like to thank the following for their contributions to this bulletin:

  • Pengfei Ding (丁鹏飞), Chenfu Bao (包沉浮), and Lenx Wei (韦韬) of Baidu X-Lab (百度安全实验室)

2017-02-01 security patch level—Vulnerability details

In the sections below, we provide details for each of the security vulnerabilities that apply to the 2017-02-01 patch level. There is a description of the issue, a severity rationale, and a table with the CVE, associated references, severity, updated Google devices, updated AOSP versions (where applicable), and date reported. When available, we will link the public change that addressed the issue to the bug ID, like the AOSP change list. When multiple changes relate to a single bug, additional references are linked to numbers following the bug ID.

Remote code execution vulnerability in Surfaceflinger

A remote code execution vulnerability in Surfaceflinger could enable an attacker using a specially crafted file to cause memory corruption during media file and data processing. This issue is rated as Critical due to the possibility of remote code execution within the context of the Surfaceflinger process.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0405 A-31960359 Kritisch All 7.0, 7.1.1 Oct 4, 2016

Remote code execution vulnerability in Mediaserver

A remote code execution vulnerability in Mediaserver could enable an attacker using a specially crafted file to cause memory corruption during media file and data processing. This issue is rated as Critical due to the possibility of remote code execution within the context of the Mediaserver process.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0406 A-32915871 [ 2 ] Kritisch All 6.0, 6.0.1, 7.0, 7.1.1 Nov 14, 2016
CVE-2017-0407 A-32873375 Kritisch All 6.0, 6.0.1, 7.0, 7.1.1 Nov 12, 2016

Remote code execution vulnerability in libgdx

A remote code execution vulnerability in libgdx could enable an attacker using a specially crafted file to execute arbitrary code in the context of an unprivileged process. This issue is rated as High due to the possibility of remote code execution in an application that uses this library.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0408 A-32769670 Hoch All 7.1.1 Nov 9, 2016

Remote code execution vulnerability in libstagefright

A remote code execution vulnerability in libstagefright could enable an attacker using a specially crafted file to execute arbitrary code in the context of an unprivileged process. This issue is rated as High due to the possibility of remote code execution in an application that uses this library.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0409 A-31999646 Hoch All 6.0, 6.0.1, 7.0, 7.1.1 Google internal

Elevation of privilege vulnerability in Java.Net

An elevation of privilege in the Java.Net library could enable malicious web content to redirect a user to another website without explicit permission. This issue is rated as High because it is a remote bypass of user interaction requirements.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2016-5552 A-31858037 Hoch All 7.0, 7.1.1 Sep 30, 2016

Elevation of privilege vulnerability in Framework APIs

An elevation of privilege vulnerability in the Framework APIs could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as High because it could be used to gain local access to elevated capabilities, which are not normally accessible to a third-party application.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0410 A-31929765 Hoch All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 2, 2016
CVE-2017-0411 A-33042690 [ 2 ] Hoch All 7.0, 7.1.1 Nov 21, 2016
CVE-2017-0412 A-33039926 [ 2 ] Hoch All 7.0, 7.1.1 Nov 21, 2016

Elevation of privilege vulnerability in Mediaserver

An elevation of privilege vulnerability in Mediaserver could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as High because it could be used to gain local access to elevated capabilities, which are not normally accessible to a third-party application.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0415 A-32706020 Hoch All 6.0, 6.0.1, 7.0, 7.1.1 Nov 4, 2016

Elevation of privilege vulnerability in Audioserver

An elevation of privilege vulnerability in Audioserver could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as High because it could be used to gain local access to elevated capabilities, which are not normally accessible to a third-party application.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0416 A-32886609 [ 2 ] Hoch All 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google internal
CVE-2017-0417 A-32705438 Hoch All 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Nov 7, 2016
CVE-2017-0418 A-32703959 [ 2 ] Hoch All 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Nov 7, 2016
CVE-2017-0419 A-32220769 Hoch All 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 15, 2016

Information disclosure vulnerability in AOSP Mail

An information disclosure vulnerability in AOSP Mail could enable a local malicious application to bypass operating system protections that isolate application data from other applications. This issue is rated as High because it could be used to gain access to data that the application does not have access to.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0420 A-32615212 Hoch All 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Sep 12, 2016

Information disclosure vulnerability in AOSP Messaging

An information disclosure vulnerability in AOSP Messaging could enable a local malicious application to bypass operating system protections that isolate application data from other applications. This issue is rated as High because it could be used to gain access to data that the application does not have access to.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0413 A-32161610 Hoch All 6.0, 6.0.1, 7.0, 7.1.1 Oct 13, 2016
CVE-2017-0414 A-32807795 Hoch All 6.0, 6.0.1, 7.0, 7.1.1 Nov 10, 2016

Information disclosure vulnerability in Framework APIs

An information disclosure vulnerability in the Framework APIs could enable a local malicious application to bypass operating system protections that isolate application data from other applications. This issue is rated as High because it could be used to gain access to data that the application does not have access to.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0421 A-32555637 Hoch All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google internal

Denial of service vulnerability in Bionic DNS

A denial of service vulnerability in Bionic DNS could enable a remote attacker to use a specially crafted network packet to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0422 A-32322088 Hoch All 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 20, 2016

Elevation of privilege vulnerability in Bluetooth

An elevation of privilege vulnerability in Bluetooth could enable a proximate attacker to manage access to documents on the device. This issue is rated as Moderate because it first requires exploitation of a separate vulnerability in the Bluetooth stack.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0423 A-32612586 Mäßig All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Nov 2, 2016

Information disclosure vulnerability in AOSP Messaging

An information disclosure vulnerability in AOSP Messaging could enable a remote attacker using a special crafted file to access data outside of its permission levels. This issue is rated as Moderate because it is a general bypass for a user level defense in depth or exploit mitigation technology in a privileged process.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0424 A-32322450 Mäßig All 6.0, 6.0.1, 7.0, 7.1.1 Oct 20, 2016

Information disclosure vulnerability in Audioserver

An information disclosure vulnerability in Audioserver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it could be used to access sensitive data without permission.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0425 A-32720785 Mäßig All 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Nov 7, 2016

Information disclosure vulnerability in Filesystem

An information disclosure vulnerability in the Filesystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it could be used to access sensitive data without permission.

CVE References Schwere Updated Google devices Updated AOSP versions Datum gemeldet
CVE-2017-0426 A-32799236 [ 2 ] Mäßig All 7.0, 7.1.1 Google internal

2017-02-05 security patch level—Vulnerability details

In the sections below, we provide details for each of the security vulnerabilities that apply to the 2017-02-05 patch level. There is a description of the issue, a severity rationale, and a table with the CVE, associated references, severity, updated Google devices, updated AOSP versions (where applicable), and date reported. When available, we will link the public change that addressed the issue to the bug ID, like the AOSP change list. When multiple changes relate to a single bug, additional references are linked to numbers following the bug ID.

Remote code execution vulnerability in Qualcomm crypto driver

A remote code execution vulnerability in the Qualcomm crypto driver could enable a remote attacker to execute arbitrary code within the context of the kernel. This issue is rated as Critical due to the possibility of remote code execution in the context of the kernel.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2016-8418 A-32652894
QC-CR#1077457
Kritisch None* Oct 10, 2016

* Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Critical due to the possibility of a local permanent device compromise, which may require reflashing the operating system to repair the device.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0427 A-31495866* Kritisch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 13, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of privilege vulnerability in NVIDIA GPU driver

An elevation of privilege vulnerability in the NVIDIA GPU driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Critical due to the possibility of a local permanent device compromise, which may require reflashing the operating system to repair the device.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0428 A-32401526*
N-CVE-2017-0428
Kritisch Nexus 9 Oct 25, 2016
CVE-2017-0429 A-32636619*
N-CVE-2017-0429
Kritisch Nexus 9 Nov 3, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of privilege vulnerability in kernel networking subsystem

An elevation of privilege vulnerability in the kernel networking subsystem could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Critical due to the possibility of a local permanent device compromise, which may require reflashing the operating system to repair the device.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2014-9914 A-32882659
Upstream kernel
Kritisch Nexus 6, Nexus Player Nov 9, 2016

Elevation of privilege vulnerability in Broadcom Wi-Fi driver

An elevation of privilege vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Critical due to the possibility of a local permanent device compromise, which may require reflashing the operating system to repair the device.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0430 A-32838767*
B-RB#107459
Kritisch Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Google internal

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Vulnerabilities in Qualcomm components

The following vulnerability affects Qualcomm components and is described in further detail in Qualcomm AMSS September 2016 security bulletin.

CVE References Severity* Updated Google devices Datum gemeldet
CVE-2017-0431 A-32573899** Kritisch None*** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

*** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in MediaTek driver

An elevation of privilege vulnerability in the MediaTek driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0432 A-28332719*
M-ALPS02708925
Hoch None** Apr 21, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in Synaptics touchscreen driver

An elevation of privilege vulnerability in the Synaptics touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the touchscreen chipset. This issue is rated as High because it first requires compromising a privileged process.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0433 A-31913571* Hoch Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL Sep 8, 2016
CVE-2017-0434 A-33001936* Hoch Pixel, Pixel XL Nov 18, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of privilege vulnerability in Qualcomm Secure Execution Environment Communicator driver

An elevation of privilege vulnerability in the Qualcomm Secure Execution Environment Communicator drive could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2016-8480 A-31804432
QC-CR#1086186 [ 2 ]
Hoch Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Sep 28, 2016

Elevation of privilege vulnerability in Qualcomm sound driver

An elevation of privilege vulnerability in the Qualcomm sound driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2016-8481 A-31906415*
QC-CR#1078000
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL Oct 1, 2016
CVE-2017-0435 A-31906657*
QC-CR#1078000
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL Oct 1, 2016
CVE-2017-0436 A-32624661*
QC-CR#1078000
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL Nov 2, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of privilege vulnerability in Qualcomm Wi-Fi driver

An elevation of privilege vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0437 A-32402310
QC-CR#1092497
Hoch Nexus 5X, Pixel, Pixel XL Oct 25, 2016
CVE-2017-0438 A-32402604
QC-CR#1092497
Hoch Nexus 5X, Pixel, Pixel XL Oct 25, 2016
CVE-2017-0439 A-32450647
QC-CR#1092059
Hoch Nexus 5X, Pixel, Pixel XL Oct 25, 2016
CVE-2016-8419 A-32454494
QC-CR#1087209
Hoch Nexus 5X, Pixel, Pixel XL Oct 26, 2016
CVE-2016-8420 A-32451171
QC-CR#1087807
Hoch Nexus 5X, Pixel, Pixel XL Oct 26, 2016
CVE-2016-8421 A-32451104
QC-CR#1087797
Hoch Nexus 5X, Pixel, Pixel XL Oct 26, 2016
CVE-2017-0440 A-33252788
QC-CR#1095770
Hoch Nexus 5X, Pixel, Pixel XL Nov 11, 2016
CVE-2017-0441 A-32872662
QC-CR#1095009
Hoch Nexus 5X, Pixel, Pixel XL Nov 11, 2016
CVE-2017-0442 A-32871330
QC-CR#1092497
Hoch Nexus 5X, Pixel, Pixel XL Nov 13, 2016
CVE-2017-0443 A-32877494
QC-CR#1092497
Hoch Nexus 5X, Pixel, Pixel XL Nov 13, 2016
CVE-2016-8476 A-32879283
QC-CR#1091940
Hoch Nexus 5X, Pixel, Pixel XL Nov 14, 2016

Elevation of privilege vulnerability in Realtek sound driver

An elevation of privilege vulnerability in the Realtek sound driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0444 A-32705232* Hoch Nexus 9 Nov 7, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of privilege vulnerability in HTC touchscreen driver

An elevation of privilege vulnerability in the HTC touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0445 A-32769717* Hoch Pixel, Pixel XL Nov 9, 2016
CVE-2017-0446 A-32917445* Hoch Pixel, Pixel XL Nov 15, 2016
CVE-2017-0447 A-32919560* Hoch Pixel, Pixel XL Nov 15, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Information disclosure vulnerability in NVIDIA video driver

An information disclosure vulnerability in the NVIDIA video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0448 A-32721029*
N-CVE-2017-0448
Hoch Nexus 9 Nov 7, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of privilege vulnerability in Broadcom Wi-Fi driver

An elevation of privilege vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0449 A-31707909*
B-RB#32094
Mäßig Nexus 6, Nexus 6P Sep 23, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of privilege vulnerability in Audioserver

An elevation of privilege vulnerability in Audioserver could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as Moderate because it is mitigated by current platform configurations.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0450 A-32917432* Mäßig Nexus 9 Nov 15, 2016

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to bypass protections that prevent an escalation of privileges. This issue is rated as Moderate because it is a general bypass for a user level defense in depth or exploit mitigation technology.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2016-10044 A-31711619* Mäßig Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Google internal

* The patch for this issue is not publicly available. Das Update ist in den neuesten binären Treibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Information disclosure vulnerability in Qualcomm Secure Execution Environment Communicator

An information disclosure vulnerability in the Qualcomm Secure Execution Environment Communicator could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2016-8414 A-31704078
QC-CR#1076407
Mäßig Nexus 5X, Nexus 6P, Android One, Pixel, Pixel XL Sep 23, 2016

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Schwere Updated Google devices Datum gemeldet
CVE-2017-0451 A-31796345
QC-CR#1073129 [ 2 ]
Mäßig Nexus 5X, Nexus 6P, Android One, Pixel, Pixel XL Sep 27, 2016

Häufige Fragen und Antworten

This section answers common questions that may occur after reading this bulletin.

1. Wie kann ich feststellen, ob mein Gerät aktualisiert wurde, um diese Probleme zu beheben?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-02-01 or later address all issues associated with the 2017-02-01 security patch level.
  • Security patch levels of 2017-02-05 or later address all issues associated with the 2017-02-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-02-01]
  • [ro.build.version.security_patch]:[2017-02-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the February 1, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of February 5, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-02-01 and 2017-02-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisionen

  • February 06, 2017: Bulletin published.
  • February 08, 2017: Bulletin revised to include AOSP links.