Бюллетень по безопасности Android — ноябрь 2022 г.

Опубликовано 7 ноября 2022 г. | Обновлено 9 ноября 2022 г.

Бюллетень по безопасности Android содержит подробную информацию об уязвимостях безопасности, затрагивающих устройства Android. Уровни исправлений безопасности от 5 ноября 2022 г. или более поздние версии решают все эти проблемы. Чтобы узнать, как проверить уровень исправления безопасности устройства, см. раздел Проверка и обновление версии Android .

Партнеры Android уведомляются обо всех проблемах как минимум за месяц до публикации. Исправления исходного кода для этих проблем были выпущены в репозиторий Android Open Source Project (AOSP) и связаны с этим бюллетенем. Этот бюллетень также содержит ссылки на исправления вне AOSP.

Наиболее серьезной из этих проблем является уязвимость с высоким уровнем безопасности в компоненте Framework, которая может привести к локальному повышению привилегий без необходимости дополнительных привилегий на выполнение. Оценка серьезности основывается на возможном воздействии, которое может оказать использование уязвимости на уязвимом устройстве, при условии, что средства защиты платформы и служб отключены в целях разработки или успешно обойдены.

Подробные сведения о средствах защиты платформы безопасности Android и Google Play Protect, улучшающих безопасность платформы Android, см. в разделе «Смягчение последствий для Android и Google Play Protect».

Устранение последствий для Android и сервисов Google

Это сводка по смягчению последствий, предоставляемых платформой безопасности Android и средствами защиты сервисов, такими как Google Play Protect . Эти возможности снижают вероятность того, что уязвимости системы безопасности могут быть успешно использованы на Android.

  • Эксплуатация многих проблем на Android усложняется улучшениями в новых версиях платформы Android. Мы рекомендуем всем пользователям по возможности обновиться до последней версии Android.
  • Команда безопасности Android активно отслеживает злоупотребления с помощью Google Play Protect и предупреждает пользователей о потенциально опасных приложениях . Google Play Protect включен по умолчанию на устройствах с Google Mobile Services и особенно важен для пользователей, которые устанавливают приложения не из Google Play.

Сведения об уязвимости на уровне исправления безопасности от 1 ноября 2022 г.

В разделах ниже мы приводим подробные сведения о каждой уязвимости системы безопасности, применимой к уровню исправления 2022-11-01. Уязвимости сгруппированы по компонентам, на которые они влияют. Проблемы описаны в таблицах ниже и включают идентификатор CVE, связанные ссылки, тип уязвимости , серьезность и обновленные версии AOSP (где применимо). Если доступно, мы связываем общедоступное изменение, устраняющее проблему, с идентификатором ошибки, например, со списком изменений AOSP. Когда несколько изменений относятся к одной ошибке, дополнительные ссылки привязываются к номерам, следующим за идентификатором ошибки. Устройства с Android 10 и более поздних версий могут получать обновления безопасности, а также системные обновления Google Play .

Рамки

Самая серьезная уязвимость в этом разделе может привести к локальному повышению привилегий без необходимости дополнительных привилегий на выполнение.

CVE использованная литература Тип Строгость Обновленные версии AOSP
CVE-2022-2209 А-235601882 окончание срока действия Высокая 10, 11, 12, 12л, 13
CVE-2022-20441 А-238605611 окончание срока действия Высокая 10, 11, 12, 12л, 13
CVE-2022-20446 А-229793943 окончание срока действия Высокая 10, 11
CVE-2022-20448 А-237540408 окончание срока действия Высокая 10, 11, 12, 12л, 13
CVE-2022-20450 А-210065877 окончание срока действия Высокая 10, 11, 12, 12л, 13
CVE-2022-20452 А-240138318 окончание срока действия Высокая 13
CVE-2022-20457 А-243924784 окончание срока действия Высокая 13

Несколько компонентов

Уязвимость в этом разделе может привести к локальному отказу в обслуживании без дополнительных привилегий выполнения.

CVE использованная литература Тип Строгость Обновленные версии AOSP
CVE-2022-20426 А-236263294 [ 2 ] DoS Высокая 10, 11, 12, 12л, 13

Система

Самая серьезная уязвимость в этом разделе может привести к локальному повышению привилегий без необходимости дополнительных привилегий на выполнение.

CVE использованная литература Тип Строгость Обновленные версии AOSP
CVE-2022-20451 А-235098883 окончание срока действия Высокая 10, 11, 12, 12л, 13
CVE-2022-20454 А-242096164 окончание срока действия Высокая 10, 11, 12, 12л, 13
CVE-2022-20462 А-230356196 окончание срока действия Высокая 10, 11, 12, 12л, 13
CVE-2022-20465 А-218500036 окончание срока действия Высокая 10, 11, 12, 12л, 13
CVE-2022-20445 А-225876506 Я БЫ Высокая 10, 11, 12, 12л, 13
CVE-2022-20447 А-233604485 Я БЫ Высокая 13
CVE-2022-20414 А-234441463 [ 2 ] DoS Высокая 10, 11, 12, 12л, 13
CVE-2022-20453 А-240685104 DoS Высокая 10, 11, 12, 12л, 13

Системные обновления Google Play

Следующие проблемы включены в компоненты Project Mainline.

Подкомпонент CVE
Компоненты медиа-фреймворка CVE-2022-2209
Wi-Fi CVE-2022-20463

Сведения об уязвимости на уровне исправления безопасности от 5 ноября 2022 г.

В разделах ниже мы приводим подробные сведения о каждой уязвимости системы безопасности, применимой к уровню исправления 2022-11-05. Уязвимости сгруппированы по компонентам, на которые они влияют. Проблемы описаны в таблицах ниже и включают идентификатор CVE, связанные ссылки, тип уязвимости , серьезность и обновленные версии AOSP (где применимо). Если доступно, мы связываем общедоступное изменение, устраняющее проблему, с идентификатором ошибки, например, со списком изменений AOSP. Когда несколько изменений относятся к одной ошибке, дополнительные ссылки привязываются к номерам, следующим за идентификатором ошибки.

Технологии воображения

Эти уязвимости затрагивают компоненты Imagination Technologies, и дополнительную информацию можно получить непосредственно у Imagination Technologies. Оценка серьезности этих проблем предоставляется непосредственно компанией Imagination Technologies.

CVE использованная литература Строгость Подкомпонент
CVE-2021-1050 А-243825200 * Высокая PowerVR-графический процессор
CVE-2021-39661 А-246824784 * Высокая PowerVR-графический процессор

Компоненты MediaTek

Эти уязвимости затрагивают компоненты MediaTek, и дополнительную информацию можно получить непосредственно в MediaTek. Оценка серьезности этих проблем предоставляется непосредственно MediaTek.

CVE использованная литература Строгость Подкомпонент
CVE-2022-32601 А-234038598
М-АЛПС07319132 *
Высокая телефония
CVE-2022-32602 А-245050053
М-АЛПС07388790 *
Высокая установка ключей

Компоненты Унисок

Эти уязвимости затрагивают компоненты Unisoc, и дополнительную информацию можно получить непосредственно у Unisoc. Оценка серьезности этих проблем предоставляется непосредственно Unisoc.

CVE использованная литература Строгость Подкомпонент
CVE-2022-2984 А-244673210
У-1901978 *
Высокая ядро
CVE-2022-2985 А-244657985
U-1882490 *
Высокая Андроид
CVE-2022-38669 А-244666286
U-1883755 *
Высокая Андроид
CVE-2022-38670 А-244674480
U-1883755 *
Высокая Андроид
CVE-2022-39105 А-245210875
U-1830881 *
Высокая ядро
CVE-2022-38672 А-244684957
U-1957128 *
Высокая ядро
CVE-2022-38673 А-246482122
U-1957128 *
Высокая ядро
CVE-2022-38676 А-244683429
U-1908118 *
Высокая ядро
CVE-2022-38690 А-244109033
U-1914157 *
Высокая ядро

Компоненты Qualcomm

Эти уязвимости затрагивают компоненты Qualcomm и более подробно описаны в соответствующем бюллетене по безопасности Qualcomm или предупреждении о безопасности. Оценка серьезности этих проблем предоставляется непосредственно Qualcomm.

CVE использованная литература Строгость Подкомпонент
CVE-2022-25724 А-238106223
QC-CR#3090325 [ 2 ] [ 3 ]
Высокая Отображать
CVE-2022-25741 А-240972788
КК-CR#3147273
Высокая беспроводная сеть
CVE-2022-25743 А-240973083
QC-CR#3153406
Высокая Отображать

Компоненты Qualcomm с закрытым исходным кодом

Эти уязвимости затрагивают компоненты Qualcomm с закрытым исходным кодом и более подробно описаны в соответствующем бюллетене по безопасности Qualcomm или предупреждении о безопасности. Оценка серьезности этих проблем предоставляется непосредственно Qualcomm.

CVE использованная литература Строгость Подкомпонент
CVE-2021-35122 А-213239915 * Критический Компонент с закрытым исходным кодом
CVE-2021-35108 А-209469945 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35109 А-209469824 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35132 А-213240063 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35135 А-213239949 * Высокая Компонент с закрытым исходным кодом
CVE-2022-25671 А-231156429 * Высокая Компонент с закрытым исходным кодом
CVE-2022-33234 А-240971780 * Высокая Компонент с закрытым исходным кодом
CVE-2022-33236 А-240973180 * Высокая Компонент с закрытым исходным кодом
CVE-2022-33237 А-240972236 * Высокая Компонент с закрытым исходным кодом
CVE-2022-33239 А-240982982 * Высокая Компонент с закрытым исходным кодом

Общие вопросы и ответы

В этом разделе даны ответы на распространенные вопросы, которые могут возникнуть после прочтения этого бюллетеня.

1. Как определить, обновлено ли мое устройство для решения этих проблем?

Чтобы узнать, как проверить уровень исправления безопасности устройства, см. раздел Проверка и обновление версии Android .

  • Уровни исправлений безопасности 2022-11-01 или более поздние устраняют все проблемы, связанные с уровнем исправлений безопасности 2022-11-01.
  • Уровни исправлений безопасности 2022-11-05 или более поздние устраняют все проблемы, связанные с уровнем исправлений безопасности 2022-11-05 и всеми предыдущими уровнями исправлений.

Производители устройств, которые включают эти обновления, должны установить уровень строки исправления следующим образом:

  • [ro.build.version.security_patch]:[2022-11-01]
  • [ro.build.version.security_patch]:[2022-11-05]

Для некоторых устройств на Android 10 или более поздней версии системное обновление Google Play будет иметь строку даты, соответствующую уровню исправления безопасности 2022-11-01. Подробнее об установке обновлений безопасности см. в этой статье .

2. Почему в этом бюллетене два уровня исправлений безопасности?

В этом бюллетене есть два уровня исправлений безопасности, чтобы партнеры Android могли быстрее устранять подмножество уязвимостей, одинаковых для всех устройств Android. Партнерам Android рекомендуется исправить все проблемы, описанные в этом бюллетене, и использовать последний уровень исправлений безопасности.

  • Устройства, использующие уровень исправления безопасности 2022-11-01, должны содержать все проблемы, связанные с этим уровнем исправления безопасности, а также исправления для всех проблем, о которых сообщалось в предыдущих бюллетенях по безопасности.
  • Устройства, использующие уровень исправлений безопасности от 2022-11-05 или более поздних версий, должны включать все применимые исправления в этом (и предыдущих) бюллетенях по безопасности.

Партнерам рекомендуется объединять исправления для всех проблем, которые они решают, в одном обновлении.

3. Что означают записи в столбце Тип ?

Записи в столбце «Тип» таблицы сведений об уязвимостях ссылаются на классификацию уязвимости системы безопасности.

Сокращенное название Определение
РЦЭ Удаленное выполнение кода
окончание срока действия Повышение привилегий
Я БЫ Раскрытие информации
DoS Отказ в обслуживании
Н/Д Классификация недоступна

4. Что означают записи в столбце «Ссылки» ?

Записи в столбце «Ссылки» таблицы сведений об уязвимостях могут содержать префикс, идентифицирующий организацию, которой принадлежит эталонное значение.

Префикс Ссылка
А- Идентификатор ошибки Android
КК- Ссылочный номер Qualcomm
М- Справочный номер MediaTek
Н- Справочный номер NVIDIA
Б- Ссылочный номер Broadcom
У- Справочный номер ЮНИСОК

5. Что означает * рядом с идентификатором ошибки Android в столбце «Ссылки» ?

Проблемы, которые не являются общедоступными, отмечены * рядом с соответствующим идентификатором ссылки. Обновление для этой проблемы обычно содержится в последних двоичных драйверах для устройств Pixel, доступных на сайте Google Developer .

6. Почему уязвимости безопасности разделены между этим бюллетенем и бюллетенями по безопасности устройств/партнеров, такими как бюллетень Pixel?

Уязвимости безопасности, описанные в этом бюллетене по безопасности, необходимы для объявления последнего уровня исправления безопасности на устройствах Android. Дополнительные уязвимости безопасности, задокументированные в бюллетенях по безопасности устройств/партнеров, не требуются для объявления уровня исправления безопасности. Производители устройств Android и наборов микросхем также могут публиковать сведения об уязвимостях безопасности, характерных для их продуктов, таких как Google , Huawei , LGE , Motorola , Nokia или Samsung .

Версии

Версия Свидание Заметки
1,0 7 ноября 2022 г. Бюллетень опубликован
1.1 9 ноября 2022 г. В бюллетень добавлены ссылки на AOSP
2.0 7 декабря 2022 г. Пересмотренная таблица CVE