Boletín de seguridad de Android: enero de 2023

Publicado el 3 de enero de 2023 | Actualizado el 10 de enero de 2023

El Boletín de seguridad de Android contiene detalles de las vulnerabilidades de seguridad que afectan a los dispositivos Android. Los niveles de parche de seguridad del 2023-01-05 o posteriores solucionan todos estos problemas. Para saber cómo verificar el nivel del parche de seguridad de un dispositivo, consulte Verifique y actualice su versión de Android .

Los socios de Android reciben notificaciones de todos los problemas al menos un mes antes de su publicación. Los parches de código fuente para estos problemas se publicarán en el repositorio del Proyecto de código abierto de Android (AOSP) en las próximas 48 horas. Revisaremos este boletín con los enlaces de AOSP cuando estén disponibles.

El más grave de estos problemas es una vulnerabilidad de alta seguridad en el componente Framework que podría provocar una escalada local de privilegios sin necesidad de privilegios de ejecución adicionales. La evaluación de la gravedad se basa en el efecto que la explotación de la vulnerabilidad podría tener en un dispositivo afectado, suponiendo que las mitigaciones de la plataforma y el servicio estén desactivadas para fines de desarrollo o si se omiten con éxito.

Consulte la sección de mitigaciones de Android y Google Play Protect para obtener detalles sobre las protecciones de la plataforma de seguridad de Android y Google Play Protect, que mejoran la seguridad de la plataforma Android.

Mitigaciones de servicios de Android y Google

Este es un resumen de las mitigaciones proporcionadas por la plataforma de seguridad de Android y las protecciones de servicios como Google Play Protect . Estas capacidades reducen la probabilidad de que las vulnerabilidades de seguridad puedan explotarse con éxito en Android.

  • La explotación de muchos problemas en Android se vuelve más difícil debido a las mejoras en las versiones más recientes de la plataforma Android. Animamos a todos los usuarios a actualizar a la última versión de Android siempre que sea posible.
  • El equipo de seguridad de Android monitorea activamente el abuso a través de Google Play Protect y advierte a los usuarios sobre aplicaciones potencialmente dañinas . Google Play Protect está habilitado de forma predeterminada en dispositivos con servicios móviles de Google y es especialmente importante para los usuarios que instalan aplicaciones desde fuera de Google Play.

2023-01-01 Detalles de vulnerabilidad a nivel del parche de seguridad

En las secciones siguientes, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2023-01-01. Las vulnerabilidades se agrupan según el componente al que afectan. Los problemas se describen en las tablas siguientes e incluyen ID de CVE, referencias asociadas, tipo de vulnerabilidad , gravedad y versiones actualizadas de AOSP (cuando corresponda). Cuando esté disponible, vinculamos el cambio público que solucionó el problema con el ID del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales están vinculadas a números que siguen al ID del error. Los dispositivos con Android 10 y posteriores pueden recibir actualizaciones de seguridad, así como actualizaciones del sistema Google Play .

Estructura

La vulnerabilidad más grave en esta sección podría provocar una escalada de privilegios local sin necesidad de privilegios de ejecución adicionales.

CVE Referencias Tipo Gravedad Versiones AOSP actualizadas
CVE-2022-20456 A-242703780 EoP Alto 10, 11, 12, 12L, 13
CVE-2022-20489 A-242703460 EoP Alto 10, 11, 12, 12L, 13
CVE-2022-20490 A-242703505 EoP Alto 10, 11, 12, 12L, 13
CVE-2022-20492 A-242704043 EoP Alto 10, 11, 12, 12L, 13
CVE-2022-20493 A-242846316 EoP Alto 10, 11, 12, 12L, 13
CVE-2023-20912 A-246301995 EoP Alto 13
CVE-2023-20916 A-229256049 EoP Alto 12, 12L
CVE-2023-20919 A-252663068 EoP Alto 13
CVE-2023-20920 A-204584366 EoP Alto 10, 11, 12, 12L, 13
CVE-2023-20921 A-243378132 EoP Alto 10, 11, 12, 12L, 13
CVE-2022-20494 A-243794204 DoS Alto 10, 11, 12, 12L, 13
CVE-2023-20922 A-237291548 DoS Alto 11, 12, 12L, 13

Sistema

La vulnerabilidad más grave en esta sección podría provocar una escalada local de privilegios de BLE sin necesidad de privilegios de ejecución adicionales.

CVE Referencias Tipo Gravedad Versiones AOSP actualizadas
CVE-2022-20461 A-228602963 EoP Alto 10, 11, 12, 12L, 13
CVE-2023-20904 A-246300272 EoP Alto 12L, 13
CVE-2023-20905 A-241387741 EoP Alto 10
CVE-2023-20913 A-246933785 EoP Alto 10, 11, 12, 12L, 13
CVE-2023-20915 A-246930197 EoP Alto 10, 11, 12, 12L, 13

Actualizaciones del sistema Google Play

Los siguientes problemas están incluidos en los componentes de Project Mainline.

Subcomponente CVE
Proveedor de medios CVE-2023-20912

2023-01-05 Detalles de vulnerabilidad a nivel de parche de seguridad

En las secciones siguientes, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2023-01-05. Las vulnerabilidades se agrupan según el componente al que afectan. Los problemas se describen en las tablas siguientes e incluyen ID de CVE, referencias asociadas, tipo de vulnerabilidad , gravedad y versiones actualizadas de AOSP (cuando corresponda). Cuando esté disponible, vinculamos el cambio público que solucionó el problema con el ID del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales están vinculadas a números que siguen al ID del error.

Núcleo

La vulnerabilidad más grave de esta sección podría provocar la ejecución remota de código sin necesidad de privilegios de ejecución adicionales.

CVE Referencias Tipo Gravedad Subcomponente
CVE-2022-42719 A-253642087
Kernel ascendente [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ 7 ] [ 8 ] [ 9 ] [ 10 ] [ 11 ] [ 12 ] [ 13 ] [ 14 ]
RCE Crítico mac80211
CVE-2022-42720 A-253642015
Kernel ascendente [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ 7 ] [ 8 ] [ 9 ] [ 10 ] [ 11 ] [ 12 ] [ 13 ] [ 14 ]
RCE Crítico WiFi
CVE-2022-42721 A-253642088
Kernel ascendente [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ 7 ] [ 8 ] [ 9 ] [ 10 ] [ 11 ] [ 12 ] [ 13 ] [ 14 ]
RCE Crítico Múltiples módulos
CVE-2022-2959 A-244395411
Núcleo ascendente
EoP Alto Tubo

Componentes del núcleo

La vulnerabilidad más grave de esta sección podría provocar la ejecución remota de código sin necesidad de privilegios de ejecución adicionales.

CVE Referencias Tipo Gravedad Subcomponente
CVE-2022-41674 A-253641805
Kernel ascendente [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ 7 ] [ 8 ] [ 9 ] [ 10 ] [ 11 ] [ 12 ] [ 13 ] [ 14 ]
RCE Crítico WiFi
CVE-2023-20928 A-254837884
Núcleo ascendente
EoP Alto conductor de carpeta

LTS del núcleo

Se han actualizado las siguientes versiones del kernel. Las actualizaciones de la versión del kernel dependen de la versión del sistema operativo Android en el momento de iniciar el dispositivo.

Referencias Versión de lanzamiento de Android Versión mínima del kernel
A-224575820 12 5.10.101

Tecnologías de la imaginación

Esta vulnerabilidad afecta a los componentes de Imagination Technologies y hay más detalles disponibles directamente en Imagination Technologies. La evaluación de la gravedad de este problema la proporciona directamente Imagination Technologies.

CVE Referencias Gravedad Subcomponente
CVE-2022-20235
A-259967780 * Alto GPU PowerVR

Componentes de MediaTek

Estas vulnerabilidades afectan a los componentes de MediaTek y hay más detalles disponibles directamente en MediaTek. MediaTek proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Gravedad Subcomponente
CVE-2022-32635
A-257714327
M-ALPS07573237 *
Alto GPS
CVE-2022-32636
A-257846591
M-ALPS07510064 *
Alto instalación de claves
CVE-2022-32637
A-257860658
M-ALPS07491374 *
Alto decodificador hevc

Componentes Unisoc

Estas vulnerabilidades afectan a los componentes de Unisoc y hay más detalles disponibles directamente en Unisoc. La evaluación de la gravedad de estos problemas la proporciona directamente Unisoc.

CVE Referencias Gravedad Subcomponente
CVE-2022-44425
A-258731891
U-2028856 *
Alto Núcleo
CVE-2022-44426
A-258728978
U-2028856 *
Alto Núcleo
CVE-2022-44427
A-258736883
U-1888565 *
Alto Núcleo
CVE-2022-44428
A-258741356
U-1888565 *
Alto Núcleo
CVE-2022-44429
A-258743555
U-1981296 *
Alto Núcleo
CVE-2022-44430
A-258749708
U-1888565 *
Alto Núcleo
CVE-2022-44431
A-258741360
U-1981296 *
Alto Núcleo
CVE-2022-44432
A-258743558
U-1981296 *
Alto Núcleo
CVE-2022-44434
A-258760518
U-2064988 *
Alto Androide
CVE-2022-44435
A-258759189
U-2064988 *
Alto Androide
CVE-2022-44436
A-258760519
U-2064988 *
Alto Androide
CVE-2022-44437
A-258759192
U-2064988 *
Alto Androide
CVE-2022-44438
A-258760781
U-2064988 *
Alto Androide

Componentes de Qualcomm

Estas vulnerabilidades afectan a los componentes de Qualcomm y se describen con más detalle en el boletín de seguridad o alerta de seguridad correspondiente de Qualcomm. Qualcomm proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Gravedad Subcomponente
CVE-2022-22088
A-231156521
Control de calidad-CR#3052411
Crítico Bluetooth
CVE-2022-33255
A-250627529
Control de calidad-CR#3212699
Alto Bluetooth

Componentes de código cerrado de Qualcomm

Estas vulnerabilidades afectan a los componentes de código cerrado de Qualcomm y se describen con más detalle en el boletín de seguridad o alerta de seguridad correspondiente de Qualcomm. Qualcomm proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Gravedad Subcomponente
CVE-2021-35097
A-209469821 * Crítico Componente de código cerrado
CVE-2021-35113
A-209469998 * Crítico Componente de código cerrado
CVE-2021-35134
A-213239776 * Crítico Componente de código cerrado
CVE-2022-23960
A-238203772 * Alto Componente de código cerrado
CVE-2022-25725
A-238101314 * Alto Componente de código cerrado
CVE-2022-25746
A-238106983 * Alto Componente de código cerrado
CVE-2022-33252
A-250627159 * Alto Componente de código cerrado
CVE-2022-33253
A-250627591 * Alto Componente de código cerrado
CVE-2022-33266
A-250627569 * Alto Componente de código cerrado
CVE-2022-33274
A-250627236 * Alto Componente de código cerrado
CVE-2022-33276
A-250627271 * Alto Componente de código cerrado
CVE-2022-33283
A-250627602 * Alto Componente de código cerrado
CVE-2022-33284
A-250627218 * Alto Componente de código cerrado
CVE-2022-33285
A-250627435 * Alto Componente de código cerrado
CVE-2022-33286
A-250627240 * Alto Componente de código cerrado

Preguntas y respuestas comunes

Esta sección responde a preguntas comunes que pueden surgir después de leer este boletín.

1. ¿Cómo puedo determinar si mi dispositivo está actualizado para solucionar estos problemas?

Para saber cómo verificar el nivel del parche de seguridad de un dispositivo, consulte Verifique y actualice su versión de Android .

  • Los niveles de parche de seguridad de 2023-01-01 o posteriores abordan todos los problemas asociados con el nivel de parche de seguridad 2023-01-01.
  • Los niveles de parche de seguridad de 2023-01-05 o posteriores abordan todos los problemas asociados con el nivel de parche de seguridad de 2023-01-05 y todos los niveles de parche anteriores.

Los fabricantes de dispositivos que incluyen estas actualizaciones deben establecer el nivel de cadena de parche en:

  • [ro.build.version.security_patch]:[2023-01-01]
  • [ro.build.version.security_patch]:[2023-01-05]

Para algunos dispositivos con Android 10 o posterior, la actualización del sistema Google Play tendrá una cadena de fecha que coincide con el nivel del parche de seguridad 2023-01-01. Consulte este artículo para obtener más detalles sobre cómo instalar actualizaciones de seguridad.

2. ¿Por qué este boletín tiene dos niveles de parches de seguridad?

Este boletín tiene dos niveles de parches de seguridad para que los socios de Android tengan la flexibilidad de corregir un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android más rápidamente. Se recomienda a los socios de Android que solucionen todos los problemas de este boletín y utilicen el último nivel de parche de seguridad.

  • Los dispositivos que utilizan el nivel de parche de seguridad 2023-01-01 deben incluir todos los problemas asociados con ese nivel de parche de seguridad, así como correcciones para todos los problemas informados en boletines de seguridad anteriores.
  • Los dispositivos que utilizan el nivel de parche de seguridad 2023-01-05 o posterior deben incluir todos los parches aplicables en este (y en los anteriores) boletines de seguridad.

Se anima a los socios a agrupar las correcciones de todos los problemas que abordan en una única actualización.

3. ¿Qué significan las entradas en la columna Tipo ?

Las entradas en la columna Tipo de la tabla de detalles de la vulnerabilidad hacen referencia a la clasificación de la vulnerabilidad de seguridad.

Abreviatura Definición
RCE Ejecución remota de código
EoP Elevación de privilegios
IDENTIFICACIÓN Divulgación de información
DoS Negación de servicio
N / A Clasificación no disponible

4. ¿Qué significan las entradas en la columna Referencias ?

Las entradas en la columna Referencias de la tabla de detalles de la vulnerabilidad pueden contener un prefijo que identifique la organización a la que pertenece el valor de referencia.

Prefijo Referencia
A- ID de error de Android
control de calidad Número de referencia de Qualcomm
METRO- Número de referencia de MediaTek
NORTE- Número de referencia de NVIDIA
B- Número de referencia de Broadcom
U- Número de referencia UNISOC

5. ¿Qué significa un * junto al ID de error de Android en la columna Referencias ?

Los números que no están disponibles públicamente tienen un * junto al ID de referencia correspondiente. La actualización para ese problema generalmente se encuentra en los controladores binarios más recientes para dispositivos Pixel disponibles en el sitio para desarrolladores de Google .

6. ¿Por qué las vulnerabilidades de seguridad se dividen entre este boletín y los boletines de seguridad de dispositivos/socios, como el boletín de Pixel?

Las vulnerabilidades de seguridad que se documentan en este boletín de seguridad deben declarar el nivel de parche de seguridad más reciente en dispositivos Android. Las vulnerabilidades de seguridad adicionales que están documentadas en los boletines de seguridad del dispositivo/socio no son necesarias para declarar un nivel de parche de seguridad. Los fabricantes de dispositivos y chipsets Android también pueden publicar detalles de vulnerabilidades de seguridad específicas de sus productos, como Google , Huawei , LGE , Motorola , Nokia o Samsung .

Versiones

Versión Fecha Notas
1.0 3 de enero de 2023 Boletín publicado
2.0 10 de enero de 2023 Tabla CVE revisada
2.1 1 de febrero de 2023 Tabla CVE revisada