Bollettino sulla sicurezza Android: febbraio 2019

Pubblicato il 4 febbraio 2019

Il Bollettino sulla sicurezza di Android contiene dettagli sulle vulnerabilità della sicurezza che interessano i dispositivi Android. I livelli delle patch di sicurezza del 05-02-2019 o successivi risolvono tutti questi problemi. Per informazioni su come verificare il livello delle patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

I partner Android vengono informati di tutti i problemi almeno un mese prima della pubblicazione. Le patch del codice sorgente per questi problemi sono state rilasciate nel repository Android Open Source Project (AOSP) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch esterne a AOSP.

Il più grave di questi problemi è una vulnerabilità critica della sicurezza nel Framework che potrebbe consentire a un utente malintenzionato remoto che utilizza un file PNG appositamente predisposto per eseguire codice arbitrario nel contesto di un processo privilegiato. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, presupponendo che le mitigazioni della piattaforma e del servizio siano disattivate per scopi di sviluppo o se aggirate con successo.

Non abbiamo ricevuto segnalazioni di sfruttamento o abuso attivo da parte dei clienti riguardo a questi problemi appena segnalati. Fare riferimento alla sezione Mitigazioni per Android e Google Play Protect per dettagli sulle protezioni della piattaforma di sicurezza Android e Google Play Protect, che migliorano la sicurezza della piattaforma Android.

Nota: le informazioni sull'ultimo aggiornamento OTA (over-the-air) e sulle immagini del firmware per i dispositivi Google sono disponibili nel bollettino di aggiornamento Pixel di febbraio 2019 .

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle mitigazioni fornite dalla piattaforma di sicurezza Android e dalle protezioni dei servizi come Google Play Protect . Queste funzionalità riducono la probabilità che le vulnerabilità della sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento di molti problemi su Android è reso più difficile dai miglioramenti apportati alle versioni più recenti della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android, ove possibile.
  • Il team di sicurezza di Android monitora attivamente eventuali abusi tramite Google Play Protect e avvisa gli utenti in merito alle applicazioni potenzialmente dannose . Google Play Protect è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano app esterne a Google Play.

Dettagli sulla vulnerabilità a livello di patch di sicurezza del 2019-02-01

Nelle sezioni seguenti, forniamo dettagli per ciascuna delle vulnerabilità della sicurezza che si applicano al livello di patch 2019-02-01. Le vulnerabilità sono raggruppate in base al componente che interessano. È presente una descrizione del problema e una tabella con CVE, riferimenti associati, tipo di vulnerabilità , gravità e versioni AOSP aggiornate (ove applicabile). Se disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID del bug.

Struttura

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di utilizzare un file PNG appositamente predisposto per eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2019-1986 A-117838472 [ 2 ] RCE Critico 9
CVE-2019-1987 A-118143775 [ 2 ] RCE Critico 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-1988 A-118372692 RCE Critico 8.0, 8.1, 9

Biblioteca

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di utilizzare un file appositamente predisposto per eseguire codice arbitrario nel contesto di un processo non privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2017-17760 A-78029030 * RCE Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2018-5268 A-78029634 * RCE Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2018-5269 A-78029727 * RCE Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2017-18009 A-78026242 * ID Moderare 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9

Sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di utilizzare una trasmissione appositamente predisposta per eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2019-1991 A-110166268 RCE Critico 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-1992 A-116222069 RCE Critico 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-1993 A-119819889 EoP Alto 8.0, 8.1, 9
CVE-2019-1994 A-117770924 EoP Alto 8.0, 8.1, 9
CVE-2019-1995 A-32589229 [ 2 ] ID Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-1996 A-111451066 ID Alto 8.0, 8.1, 9
CVE-2019-1997 A-117508900 ID Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-1998 A-116055338 [ 2 ] DoS Alto 9

2019-02-05 Dettagli sulla vulnerabilità a livello di patch di sicurezza

Nelle sezioni seguenti, forniamo dettagli per ciascuna delle vulnerabilità della sicurezza che si applicano al livello di patch 2019-02-05. Le vulnerabilità sono raggruppate in base al componente che interessano e includono dettagli come CVE, riferimenti associati, tipo di vulnerabilità , gravità , componente (ove applicabile) e versioni AOSP aggiornate (ove applicabile). Se disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID del bug.

Componenti del kernel

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-10879 A-116406063
Kernel a monte
EoP Alto file system ext4
CVE-2019-1999 A-120025196 * EoP Alto Driver del raccoglitore
CVE-2019-2000 A-120025789 * EoP Alto Driver del raccoglitore
CVE-2019-2001 A-117422211 * ID Alto iomem

Componenti NVIDIA

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di utilizzare un file appositamente predisposto per eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-6271 A-80198474 * RCE Critico libnvomx
CVE-2018-6267 A-70857947 * EoP Alto libnvomx
CVE-2018-6268 A-80433161 * EoP Alto libnvomx
CVE-2016-6684 A-117423758 * ID Alto registro del kernel

Componenti Qualcomm

Queste vulnerabilità interessano i componenti Qualcomm e sono descritte in maggiore dettaglio nel bollettino di sicurezza o nell'avviso di sicurezza di Qualcomm appropriato. La valutazione della gravità di questi problemi viene fornita direttamente da Qualcomm.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-11262 A-76424945
QC-CR#2221192
N / A Critico boot loader
CVE-2018-11280 A-109741776
QC-CR#2185061
N / A Alto Modem
CVE-2018-11275 A-74409078
QC-CR#2221256 [ 2 ]
N / A Alto Boot loader
CVE-2018-13900 A-119052051
QC-CR#2287499
N / A Alto Modem
CVE-2018-13905 A-119052050
QC-CR#2225202
N / A Alto Grafica

Componenti closed source di Qualcomm

Queste vulnerabilità interessano i componenti Qualcomm e sono descritte in maggiore dettaglio nel bollettino di sicurezza o nell'avviso di sicurezza di Qualcomm appropriato. La valutazione della gravità di questi problemi viene fornita direttamente da Qualcomm.

CVE Riferimenti Tipo Gravità Componente
CVE-2018-11289 A-109678453 * N / A Critico Componente closed source
CVE-2018-11820 A-111089815 * N / A Critico Componente closed source
CVE-2018-11938 A-112279482 * N / A Critico Componente closed source
CVE-2018-11945 A-112278875 * N / A Critico Componente closed source
CVE-2018-11268 A-109678259 * N / A Alto Componente closed source
CVE-2018-11845 A-111088838 * N / A Alto Componente closed source
CVE-2018-11864 A-111092944 * N / A Alto Componente closed source
CVE-2018-11921 A-112278972 * N / A Alto Componente closed source
CVE-2018-11931 A-112279521 * N / A Alto Componente closed source
CVE-2018-11932 A-112279426 * N / A Alto Componente closed source
CVE-2018-11935 A-112279483 * N / A Alto Componente closed source
CVE-2018-11948 A-112279144 * N / A Alto Componente closed source
CVE-2018-5839 A-112279544 * N / A Alto Componente closed source
CVE-2018-13904 A-119050566 * N / A Alto Componente closed source

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che potrebbero sorgere dopo aver letto questo bollettino.

1. Come posso determinare se il mio dispositivo è aggiornato per risolvere questi problemi?

Per informazioni su come verificare il livello delle patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

  • I livelli delle patch di sicurezza del 01-02-2019 o successivi risolvono tutti i problemi associati al livello delle patch di sicurezza del 01-02-2019.
  • I livelli di patch di sicurezza del 05-02-2019 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 05-02-2019 e a tutti i livelli di patch precedenti.

I produttori di dispositivi che includono questi aggiornamenti dovrebbero impostare il livello della stringa di patch su:

  • [ro.build.version.security_patch]:[2019-02-01]
  • [ro.build.version.security_patch]:[2019-02-05]

2. Perché questo bollettino prevede due livelli di patch di sicurezza?

Questo bollettino prevede due livelli di patch di sicurezza in modo che i partner Android abbiano la flessibilità necessaria per correggere più rapidamente un sottoinsieme di vulnerabilità simili su tutti i dispositivi Android. I partner Android sono incoraggiati a risolvere tutti i problemi presenti in questo bollettino e a utilizzare il livello di patch di sicurezza più recente.

  • I dispositivi che utilizzano il livello di patch di sicurezza 2019-02-01 devono includere tutti i problemi associati a tale livello di patch di sicurezza, nonché le correzioni per tutti i problemi segnalati nei bollettini di sicurezza precedenti.
  • I dispositivi che utilizzano il livello di patch di sicurezza del 05-02-2019 o successivo devono includere tutte le patch applicabili in questo (e nei precedenti) bollettini sulla sicurezza.

I partner sono incoraggiati a raggruppare le correzioni per tutti i problemi che stanno affrontando in un unico aggiornamento.

3. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice remoto
EoP Elevazione dei privilegi
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

4. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
QC- Numero di riferimento di Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom

5. Cosa significa un * accanto all'ID del bug Android nella colonna Riferimenti ?

I problemi che non sono disponibili pubblicamente hanno un * accanto all'ID del bug Android nella colonna Riferimenti . L'aggiornamento per questo problema è generalmente contenuto negli ultimi driver binari per i dispositivi Pixel disponibili sul sito degli sviluppatori di Google .

6. Perché le vulnerabilità della sicurezza sono suddivise tra questo bollettino e i bollettini sulla sicurezza dei dispositivi/partner, come il bollettino Pixel?

Le vulnerabilità della sicurezza documentate in questo bollettino sulla sicurezza sono necessarie per dichiarare il livello di patch di sicurezza più recente sui dispositivi Android. Ulteriori vulnerabilità di sicurezza documentate nei bollettini sulla sicurezza del dispositivo/del partner non sono necessarie per dichiarare un livello di patch di sicurezza. I produttori di dispositivi e chipset Android sono incoraggiati a documentare la presenza di altre correzioni sui propri dispositivi tramite i propri siti Web di sicurezza, come i bollettini di sicurezza Samsung , LGE o Pixel .

Versioni

Versione Data Appunti
1.0 4 febbraio 2019 Pubblicato il bollettino