Bollettino sulla sicurezza Android: agosto 2016

Pubblicato il 01 agosto 2016 | Aggiornato il 21 ottobre 2016

L'Android Security Bulletin contiene i dettagli delle vulnerabilità di sicurezza che interessano i dispositivi Android. Oltre al bollettino, abbiamo rilasciato un aggiornamento di sicurezza per i dispositivi Nexus tramite un aggiornamento over-the-air (OTA). Le immagini del firmware Nexus sono state rilasciate anche al sito degli sviluppatori di Google . I livelli di patch di sicurezza del 5 agosto 2016 o successivi risolvono questi problemi. Fare riferimento alla documentazione per informazioni su come controllare il livello di patch di sicurezza.

I partner sono stati informati dei problemi descritti nel bollettino il 6 luglio 2016 o prima. Ove applicabile, le patch del codice sorgente per questi problemi sono state rilasciate nel repository Android Open Source Project (AOSP). Questo bollettino include anche collegamenti a patch al di fuori di AOSP.

Il più grave di questi problemi è una vulnerabilità di sicurezza critica che potrebbe consentire l'esecuzione di codice in modalità remota su un dispositivo interessato tramite più metodi come e-mail, navigazione Web e MMS durante l'elaborazione di file multimediali. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, supponendo che la piattaforma e le attenuazioni del servizio siano disabilitate per scopi di sviluppo o se bypassate correttamente.

Non abbiamo avuto segnalazioni di sfruttamento attivo da parte dei clienti o abuso di questi problemi appena segnalati. Fare riferimento alla sezione sulle attenuazioni dei servizi Android e Google per i dettagli sulle protezioni della piattaforma di sicurezza Android e sulle protezioni dei servizi come SafetyNet, che migliorano la sicurezza della piattaforma Android.

Invitiamo tutti i clienti ad accettare questi aggiornamenti sui propri dispositivi.

Annunci

  • Bollettino rivisto per correggere CVE-2016-3856 in CVE-2016-2060.
  • Questo bollettino contiene due stringhe a livello di patch di sicurezza per fornire ai partner Android la flessibilità di spostarsi più rapidamente per correggere un sottoinsieme di vulnerabilità simili su tutti i dispositivi Android. Per ulteriori informazioni, vedere Domande e risposte comuni :
    • 01-08-2016 : Stringa del livello di patch di sicurezza parziale. Questa stringa di livello di patch di sicurezza indica che tutti i problemi associati a 2016-08-01 (e tutte le precedenti stringhe di livello di patch di sicurezza) sono stati risolti.
    • 05-08-2016 : Completa la stringa del livello di patch di sicurezza. Questa stringa del livello di patch di sicurezza indica che tutti i problemi associati a 2016-08-01 e 2016-08-05 (e tutte le precedenti stringhe di livello di patch di sicurezza) sono stati risolti.
  • I dispositivi Nexus supportati riceveranno un singolo aggiornamento OTA con il livello di patch di sicurezza del 05 agosto 2016.

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle attenuazioni fornite dalla piattaforma di sicurezza Android e dalle protezioni del servizio come SafetyNet. Queste funzionalità riducono la probabilità che le vulnerabilità della sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle versioni più recenti della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android, ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi con Verify Apps e SafetyNet , progettati per avvisare gli utenti di applicazioni potenzialmente dannose . Verifica app è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano applicazioni al di fuori di Google Play. Gli strumenti di rooting dei dispositivi sono vietati all'interno di Google Play, ma Verifica app avvisa gli utenti quando tentano di installare un'applicazione di rooting rilevata, indipendentemente da dove provenga. Inoltre, Verifica app tenta di identificare e bloccare l'installazione di applicazioni dannose note che sfruttano una vulnerabilità di escalation dei privilegi. Se tale applicazione è già stata installata, Verifica app avviserà l'utente e tenterà di rimuovere l'applicazione rilevata.
  • A seconda dei casi, le applicazioni Google Hangouts e Messenger non passano automaticamente i file multimediali a processi come Mediaserver.

Ringraziamenti

Vorremmo ringraziare questi ricercatori per il loro contributo:

Vorremmo ringraziare Daniel Micay di Copperhead Security, Jeff Vander Stoep e Yabin Cui di Google per il loro contributo di aggiornamenti a livello di piattaforma per mitigare una classe di vulnerabilità come CVE-2016-3843. Questa mitigazione si basa sul lavoro di Brad Spengler di Grsecurity.

Livello patch di sicurezza 01-08-2016: dettagli sulla vulnerabilità della sicurezza

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2016-08-01. C'è una descrizione del problema, una logica di gravità e una tabella con il CVE, i riferimenti associati, la gravità, i dispositivi Nexus aggiornati, le versioni AOSP aggiornate (ove applicabile) e la data segnalata. Quando disponibile, collegheremo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug.

Vulnerabilità dell'esecuzione di codice in modalità remota in Mediaserver

Una vulnerabilità legata all'esecuzione di codice in modalità remota in Mediaserver potrebbe consentire a un utente malintenzionato che utilizza un file appositamente predisposto di causare il danneggiamento della memoria durante l'elaborazione di file multimediali e dati. Questo problema è considerato Critico a causa della possibilità di esecuzione di codice in modalità remota nel contesto del processo Mediaserver. Il processo Mediaserver ha accesso a flussi audio e video, nonché accesso a privilegi a cui normalmente le app di terze parti non potrebbero accedere.

La funzionalità interessata è fornita come parte fondamentale del sistema operativo e sono disponibili più applicazioni che consentono di raggiungerla con contenuti remoti, in particolare MMS e riproduzione di file multimediali tramite browser.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3819 A-28533562 Critico Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2 maggio 2016
CVE-2016-3820 A-28673410 Critico Tutto Nexus 6.0, 6.0.1 6 maggio 2016
CVE-2016-3821 A-28166152 Critico Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Vulnerabilità dell'esecuzione di codice in modalità remota in libjhead

Una vulnerabilità legata all'esecuzione di codice in modalità remota in libjhead potrebbe consentire a un utente malintenzionato che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo senza privilegi. Questo problema è classificato come Alto a causa della possibilità di esecuzione di codice in modalità remota nelle applicazioni che utilizzano questa libreria.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3822 A-28868315 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Elevazione della vulnerabilità dei privilegi in Mediaserver

Una vulnerabilità legata all'acquisizione di privilegi più elevati in Mediaserver potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato. Questo problema è classificato come Alto perché potrebbe essere utilizzato per ottenere l'accesso locale a funzionalità elevate, che normalmente non sono accessibili a un'applicazione di terze parti.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3823 A-28815329 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 17 maggio 2016
CVE-2016-3824 A-28816827 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 17 maggio 2016
CVE-2016-3825 A-28816964 Alto Tutto Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 17 maggio 2016
CVE-2016-3826 A-29251553 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 9 giugno 2016

Vulnerabilità Denial of Service in Mediaserver

Una vulnerabilità Denial of Service in Mediaserver potrebbe consentire a un utente malintenzionato che utilizza un file appositamente predisposto di causare il blocco o il riavvio di un dispositivo. Questo problema è classificato come Alto a causa della possibilità di una negazione del servizio remota temporanea.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3827 A-28816956 Alto Tutto Nexus 6.0.1 16 maggio 2016
CVE-2016-3828 A-28835995 Alto Tutto Nexus 6.0, 6.0.1 17 maggio 2016
CVE-2016-3829 A-29023649 Alto Tutto Nexus 6.0, 6.0.1 27 maggio 2016
CVE-2016-3830 A-29153599 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Vulnerabilità Denial of Service nell'orologio di sistema

Una vulnerabilità Denial of Service nell'orologio di sistema potrebbe consentire a un utente malintenzionato remoto di arrestare il dispositivo in modo anomalo. Questo problema è classificato come Alto a causa della possibilità di una negazione del servizio remota temporanea.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3831 A-29083635 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 31 maggio 2016

Elevazione della vulnerabilità dei privilegi nelle API del framework

Una vulnerabilità legata all'acquisizione di privilegi più elevati nelle API del framework potrebbe consentire a un'applicazione dannosa locale di aggirare le protezioni del sistema operativo che isolano i dati dell'applicazione da altre applicazioni. Questo problema è classificato come moderato perché potrebbe essere usato per accedere a dati che non rientrano nei livelli di autorizzazione dell'applicazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3832 A-28795098 Moderare Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 15 maggio 2016

Elevazione della vulnerabilità dei privilegi in Shell

Un'elevazione dei privilegi nella Shell potrebbe consentire a un'applicazione dannosa locale di aggirare i vincoli del dispositivo come le restrizioni degli utenti. Questo problema è classificato come moderato perché è un bypass locale delle autorizzazioni utente.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3833 A-29189712 [ 2 ] Moderare Tutto Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Vulnerabilità di divulgazione delle informazioni in OpenSSL

Una vulnerabilità di divulgazione di informazioni in OpenSSL potrebbe consentire a un'applicazione dannosa locale di accedere a dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come moderato perché potrebbe essere utilizzato per accedere a dati sensibili senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2842 A-29060514 Nessuno* Tutto Nexus 4.4.4, 5.0.2, 5.1.1 29 marzo 2016

* I dispositivi Nexus supportati che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità

Vulnerabilità della divulgazione di informazioni nelle API della fotocamera

Una vulnerabilità di divulgazione di informazioni nelle API della fotocamera potrebbe consentire a un'applicazione dannosa locale di accedere a strutture di dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come moderato perché potrebbe essere utilizzato per accedere a dati sensibili senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3834 A-28466701 Moderare Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 28 aprile 2016

Vulnerabilità di divulgazione delle informazioni in Mediaserver

Una vulnerabilità di divulgazione di informazioni in Mediaserver potrebbe consentire a un'applicazione dannosa locale di accedere a dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come moderato perché potrebbe essere utilizzato per accedere a dati sensibili senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3835 A-28920116 Moderare Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 23 maggio 2016

Vulnerabilità di divulgazione delle informazioni in SurfaceFlinger

Una vulnerabilità di divulgazione di informazioni nel servizio SurfaceFlinger potrebbe consentire a un'applicazione dannosa locale di accedere a dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come moderato perché potrebbe essere utilizzato per accedere a dati sensibili senza l'autorizzazione esplicita dell'utente.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3836 A-28592402 Moderare Tutto Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 4 maggio 2016

Vulnerabilità alla divulgazione delle informazioni nel Wi-Fi

Una vulnerabilità di divulgazione di informazioni nel Wi-Fi potrebbe consentire a un'applicazione dannosa locale di accedere a dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come moderato perché potrebbe essere utilizzato per accedere a dati sensibili senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3837 A-28164077 Moderare Tutto Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Vulnerabilità Denial of Service nell'interfaccia utente del sistema

Una vulnerabilità Denial of Service nell'interfaccia utente del sistema potrebbe consentire a un'applicazione dannosa locale di impedire le chiamate di emergenza da uno schermo bloccato. Questo problema è classificato come moderato a causa della possibilità di una negazione del servizio su una funzione critica.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3838 A-28761672 Moderare Tutto Nexus 6.0, 6.0.1 Google interno

Vulnerabilità Denial of Service in Bluetooth

Una vulnerabilità Denial of Service in Bluetooth potrebbe consentire a un'applicazione dannosa locale di impedire le chiamate di emergenza da un dispositivo Bluetooth. Questo problema è classificato come moderato a causa della possibilità di una negazione del servizio su una funzione critica.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3839 A-28885210 Moderare Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Livello patch di sicurezza 2016-08-05: dettagli sulla vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2016-08-05. C'è una descrizione del problema, una logica di gravità e una tabella con il CVE, i riferimenti associati, la gravità, i dispositivi Nexus aggiornati, le versioni AOSP aggiornate (ove applicabile) e la data segnalata. Quando disponibile, collegheremo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug.

Vulnerabilità dell'esecuzione di codice in remoto nel driver Wi-Fi Qualcomm

Una vulnerabilità legata all'esecuzione di codice in modalità remota nel driver Wi-Fi di Qualcomm potrebbe consentire a un utente malintenzionato in remoto di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Critico a causa della possibilità di una compromissione permanente del dispositivo locale.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2014-9902 A-28668638

QC-CR#553937
QC-CR#553941

Critico Nesso 7 (2013) 31 marzo 2014

Vulnerabilità dell'esecuzione di codice in modalità remota in Conscrypt

Una vulnerabilità legata all'esecuzione di codice in modalità remota in Conscrypt potrebbe consentire a un utente malintenzionato in remoto di eseguire codice arbitrario nel contesto di un processo privilegiato. Questo problema è considerato critico a causa della possibilità di esecuzione di codice in modalità remota.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3840 A-28751153 Critico Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Elevazione della vulnerabilità dei privilegi nei componenti di Qualcomm

La tabella seguente contiene le vulnerabilità di sicurezza che interessano i componenti Qualcomm, inclusi potenzialmente il bootloader, il driver della fotocamera, l'unità caratteri, la rete, il driver audio e il driver video.

Il più grave di questi problemi è classificato come critico a causa della possibilità che un'applicazione dannosa locale possa eseguire codice arbitrario nel contesto del kernel portando a una compromissione permanente del dispositivo locale, che potrebbe richiedere il reflash del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2014-9863 A-28768146

QC-CR#549470

Critico Nesso 5, Nesso 7 (2013) 30 aprile 2014
CVE-2014-9864 A-28747998

QC-CR#561841

Alto Nesso 5, Nesso 7 (2013) 27 marzo 2014
CVE-2014-9865 A-28748271

QC-CR#550013

Alto Nesso 5, Nesso 7 (2013) 27 marzo 2014
CVE-2014-9866 A-28747684

QC-CR#511358

Alto Nesso 5, Nesso 7 (2013) 31 marzo 2014
CVE-2014-9867 A-28749629

QC-CR#514702

Alto Nesso 5, Nesso 7 (2013) 31 marzo 2014
CVE-2014-9868 A-28749721

QC-CR#511976

Alto Nesso 5, Nesso 7 (2013) 31 marzo 2014
CVE-2014-9869 A-28749728

QC-CR#514711 [ 2 ]

Alto Nesso 5, Nesso 7 (2013) 31 marzo 2014
CVE-2014-9870 A-28749743

QC-CR#561044

Alto Nesso 5, Nesso 7 (2013) 31 marzo 2014
CVE-2014-9871 A-28749803

QC-CR#514717

Alto Nesso 5, Nesso 7 (2013) 31 marzo 2014
CVE-2014-9872 A-28750155

QC-CR#590721

Alto Nexus 5 31 marzo 2014
CVE-2014-9873 A-28750726

QC-CR#556860

Alto Nesso 5, Nesso 7 (2013) 31 marzo 2014
CVE-2014-9874 A-28751152

QC-CR#563086

Alto Nexus 5, Nexus 5X, Nexus 6P, Nexus 7 (2013) 31 marzo 2014
CVE-2014-9875 A-28767589

QC-CR#483310

Alto Nesso 7 (2013) 30 aprile 2014
CVE-2014-9876 A-28767796

QC-CR#483408

Alto Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013) 30 aprile 2014
CVE-2014-9877 A-28768281

QC-CR#547231

Alto Nesso 5, Nesso 7 (2013) 30 aprile 2014
CVE-2014-9878 A-28769208

QC-CR#547479

Alto Nexus 5 30 aprile 2014
CVE-2014-9879 A-28769221

QC-CR#524490

Alto Nexus 5 30 aprile 2014
CVE-2014-9880 A-28769352

QC-CR#556356

Alto Nesso 7 (2013) 30 aprile 2014
CVE-2014-9881 A-28769368

QC-CR#539008

Alto Nesso 7 (2013) 30 aprile 2014
CVE-2014-9882 A-28769546

QC-CR#552329 [ 2 ]

Alto Nesso 7 (2013) 30 aprile 2014
CVE-2014-9883 A-28769912

QC-CR#565160

Alto Nesso 5, Nesso 7 (2013) 30 aprile 2014
CVE-2014-9884 A-28769920

QC-CR#580740

Alto Nesso 5, Nesso 7 (2013) 30 aprile 2014
CVE-2014-9885 A-28769959

QC-CR#562261

Alto Nexus 5 30 aprile 2014
CVE-2014-9886 A-28815575

QC-CR#555030

Alto Nesso 5, Nesso 7 (2013) 30 aprile 2014
CVE-2014-9887 A-28804057

QC-CR#636633

Alto Nesso 5, Nesso 7 (2013) 3 luglio 2014
CVE-2014-9888 A-28803642

QC-CR#642735

Alto Nesso 5, Nesso 7 (2013) 29 agosto 2014
CVE-2014-9889 A-28803645

QC-CR#674712

Alto Nexus 5 31 ottobre 2014
CVE-2015-8937 A-28803962

QC-CR#770548

Alto Nesso 5, Nesso 6, Nesso 7 (2013) 31 marzo 2015
CVE-2015-8938 A-28804030

QC-CR#766022

Alto Nesso 6 31 marzo 2015
CVE-2015-8939 A-28398884

QC-CR#779021

Alto Nesso 7 (2013) 30 aprile 2015
CVE-2015-8940 A-28813987

QC-CR#792367

Alto Nesso 6 30 aprile 2015
CVE-2015-8941 A-28814502

QC-CR#792473

Alto Nesso 6, Nesso 7 (2013) 29 maggio 2015
CVE-2015-8942 A-28814652

QC-CR#803246

Alto Nesso 6 30 giugno 2015
CVE-2015-8943 A-28815158

QC-CR#794217

QC-CR#836226

Alto Nexus 5 11 settembre 2015
CVE-2014-9891 A-28749283

QC-CR#550061

Moderare Nexus 5 13 marzo 2014
CVE-2014-9890 A-28770207

QC-CR#529177

Moderare Nesso 5, Nesso 7 (2013) 2 giugno 2014

Elevazione della vulnerabilità dei privilegi nel componente di rete del kernel

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel componente di rete del kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di una compromissione permanente del dispositivo locale, che potrebbe richiedere il reflash del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2015-2686 A-28759139

kernel a monte

Critico Tutto Nexus 23 marzo 2015
CVE-2016-3841 A-28746669

kernel a monte

Critico Tutto Nexus 3 dicembre 2015

Elevazione della vulnerabilità dei privilegi nel driver della GPU Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver della GPU Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di una compromissione permanente del dispositivo locale, che potrebbe richiedere il reflash del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2504 A-28026365

QC-CR#1002974

Critico Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013) 5 aprile 2016
CVE-2016-3842 A-28377352

QC-CR#1002974

Critico Nesso 5X, Nesso 6, Nesso 6P 25 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nel componente delle prestazioni di Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel componente delle prestazioni di Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di una compromissione permanente del dispositivo locale, che potrebbe richiedere il reflash del sistema operativo per riparare il dispositivo.

Nota: in questo bollettino in A-29119870 è presente anche un aggiornamento a livello di piattaforma progettato per mitigare questa classe di vulnerabilità.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3843 A-28086229*

QC-CR#1011071

Critico Nexus 5X, Nexus 6P 7 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nel kernel

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di una compromissione permanente del dispositivo locale, che potrebbe richiedere il reflash del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3857 A-28522518* Critico Nesso 7 (2013) 2 maggio 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nel sistema di memoria del kernel

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel sistema di memoria del kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2015-1593 A-29577822

kernel a monte

Alto Giocatore Nexus 13 febbraio 2015
CVE-2016-3672 A-28763575

kernel a monte

Alto Giocatore Nexus 25 marzo 2016

Elevazione della vulnerabilità dei privilegi nel componente audio del kernel

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel componente audio del kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2544 A-28695438

kernel a monte

Alto Tutto Nexus 19 gennaio 2016
CVE-2016-2546 A-28694392

kernel a monte

Alto Pixel C 19 gennaio 2016
CVE-2014-9904 A-28592007

kernel a monte

Alto Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Nexus Player 4 maggio 2016

Elevazione della vulnerabilità dei privilegi nel file system del kernel

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel file system del kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2012-6701 A-28939037

kernel a monte

Alto Nesso 5, Nesso 7 (2013) 2 marzo 2016

Elevazione della vulnerabilità dei privilegi in Mediaserver

Una vulnerabilità legata all'acquisizione di privilegi più elevati in Mediaserver potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato. Questo problema è classificato come Alto perché potrebbe essere utilizzato per ottenere l'accesso locale a funzionalità elevate, che non sono accessibili a un'applicazione di terze parti.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3844 A-28299517*

N-CVE-2016-3844

Alto Nexus 9, Pixel C 19 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nel driver video del kernel

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver video del kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3845 A-28399876* Alto Nexus 5 20 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nel driver dell'interfaccia periferica seriale

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver dell'interfaccia periferica seriale potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3846 A-28817378* Alto Nexus 5X, Nexus 6P 17 maggio 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nel driver multimediale NVIDIA

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver multimediale NVIDIA potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3847 A-28871433*

N-CVE-2016-3847

Alto Nesso 9 19 maggio 2016
CVE-2016-3848 A-28919417*

N-CVE-2016-3848

Alto Nesso 9 19 maggio 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nel driver ION

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver ION potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3849 A-28939740 Alto Pixel C 24 maggio 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nel bootloader di Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel bootloader di Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3850 A-27917291

QC-CR#945164

Alto Nexus 5, Nexus 5X, Nexus 6P, Nexus 7 (2013) 28 marzo 2016

Elevazione della vulnerabilità dei privilegi nel sottosistema delle prestazioni del kernel

L'aumento delle vulnerabilità dei privilegi nel sottosistema delle prestazioni del kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto a causa della superficie di attacco del kernel disponibile per gli aggressori.

Nota: questo è un aggiornamento a livello di piattaforma progettato per mitigare una classe di vulnerabilità come CVE-2016-3843 (A-28086229).

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3843 A-29119870* Alto Tutto Nexus 6.0, 6.1 Google interno

* Una patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nel bootloader di LG Electronics

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel bootloader di LG Electronics potrebbe consentire a un utente malintenzionato di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3851 A-29189941* Alto Nesso 5X Google interno

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Vulnerabilità di divulgazione delle informazioni nei componenti di Qualcomm

La tabella seguente contiene le vulnerabilità di sicurezza che interessano i componenti Qualcomm, inclusi potenzialmente il bootloader, il driver della fotocamera, il driver dei caratteri, la rete, il driver audio e il driver video.

Il più grave di questi problemi è classificato come Alto a causa della possibilità che un'applicazione dannosa locale possa accedere a dati al di fuori dei suoi livelli di autorizzazione, ad esempio dati sensibili senza l'autorizzazione esplicita dell'utente.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2014-9892 A-28770164

QC-CR#568717

Alto Nesso 5, Nesso 7 (2013) 2 giugno 2014
CVE-2015-8944 A-28814213

QC-CR#786116

Alto Nesso 6, Nesso 7 (2013) 30 aprile 2015
CVE-2014-9893 A-28747914

QC-CR#542223

Moderare Nexus 5 27 marzo 2014
CVE-2014-9894 A-28749708

QC-CR#545736

Moderare Nesso 7 (2013) 31 marzo 2014
CVE-2014-9895 A-28750150

QC-CR#570757

Moderare Nesso 5, Nesso 7 (2013) 31 marzo 2014
CVE-2014-9896 A-28767593

QC-CR#551795

Moderare Nesso 5, Nesso 7 (2013) 30 aprile 2014
CVE-2014-9897 A-28769856

QC-CR#563752

Moderare Nexus 5 30 aprile 2014
CVE-2014-9898 A-28814690

QC-CR#554575

Moderare Nesso 5, Nesso 7 (2013) 30 aprile 2014
CVE-2014-9899 A-28803909

QC-CR#547910

Moderare Nexus 5 3 luglio 2014
CVE-2014-9900 A-28803952

QC-CR#570754

Moderare Nesso 5, Nesso 7 (2013) 8 agosto 2014

Vulnerabilità di divulgazione delle informazioni nello scheduler del kernel

Una vulnerabilità di divulgazione delle informazioni nello scheduler del kernel potrebbe consentire a un'applicazione dannosa locale di accedere ai dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come Alto perché potrebbe essere utilizzato per accedere a dati sensibili senza l'autorizzazione esplicita dell'utente.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2014-9903 A-28731691

kernel a monte

Alto Nexus 5X, Nexus 6P 21 febbraio 2014

Vulnerabilità di divulgazione delle informazioni nel driver Wi-Fi MediaTek (specifico del dispositivo)

Una vulnerabilità di divulgazione di informazioni nel driver Wi-Fi MediaTek potrebbe consentire a un'applicazione dannosa locale di accedere ai dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come Alto perché potrebbe essere utilizzato per accedere a dati sensibili senza l'autorizzazione esplicita dell'utente.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3852 A-29141147*

M-ALPS02751738

Alto Android Uno 12 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Vulnerabilità di divulgazione delle informazioni nel driver USB

Una vulnerabilità di divulgazione di informazioni nel driver USB potrebbe consentire a un'applicazione dannosa locale di accedere ai dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come Alto perché potrebbe essere utilizzato per accedere a dati sensibili senza l'autorizzazione esplicita dell'utente.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-4482 A-28619695

kernel a monte

Alto Tutto Nexus 3 maggio 2016

Vulnerabilità Denial of Service nei componenti Qualcomm

La tabella seguente contiene le vulnerabilità di sicurezza che interessano i componenti Qualcomm, incluso potenzialmente il driver Wi-Fi.

Il più grave di questi problemi è classificato come Alto a causa della possibilità che un utente malintenzionato possa causare una negazione del servizio remota temporanea con conseguente blocco o riavvio del dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2014-9901 A-28670333

QC-CR#548711

Alto Nesso 7 (2013) 31 marzo 2014

Elevazione della vulnerabilità dei privilegi nei servizi di Google Play

Una vulnerabilità legata all'acquisizione di privilegi più elevati nei servizi di Google Play potrebbe consentire a un utente malintenzionato locale di aggirare la protezione del ripristino delle impostazioni di fabbrica e ottenere l'accesso al dispositivo. Questo è classificato come Moderato a causa della possibilità di bypassare la protezione del ripristino delle impostazioni di fabbrica, che potrebbe portare al ripristino corretto del dispositivo e alla cancellazione di tutti i suoi dati.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3853 A-26803208* Moderare Tutto Nexus Nessuno 4 maggio 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Elevazione della vulnerabilità dei privilegi nelle API Framework

Una vulnerabilità relativa all'acquisizione di privilegi più elevati nelle API del framework potrebbe consentire a un'applicazione preinstallata di aumentare la priorità del filtro degli intenti quando l'applicazione viene aggiornata senza che l'utente venga avvisato. Questo problema è classificato come moderato perché potrebbe essere usato per ottenere funzionalità elevate senza l'autorizzazione esplicita dell'utente.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2497 A-27450489 Moderare Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Vulnerabilità di divulgazione delle informazioni nel componente di rete del kernel

Una vulnerabilità di divulgazione di informazioni nel componente di rete del kernel potrebbe consentire a un'applicazione dannosa locale di accedere ai dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come Moderato perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-4486 A-28620102

kernel a monte

Moderare Tutto Nexus 3 maggio 2016

Vulnerabilità della divulgazione di informazioni nel componente audio del kernel

Una vulnerabilità di divulgazione di informazioni nel componente audio del kernel potrebbe consentire a un'applicazione dannosa locale di accedere ai dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come Moderato perché richiede innanzitutto la compromissione di un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-4569 A-28980557

kernel a monte

Moderare Tutto Nexus 9 maggio 2016
CVE-2016-4578 A-28980217

Kernel a monte [ 2 ]

Moderare Tutto Nexus 11 maggio 2016

Vulnerabilità nei componenti Qualcomm

La tabella seguente contiene le vulnerabilità di sicurezza che interessano i componenti Qualcomm, inclusi potenzialmente il bootloader, il driver della fotocamera, il driver dei caratteri, la rete, il driver audio e il driver video.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3854 QC-CR#897326 Alto Nessuno febbraio 2016
CVE-2016-3855 QC-CR#990824 Alto Nessuno maggio 2016
CVE-2016-2060 QC-CR#959631 Moderare Nessuno aprile 2016

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che possono verificarsi dopo la lettura di questo bollettino.

1. Come faccio a determinare se il mio dispositivo è aggiornato per risolvere questi problemi?

I livelli di patch di sicurezza del 01-08-2016 o successivi risolvono tutti i problemi associati al livello della stringa di patch di sicurezza del 01-08-2016. I livelli di patch di sicurezza del 05-08-2016 o successivi risolvono tutti i problemi associati al livello della stringa di patch di sicurezza del 05-08-2016. Fare riferimento al Centro assistenza per istruzioni su come controllare il livello di patch di sicurezza. I produttori di dispositivi che includono questi aggiornamenti devono impostare il livello della stringa di patch su: [ro.build.version.security_patch]:[2016-08-01] o [ro.build.version.security_patch]:[2016-08-05].

2. Perché questo bollettino ha due stringhe a livello di patch di sicurezza?

Questo bollettino contiene due stringhe a livello di patch di sicurezza per fornire ai partner Android la flessibilità di muoversi più rapidamente per correggere un sottoinsieme di vulnerabilità simili su tutti i dispositivi Android. I partner Android sono invitati a risolvere tutti i problemi in questo bollettino e a utilizzare la stringa del livello di patch di sicurezza più recente.

I dispositivi che utilizzano il livello di patch di sicurezza del 5 agosto 2016 o più recente devono includere tutte le patch applicabili in questo (e precedenti) bollettini sulla sicurezza.

I dispositivi che utilizzano il livello di patch di sicurezza del 1 agosto 2016 devono includere tutti i problemi associati a tale livello di patch di sicurezza, nonché le correzioni per tutti i problemi segnalati nei precedenti bollettini sulla sicurezza. I dispositivi che utilizzano il livello di patch di sicurezza del 1 agosto 2016 possono includere anche un sottoinsieme di correzioni associate al livello di patch di sicurezza del 5 agosto 2016.

3 . Come faccio a determinare quali dispositivi Nexus sono interessati da ciascun problema?

Nelle sezioni dei dettagli sulla vulnerabilità della sicurezza 01-08-2016 e 05-08-2016 , ogni tabella ha una colonna Dispositivi Nexus aggiornati che copre la gamma di dispositivi Nexus interessati aggiornati per ogni problema. Questa colonna ha alcune opzioni:

  • Tutti i dispositivi Nexus : se un problema riguarda tutti i dispositivi Nexus, la tabella conterrà "Tutti i Nexus" nella colonna dei dispositivi Nexus aggiornati . "All Nexus" racchiude i seguenti dispositivi supportati : Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013), Nexus 9, Android One, Nexus Player e Pixel C.
  • Alcuni dispositivi Nexus : se un problema non riguarda tutti i dispositivi Nexus, i dispositivi Nexus interessati vengono elencati nella colonna Dispositivi Nexus aggiornati .
  • Nessun dispositivo Nexus : se nessun dispositivo Nexus è interessato dal problema, la tabella riporterà "Nessuno" nella colonna Dispositivi Nexus aggiornati .

4. A cosa corrispondono le voci nella colonna dei riferimenti?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento. Questi prefissi vengono mappati come segue:

Prefisso Riferimento
UN- ID bug Android
controllo qualità- Numero di riferimento Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA

Revisioni

  • 01 agosto 2016: pubblicato il bollettino.
  • 2 agosto 2016: Bollettino rivisto per includere i collegamenti AOSP.
  • 16 agosto 2016: CVE-2016-3856 corretto in CVE-2016-2060 e aggiornato l'URL di riferimento.
  • 21 ottobre 2016: corretto errore di battitura in CVE-2016-4486.