Bollettino sulla sicurezza Android: aprile 2022

Pubblicato il 4 aprile 2022 | Aggiornato il 5 aprile 2022

Il Bollettino sulla sicurezza di Android contiene dettagli sulle vulnerabilità della sicurezza che interessano i dispositivi Android. I livelli delle patch di sicurezza del 05-04-2022 o successivi risolvono tutti questi problemi. Per informazioni su come verificare il livello delle patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

I partner Android vengono informati di tutti i problemi almeno un mese prima della pubblicazione. Le patch del codice sorgente per questi problemi sono state rilasciate nel repository Android Open Source Project (AOSP) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch esterne a AOSP.

Il più grave di questi problemi è un'elevata vulnerabilità della sicurezza nel componente Framework che potrebbe portare a un'escalation locale dei privilegi senza che siano necessari ulteriori privilegi di esecuzione. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, presupponendo che le mitigazioni della piattaforma e del servizio siano disattivate per scopi di sviluppo o se aggirate con successo.

Fare riferimento alla sezione Mitigazioni per Android e Google Play Protect per dettagli sulle protezioni della piattaforma di sicurezza Android e Google Play Protect, che migliorano la sicurezza della piattaforma Android.

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle mitigazioni fornite dalla piattaforma di sicurezza Android e dalle protezioni dei servizi come Google Play Protect . Queste funzionalità riducono la probabilità che le vulnerabilità della sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento di molti problemi su Android è reso più difficile dai miglioramenti apportati alle versioni più recenti della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android, ove possibile.
  • Il team di sicurezza di Android monitora attivamente eventuali abusi tramite Google Play Protect e avvisa gli utenti in merito alle applicazioni potenzialmente dannose . Google Play Protect è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano app esterne a Google Play.

Dettagli sulla vulnerabilità a livello di patch di sicurezza del 2022-04-01

Nelle sezioni seguenti forniamo dettagli per ciascuna vulnerabilità di sicurezza che si applica al livello di patch 2022-04-01. Le vulnerabilità sono raggruppate in base al componente che interessano. I problemi sono descritti nelle tabelle seguenti e includono ID CVE, riferimenti associati, tipo di vulnerabilità , gravità e versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID del bug. I dispositivi con Android 10 e versioni successive potrebbero ricevere aggiornamenti di sicurezza e aggiornamenti di sistema di Google Play .

Struttura

La vulnerabilità più grave in questa sezione potrebbe portare all'escalation locale dei privilegi senza che siano necessari ulteriori privilegi di esecuzione.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2021-0694 A-183147114 EoP Alto 11
CVE-2021-39794 A-205836329 EoP Alto 11, 12, 12 litri
CVE-2021-39796 A-205595291 EoP Alto 10, 11, 12, 12 litri
CVE-2021-39797 A-209607104 EoP Alto 12, 12L
CVE-2021-39798 A-213169612 EoP Alto 12, 12L
CVE-2021-39799 A-200288596 EoP Alto 12, 12L

Quadro multimediale

La vulnerabilità più grave in questa sezione potrebbe portare alla divulgazione remota di informazioni senza la necessità di ulteriori privilegi di esecuzione.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2021-39803 A-193790350 ID Alto 10, 11, 12, 12 litri
CVE-2021-39804 A-215002587 DoS Alto 11, 12, 12 litri

Sistema

La vulnerabilità più grave in questa sezione potrebbe portare all'escalation locale dei privilegi senza che siano necessari ulteriori privilegi di esecuzione.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2021-39808 A-209966086 EoP Alto 10, 11, 12
CVE-2021-39805 A-212694559 ID Alto 12, 12L
CVE-2021-39809 A-205837191 ID Alto 10, 11, 12, 12 litri

Aggiornamenti del sistema Google Play

I seguenti problemi sono inclusi nei componenti Project Mainline.

Componente CVE
MediaProvider CVE-2021-39795
Codec multimediali CVE-2021-39803

Dettagli sulla vulnerabilità a livello di patch di sicurezza del 2022-04-05

Nelle sezioni seguenti forniamo dettagli per ciascuna vulnerabilità di sicurezza che si applica al livello di patch 2022-04-05. Le vulnerabilità sono raggruppate in base al componente che interessano. I problemi sono descritti nelle tabelle seguenti e includono ID CVE, riferimenti associati, tipo di vulnerabilità , gravità e versioni AOSP aggiornate (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID del bug.

Sistema

La vulnerabilità più grave in questa sezione potrebbe portare all'escalation locale dei privilegi dall'account Guest senza che siano necessari ulteriori privilegi di esecuzione.

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2021-39807 A-209446496 EoP Alto 10, 11, 12, 12 litri

Componenti del kernel

La vulnerabilità più grave in questa sezione potrebbe portare all'escalation locale dei privilegi senza che siano necessari ulteriori privilegi di esecuzione.

CVE Riferimenti Tipo Gravità Componente
CVE-2021-0707 A-155756045
Kernel a monte
EoP Alto dma-buff
CVE-2021-39801 A-209791720
Kernel a monte [ 2 ] [ 3 ]
EoP Alto IONE
CVE-2021-39802 A-213339151
Kernel a monte [ 2 ] [ 3 ] [ 4 ]
EoP Alto Gestione della memoria
CVE-2021-39800 A-208277166
Kernel a monte [ 2 ] [ 3 ]
ID Alto IONE

Componenti MediaTek

Queste vulnerabilità interessano i componenti MediaTek e ulteriori dettagli sono disponibili direttamente da MediaTek. La valutazione della gravità di questi problemi viene fornita direttamente da MediaTek.

CVE Riferimenti Gravità Componente
CVE-2022-20081
A-218242055
M-ALPS06461919 *
Alto A-GPS
CVE-2021-25477
A-220262213
M-MOLY00684727 *
Alto Modem LTE RRC

Componenti Qualcomm

Queste vulnerabilità interessano i componenti Qualcomm e sono descritte in maggiore dettaglio nel bollettino di sicurezza o nell'avviso di sicurezza di Qualcomm appropriato. La valutazione della gravità di questi problemi viene fornita direttamente da Qualcomm.

CVE Riferimenti Gravità Componente
CVE-2021-35081
A-213239834
QC-CR#3028274
Critico Wi-Fi
CVE-2021-35112
A-201574693
QC-CR#3049280
Critico Schermo
CVE-2021-35123
A-213239948
QC-CR#3032290
Critico Bluetooth
CVE-2021-30334
A-213239835
QC-CR#2963049 [ 2 ]
QC-CR#3052789
Alto Schermo
CVE-2021-35091
A-204905109
QC-CR#3008877
Alto Schermo
CVE-2021-35095 A-204905206
QC-CR#2996895
Alto Nocciolo
CVE-2021-35130
A-213240026
QC-CR#3057133
Alto Schermo

Componenti closed source di Qualcomm

Queste vulnerabilità interessano i componenti closed source di Qualcomm e sono descritte in maggiore dettaglio nel bollettino di sicurezza o nell'avviso di sicurezza di Qualcomm appropriato. La valutazione della gravità di questi problemi viene fornita direttamente da Qualcomm.

CVE Riferimenti Gravità Componente
CVE-2021-30339
A-202025975 * Critico Componente closed source
CVE-2021-30341
A-202024969 * Critico Componente closed source
CVE-2021-30342
A-202025860 * Critico Componente closed source
CVE-2021-30343
A-202025978 * Critico Componente closed source
CVE-2021-30347 A-202025598 * Critico Componente closed source
CVE-2021-35104 A-213240044 * Critico Componente closed source
CVE-2021-30281 A-202025858 * Alto Componente closed source
CVE-2021-30338
A-202025859 * Alto Componente closed source
CVE-2021-30340 A-202025736 * Alto Componente closed source
CVE-2021-30344 A-192612963 * Alto Componente closed source
CVE-2021-30345 A-202025737 * Alto Componente closed source
CVE-2021-30346 A-202025862 * Alto Componente closed source
CVE-2021-30349 A-202025797 * Alto Componente closed source
CVE-2021-30350
A-202025979 * Alto Componente closed source
CVE-2021-35070
A-202025864 * Alto Componente closed source
CVE-2021-35100 A-213240046 * Alto Componente closed source

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che potrebbero sorgere dopo aver letto questo bollettino.

1. Come posso determinare se il mio dispositivo è aggiornato per risolvere questi problemi?

Per informazioni su come verificare il livello delle patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

  • I livelli delle patch di sicurezza del 01-04-2022 o successivi risolvono tutti i problemi associati al livello delle patch di sicurezza del 01-04-2022.
  • I livelli di patch di sicurezza del 05-04-2022 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 05-04-2022 e a tutti i livelli di patch precedenti.

I produttori di dispositivi che includono questi aggiornamenti dovrebbero impostare il livello della stringa di patch su:

  • [ro.build.version.security_patch]:[2022-04-01]
  • [ro.build.version.security_patch]:[2022-04-05]

Per alcuni dispositivi con Android 10 o versioni successive, l'aggiornamento del sistema Google Play avrà una stringa di data che corrisponde al livello della patch di sicurezza 2022-04-01. Consulta questo articolo per ulteriori dettagli su come installare gli aggiornamenti di sicurezza.

2. Perché questo bollettino prevede due livelli di patch di sicurezza?

Questo bollettino prevede due livelli di patch di sicurezza in modo che i partner Android abbiano la flessibilità necessaria per correggere più rapidamente un sottoinsieme di vulnerabilità simili su tutti i dispositivi Android. I partner Android sono incoraggiati a risolvere tutti i problemi presenti in questo bollettino e a utilizzare il livello di patch di sicurezza più recente.

  • I dispositivi che utilizzano il livello di patch di sicurezza 2022-04-01 devono includere tutti i problemi associati a tale livello di patch di sicurezza, nonché le correzioni per tutti i problemi segnalati nei bollettini di sicurezza precedenti.
  • I dispositivi che utilizzano il livello di patch di sicurezza del 05-04-2022 o successivo devono includere tutte le patch applicabili in questo (e nei precedenti) bollettini sulla sicurezza.

I partner sono incoraggiati a raggruppare le correzioni per tutti i problemi che stanno affrontando in un unico aggiornamento.

3. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice remoto
EoP Elevazione dei privilegi
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

4. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
QC- Numero di riferimento di Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom
U- Numero di riferimento UNISOC

5. Cosa significa un * accanto all'ID del bug Android nella colonna Riferimenti ?

I numeri che non sono disponibili pubblicamente hanno un * accanto all'ID di riferimento corrispondente. L'aggiornamento per questo problema è generalmente contenuto negli ultimi driver binari per i dispositivi Pixel disponibili sul sito degli sviluppatori di Google .

6. Perché le vulnerabilità della sicurezza sono suddivise tra questo bollettino e i bollettini sulla sicurezza dei dispositivi/partner, come il bollettino Pixel?

Le vulnerabilità della sicurezza documentate in questo bollettino sulla sicurezza sono necessarie per dichiarare il livello di patch di sicurezza più recente sui dispositivi Android. Ulteriori vulnerabilità di sicurezza documentate nei bollettini sulla sicurezza del dispositivo/partner non sono necessarie per dichiarare un livello di patch di sicurezza. I produttori di dispositivi e chipset Android possono anche pubblicare dettagli sulle vulnerabilità di sicurezza specifiche dei loro prodotti, come Google , Huawei , LGE , Motorola , Nokia o Samsung .

Versioni

Versione Data Appunti
1.0 4 aprile 2022 Bollettino pubblicato
1.1 5 aprile 2022 Bollettino rivisto per includere collegamenti AOSP
2.0 18 luglio 2022 Tabella CVE rivista