Pixel Update Bulletin—มกราคม 2022

เผยแพร่เมื่อ 4 มกราคม 2022

พิกเซลปรับปรุงแถลงการณ์มีรายละเอียดของช่องโหว่ด้านความปลอดภัยและปรับปรุงการทำงานมีผลกระทบต่อ อุปกรณ์พิกเซลสนับสนุน (อุปกรณ์ของ Google) สำหรับอุปกรณ์ Google ระดับแพตช์ความปลอดภัยปี 2022-01-05 หรือใหม่กว่าจะแก้ไขปัญหาทั้งหมดในกระดานข่าวนี้และปัญหาทั้งหมดในกระดานข่าวความปลอดภัยของ Android มกราคม 2022 เรียนรู้วิธีการตรวจสอบระดับโปรแกรมปรับปรุงความปลอดภัยของอุปกรณ์ให้ดูที่ การตรวจสอบและอัปเดตเวอร์ชัน Android ของคุณ

อุปกรณ์ Google ที่รองรับทั้งหมดจะได้รับการอัปเดตเป็นระดับแพตช์ 2022-01-05 เราสนับสนุนให้ลูกค้าทุกคนยอมรับการอัปเดตเหล่านี้ในอุปกรณ์ของตน

ประกาศ

  • นอกเหนือจากช่องโหว่ด้านความปลอดภัยที่อธิบายไว้ใน Android Security Bulletin ในเดือนมกราคม 2022 แล้ว อุปกรณ์ Google ยังมีแพตช์สำหรับช่องโหว่ด้านความปลอดภัยที่อธิบายไว้ด้านล่าง

แพตช์ความปลอดภัย

ช่องโหว่จะถูกจัดกลุ่มตามองค์ประกอบที่ได้รับผลกระทบ มีรายละเอียดของปัญหาและตารางที่มี CVE ที่อ้างอิงการเชื่อมโยงเป็น ประเภทของความเสี่ยง , ความรุนแรง และการปรับปรุงรุ่น Android โครงการ Open Source (AOSP) (ถ้ามี) หากมี เราจะเชื่อมโยงการเปลี่ยนแปลงสาธารณะที่แก้ไขปัญหากับรหัสจุดบกพร่อง เช่น รายการการเปลี่ยนแปลง AOSP เมื่อการเปลี่ยนแปลงหลายรายการเกี่ยวข้องกับจุดบกพร่องเดียว การอ้างอิงเพิ่มเติมจะเชื่อมโยงกับหมายเลขตาม ID จุดบกพร่อง

Pixel

CVE อ้างอิง พิมพ์ ความรุนแรง ส่วนประกอบ
CVE-2021-39678 A-171742549 * EoP สูง Gboard
CVE-2021-39679 A-188745089 * EoP สูง จอแสดงผล/กราฟิก
CVE-2021-39682 A-201677538 * EoP สูง จอแสดงผล/กราฟิก
CVE-2021-39683 A-202003354 * EoP สูง ไททัน M2
CVE-2021-39684 A-203250788 * EoP สูง Bootloader
CVE-2021-40490 A-199579676 * EoP สูง เคอร์เนล
CVE-2021-39680 A-197965864 * ไอดี สูง ไททัน M2
CVE-2021-39681 A-200251074 * EoP ปานกลาง โทรศัพท์

ส่วนประกอบ Qualcomm

CVE อ้างอิง ความรุนแรง ส่วนประกอบ
CVE-2021-30313 A-178720043

QC-CR#2878995

ปานกลาง เคอร์เนล

ส่วนประกอบโอเพ่นซอร์สของ Qualcomm

CVE อ้างอิง ความรุนแรง ส่วนประกอบ
CVE-2021-30314 A-193072178 * ปานกลาง ส่วนประกอบที่ปิดแหล่งที่มา

แพทช์การทำงาน

สำหรับรายละเอียดเกี่ยวกับการแก้ไขข้อบกพร่องใหม่และแพทช์การทำงานรวมอยู่ในข่าวประชาสัมพันธ์ฉบับนี้ให้ดูที่ ฟอรั่มพิกเซลชุมชน

คำถามและคำตอบทั่วไป

ส่วนนี้จะตอบคำถามทั่วไปที่อาจเกิดขึ้นหลังจากอ่านกระดานข่าวนี้

1. ฉันจะทราบได้อย่างไรว่าอุปกรณ์ของฉันได้รับการอัปเดตเพื่อแก้ไขปัญหาเหล่านี้หรือไม่

ระดับแพตช์ความปลอดภัย 2022-01-05 หรือใหม่กว่า แก้ไขปัญหาทั้งหมดที่เกี่ยวข้องกับระดับแพตช์ความปลอดภัย 2022-01-05 และระดับแพตช์ก่อนหน้าทั้งหมด เรียนรู้วิธีการตรวจสอบระดับโปรแกรมปรับปรุงความปลอดภัยของอุปกรณ์อ่านคำแนะนำเกี่ยวกับ ตารางการปรับปรุงอุปกรณ์ Google

2. ทำรายการในค่าเฉลี่ยคอลัมน์ประเภท?

รายการในคอลัมน์ประเภทของช่องโหว่รายละเอียดอ้างอิงตารางการจัดหมวดหมู่ของช่องโหว่การรักษาความปลอดภัย

ตัวย่อ คำนิยาม
RCE การเรียกใช้โค้ดจากระยะไกล
EoP ยกระดับสิทธิพิเศษ
ไอดี การเปิดเผยข้อมูล
DoS ปฏิเสธการให้บริการ
ไม่มี ไม่มีการจัดประเภท

3 สิ่งที่ทำรายการในค่าเฉลี่ยคอลัมน์อ้างอิง?

รายการภายใต้การอ้างอิงคอลัมน์ของตารางรายละเอียดช่องโหว่อาจจะมีคำนำหน้าระบุองค์กรที่ค่าอ้างอิงเป็น

คำนำหน้า อ้างอิง
เอ- รหัสข้อบกพร่องของ Android
QC- หมายเลขอ้างอิง Qualcomm
ม- หมายเลขอ้างอิง MediaTek
น- หมายเลขอ้างอิง NVIDIA
ข- หมายเลขอ้างอิง Broadcom
ยู- หมายเลขอ้างอิง UNISOC

4. อะไรนี้ * ติดกับรหัสข้อผิดพลาดใน Android หมายถึงคอลัมน์อ้างอิง?

ปัญหาที่ไม่ได้เปิดเผยต่อสาธารณชนมี * ติดกับรหัสข้อผิดพลาดของ Android ในการอ้างอิงคอลัมน์ การปรับปรุงสำหรับปัญหาที่มีอยู่ทั่วไปในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์พิกเซลพร้อมใช้งานจาก เว็บไซต์ของนักพัฒนาซอฟต์แวร์ Google

5. เหตุใดช่องโหว่ด้านความปลอดภัยจึงถูกแบ่งระหว่างกระดานข่าวนี้กับกระดานข่าวสารความปลอดภัยของ Android

ช่องโหว่ด้านความปลอดภัยที่บันทึกไว้ในกระดานข่าวความปลอดภัยของ Android จำเป็นต้องประกาศระดับแพตช์ความปลอดภัยล่าสุดบนอุปกรณ์ Android ช่องโหว่ด้านความปลอดภัยเพิ่มเติม เช่น ที่บันทึกไว้ในกระดานข่าวนี้ไม่จำเป็นสำหรับการประกาศระดับแพตช์ความปลอดภัย

รุ่น

เวอร์ชั่น วันที่ หมายเหตุ
1.0 4 มกราคม 2565 ออกแถลงการณ์