Android のセキュリティに関する公開情報 - 2019 年 10 月

2019 年 10 月 7 日公開 | 2019 年 10 月 29 日更新

Android のセキュリティに関する公開情報には、Android デバイスに影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2019-10-06 以降では、下記のすべての問題に対処しています。デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法についての説明をご覧ください。

Android パートナーには、情報公開の 1 か月前までにすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)リポジトリに、下記の問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大度の高いものは、メディア フレームワーク コンポーネントに重大なセキュリティの脆弱性があるため、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行できるようになるおそれがあることです。重大度の評価は、攻撃対象のデバイスでその脆弱性が悪用された場合の影響に基づいています。プラットフォームやサービスでのリスク軽減策が、開発目的または不正な回避策により無効となっていると仮定しています。

Android セキュリティ プラットフォームの保護や Google Play プロテクトについて詳しくは、Android と Google Play プロテクトでのリスク軽減策をご覧ください。こうした保護により、Android プラットフォームのセキュリティが改善されます。

お知らせ

Android 10 には、Google モバイル サービスを搭載した Android デバイスにアップデートを迅速に配信することを実現する、Google Play システム アップデート(プロジェクト Mainline)が導入されています。Android のセキュリティに関する公開情報では、Google Play システム アップデートで修正されたセキュリティ問題を掲載しています。セキュリティ アップデートのインストール方法について詳しくは、こちらの記事をご覧ください。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームの保護と Google Play プロテクトのようなサービスの保護によるリスクの軽減について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らします。

  • Android プラットフォームの最新版での機能強化により、Android 上の多くの問題について悪用が困難になります。Google では、すべてのユーザーに対し、できる限り最新バージョンの Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、有害な可能性があるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載したデバイスではデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとっては特に重要です。

セキュリティ パッチレベル 2019-10-01 の脆弱性の詳細

以下に、パッチレベル 2019-10-01 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。問題の説明に続いて、CVE、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を表にまとめています。問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)が参照可能な場合は、バグ ID にその情報へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクがあります。Android 10 以降を搭載したデバイスは、セキュリティ アップデートと Google Play システム アップデートを受信することがあります。

フレームワーク

フレームワークの最も重大な脆弱性により、悪意のあるローカルアプリによって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2019-2173 A-123013720 EoP 7.1.1、7.1.2、8.0、8.1、9

メディア フレームワーク

メディア フレームワークの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2019-2184 A-134578122 RCE 重大 7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2185 A-136173699 RCE 10
RCE 重大 7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2186 A-136175447 RCE 10
RCE 重大 7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2110 A-69703445 [2] ID 9

システム

システムの最も重大な脆弱性により、悪意のあるローカルアプリによって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2019-2114 A-123700348 [2] EoP 8.0、8.1、9
CVE-2019-2187 A-124940143 ID 7.1.1、7.1.2、8.0、8.1、9、10

Google Play システム アップデート

下記のセキュリティ問題は、Google Play システム アップデートに含まれています。

コンポーネント CVE
メディア コーデック CVE-2019-2185、CVE-2019-2186

セキュリティ パッチレベル 2019-10-05 の脆弱性の詳細

以下に、パッチレベル 2019-10-05 に該当するセキュリティ脆弱性の各項目の詳細を示します。影響を受けるコンポーネントごとに脆弱性を分類し、CVE、関連する参照先、脆弱性のタイプ重大度、コンポーネント(該当する場合)、更新対象の AOSP バージョン(該当する場合)などの詳細を記載しています。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクを設定しています。

カーネル コンポーネント

フレームワークの脆弱性により、悪意のあるローカルアプリによって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-19824 A-120783587
アップストリーム カーネル
EoP USB オーディオ

Qualcomm コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2019-2268 A-127512519
QC-CR#2263727
QC-CR#2429210
なし WLAN ホスト
CVE-2019-10535 A-136501752
QC-CR#2308644
なし WLAN ホスト
CVE-2018-11902 A-136498768
QC-CR#2278457
なし WLAN ホスト

Qualcomm クローズドソース コンポーネント

Qualcomm クローズドソース コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-13916 A-122473303* なし 重大 クローズドソース コンポーネント
CVE-2019-2251 A-122474427* なし 重大 クローズドソース コンポーネント
CVE-2019-2271 A-129766175* なし 重大 クローズドソース コンポーネント
CVE-2019-2289 A-129765090* なし 重大 クローズドソース コンポーネント
CVE-2019-2315 A-129766098* なし 重大 クローズドソース コンポーネント
CVE-2019-2329 A-129766136* なし 重大 クローズドソース コンポーネント
CVE-2019-2336 A-129766497* なし 重大 クローズドソース コンポーネント
CVE-2019-2339 A-129765860* なし 重大 クローズドソース コンポーネント
CVE-2019-2271 A-129765571* なし クローズドソース コンポーネント
CVE-2019-2303 A-129765728* なし クローズドソース コンポーネント
CVE-2019-2318 A-129766832* なし クローズドソース コンポーネント
CVE-2019-2335 A-129766932* なし クローズドソース コンポーネント
CVE-2019-10490 A-132108421* なし クローズドソース コンポーネント
CVE-2019-2295 A-132108893* なし クローズドソース コンポーネント

セキュリティ パッチレベル 2019-10-06 の脆弱性の詳細

以下に、パッチレベル 2019-10-06 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。問題の説明に続いて、CVE、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を表にまとめています。問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)が参照可能な場合は、バグ ID にその情報へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクがあります。Android 10 以降を搭載したデバイスは、セキュリティ アップデートと Google Play システム アップデートを受信することがあります。

カーネル コンポーネント

カーネル コンポーネントの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2019-2215 A-141720095 EoP Binder

一般的な質問と回答

上記の公開情報に対する一般的な質問とその回答は以下のとおりです。

1. 上記の問題に対処するようにデバイスが更新されているかどうかを確かめるには、どうすればよいですか?

デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法をご覧ください。

  • セキュリティ パッチレベル 2019-10-01 以降では、セキュリティ パッチレベル 2019-10-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2019-10-05 以降では、セキュリティ パッチレベル 2019-10-05 以前のすべてのパッチレベルに関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2019-10-06 以降では、セキュリティ パッチレベル 2019-10-06 以前のすべてのパッチレベルに関連するすべての問題に対処しています。

デバイス メーカーは、こうしたアップデートを組み込む場合、パッチレベル文字列を以下のとおり設定する必要があります。

  • [ro.build.version.security_patch]:[2019-10-01]
  • [ro.build.version.security_patch]:[2019-10-05]
  • [ro.build.version.security_patch]:[2019-10-06]

Android 10 以降を搭載した一部のデバイスでは、Google Play システム アップデートに、セキュリティ パッチレベル 2019-10-01 と一致する日付文字列が含まれます。セキュリティ アップデートのインストール方法について詳しくは、こちらの記事をご覧ください。

2. この公開情報に 3 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、3 つのセキュリティ パッチレベルを定義しています。これは、すべての Android デバイスで同様の問題が発生する一部の脆弱性をサブセットとし、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーは、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2019-10-01 のセキュリティ パッチレベルを使用するデバイスには、そのセキュリティ パッチレベルに関連するすべての問題と、それより前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2019-10-05 以降のセキュリティ パッチレベルを使用するデバイスには、そのセキュリティ パッチレベル、2019-10-01 のセキュリティ パッチレベルに関連するすべての問題と、それ以前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2019-10-06 以降のセキュリティ パッチレベルを使用するデバイスには、今回(およびそれより前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーには、対処するすべての問題の修正を 1 つのアップデートにまとめて提供することが推奨されています。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
なし 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属する組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、「参照」列の Android バグ ID の横に「*」を付けています。この問題のアップデートは、Google デベロッパー サイトから入手できる Pixel デバイス用最新バイナリ ドライバに通常含まれています。

6. セキュリティの脆弱性が、この公開情報とデバイスやパートナーのセキュリティに関する公開情報(Pixel のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android デバイスの最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要となります。それ以外の、デバイスやパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必須ではありません。また、Android デバイスやチップセットのメーカー(GoogleHuaweiLGEMotorolaNokiaSamsung など)からも、各社製品に固有のセキュリティの脆弱性に関する詳細情報が公開される場合があります。

バージョン

バージョン 日付 メモ
1.0 2019 年 10 月 7 日 情報公開
1.1 2019 年 10 月 8 日 CVE-2019-2215 の項目と AOSP リンクを追加
1.2 2019 年 10 月 29 日 CVE の表を改訂