O Google tem o compromisso de promover a igualdade racial para as comunidades negras. Saiba como.

Boletim de segurança do Android — junho de 2017

Publicado em 5 de junho de 2017 | Atualizado em 17 de agosto de 2017

O Boletim de Segurança do Android contém detalhes das vulnerabilidades de segurança que afetam os dispositivos Android. Os níveis de patch de segurança de 05 de junho de 2017 ou posterior abordam todos esses problemas. Consulte a programação de atualização do Pixel e do Nexus para saber como verificar o nível de patch de segurança de um dispositivo.

Os parceiros foram notificados dos problemas descritos no boletim há pelo menos um mês. Os patches de código-fonte para esses problemas serão lançados no repositório do Android Open Source Project (AOSP) e vinculados a este boletim. Este boletim também inclui links para patches fora do AOSP.

O mais grave desses problemas é uma vulnerabilidade de segurança crítica no Media Framework que pode permitir que um invasor remoto usando um arquivo especialmente criado cause corrupção de memória durante o processamento de dados e arquivos de mídia. A avaliação de gravidade é baseada no efeito que a exploração da vulnerabilidade possivelmente teria em um dispositivo afetado, supondo que as atenuações da plataforma e do serviço sejam desativadas para fins de desenvolvimento ou se forem ignoradas com êxito.

Não tivemos relatos de exploração ativa de clientes ou abuso desses problemas relatados recentemente. Consulte a seção de mitigações do Android e do Google Play Protect para obter detalhes sobre as proteções da plataforma de segurança Android e o Google Play Protect , que melhoram a segurança da plataforma Android.

Incentivamos todos os clientes a aceitar essas atualizações em seus dispositivos.

Observação: as informações sobre a atualização OTA (over-the-air) mais recente e as imagens de firmware para dispositivos do Google estão disponíveis na seção de atualizações de dispositivos do Google .

Anúncios

  • Simplificamos o boletim de segurança mensal para torná-lo mais fácil de ler. Como parte desta atualização, as informações de vulnerabilidade são categorizadas por componente afetado, classificadas pelo nome do componente em um nível de patch de segurança, e as informações específicas do dispositivo do Google são hospedadas em uma seção dedicada .
  • Este boletim tem duas strings de nível de patch de segurança para fornecer aos parceiros Android a flexibilidade de corrigir mais rapidamente um subconjunto de vulnerabilidades semelhantes em todos os dispositivos Android. Consulte Perguntas e respostas comuns para obter informações adicionais:
    • 2017-06-01 : String de nível de patch de segurança parcial. Essa string de nível de patch de segurança indica que todos os problemas associados a 2017-06-01 (e todas as strings de nível de patch de segurança anteriores) foram resolvidos.
    • 2017-06-05 : Sequência de nível de patch de segurança completa. Essa string de nível de patch de segurança indica que todos os problemas associados a 2017-06-01 e 2017-06-05 (e todas as strings de nível de patch de segurança anteriores) foram resolvidos.

Mitigações do Android e do Google Play Protect

Este é um resumo das mitigações fornecidas pela plataforma de segurança do Android e proteções de serviços, como o Google Play Protect . Esses recursos reduzem a probabilidade de vulnerabilidades de segurança serem exploradas com sucesso no Android.

  • A exploração de muitos problemas no Android é dificultada pelos aprimoramentos nas versões mais recentes da plataforma Android. Incentivamos todos os usuários a atualizar para a versão mais recente do Android sempre que possível.
  • A equipe de segurança do Android monitora ativamente o abuso por meio do Google Play Protect e avisa os usuários sobre aplicativos potencialmente prejudiciais . O Google Play Protect está ativado por padrão em dispositivos com Google Mobile Services e é especialmente importante para usuários que instalam aplicativos de fora do Google Play.

2017-06-01 nível de patch de segurança — detalhes da vulnerabilidade

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch 2017-06-01. As vulnerabilidades são agrupadas sob o componente que elas afetam. Há uma descrição do problema e uma tabela com o CVE, referências associadas, tipo de vulnerabilidade , gravidade e versões atualizadas do AOSP (quando aplicável). Quando disponível, vinculamos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações do AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após o ID do bug.

Bluetooth

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo malicioso local acesse dados fora de seus níveis de permissão.

CVE Referências Modelo Gravidade Versões AOSP atualizadas
CVE-2017-0645 A-35385327 EoP Moderado 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0646 A-33899337 EU IRIA Moderado 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Bibliotecas

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando um arquivo especialmente criado execute código arbitrário no contexto de um processo sem privilégios.

CVE Referências Modelo Gravidade Versões AOSP atualizadas
CVE-2015-8871 A-35443562 * RCE Alto 5.0.2, 5.1.1, 6.0, 6.0.1
CVE-2016-8332 A-37761553 * RCE Alto 5.0.2, 5.1.1, 6.0, 6.0.1
CVE-2016-5131 A-36554209 RCE Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016-4658 A-36554207 RCE Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0663 A-37104170 RCE Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-7376 A-36555370 RCE Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-5056 A-36809819 RCE Moderado 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-7375 A-36556310 RCE Moderado 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0647 A-36392138 EU IRIA Moderado 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016-1839 A-36553781 DoS Moderado 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Estrutura de mídia

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando um arquivo especialmente criado cause corrupção de memória durante o arquivo de mídia e o processamento de dados.

CVE Referências Modelo Gravidade Versões AOSP atualizadas
CVE-2017-0637 A-34064500 RCE Crítico 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0391 A-32322258 DoS Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0640 A-33129467 * DoS Alto 6.0, 6.0.1, 7.0, 7.1.1
CVE-2017-0641 A-34360591 DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0642 A-34819017 DoS Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0643 A-35645051 * DoS Alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1
CVE-2017-0644 A-35472997 * DoS Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1

IU do sistema

A vulnerabilidade mais grave nesta seção pode permitir que um invasor usando um arquivo especialmente criado execute código arbitrário no contexto de um processo sem privilégios.

CVE Referências Modelo Gravidade Versões AOSP atualizadas
CVE-2017-0638 A-36368305 RCE Alto 7.1.1, 7.1.2

2017-06-05 nível de patch de segurança — detalhes da vulnerabilidade

Nas seções abaixo, fornecemos detalhes para cada uma das vulnerabilidades de segurança que se aplicam ao nível de patch 2017-06-05. As vulnerabilidades são agrupadas no componente que afetam e incluem detalhes como o CVE, referências associadas, tipo de vulnerabilidade , gravidade , componente (quando aplicável) e versões atualizadas do AOSP (quando aplicável). Quando disponível, vinculamos a alteração pública que abordou o problema ao ID do bug, como a lista de alterações do AOSP. Quando várias alterações estão relacionadas a um único bug, referências adicionais são vinculadas a números após o ID do bug.

Componentes do kernel

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo malicioso local execute código arbitrário no contexto do kernel.

CVE Referências Modelo Gravidade Componente
CVE-2017-0648 A-36101220 * EoP Alto depurador FIQ
CVE-2017-0651 A-35644815 * EU IRIA Baixo Subsistema ION

Bibliotecas

A vulnerabilidade mais grave nesta seção pode permitir que um invasor remoto usando um arquivo especialmente criado obtenha acesso a informações confidenciais.

CVE Referências Modelo Gravidade Versões AOSP atualizadas
CVE-2015-7995 A-36810065 * EU IRIA Moderado 4.4.4

Componentes MediaTek

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo malicioso local execute código arbitrário no contexto do kernel.

CVE Referências Modelo Gravidade Componente
CVE-2017-0636 A-35310230 *
M-ALPS03162263
EoP Alto Driver de fila de comandos
CVE-2017-0649 A-34468195 *
M-ALPS03162283
EoP Moderado Driver de som

Componentes NVIDIA

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo malicioso local execute código arbitrário no contexto do kernel.

CVE Referências Modelo Gravidade Componente
CVE-2017-6247 A-34386301 *
N-CVE-2017-6247
EoP Alto Driver de som
CVE-2017-6248 A-34372667 *
N-CVE-2017-6248
EoP Moderado Driver de som
CVE-2017-6249 A-34373711 *
N-CVE-2017-6249
EoP Moderado Driver de som

Componentes da Qualcomm

A vulnerabilidade mais grave nesta seção pode permitir que um invasor próximo execute código arbitrário no contexto do kernel.

CVE Referências Modelo Gravidade Componente
CVE-2017-7371 A-36250786
QC-CR#1101054
RCE Crítico Driver Bluetooth
CVE-2017-7365 A-32449913
QC-CR#1017009
EoP Alto Bootloader
CVE-2017-7366 A-36252171
QC-CR#1036161 [ 2 ]
EoP Alto Driver GPU
CVE-2017-7367 A-34514708
QC-CR#1008421
DoS Alto Bootloader
CVE-2016-5861 A-36251375
QC-CR#1103510
EoP Moderado Driver de vídeo
CVE-2016-5864 A-36251231
QC-CR#1105441
EoP Moderado Driver de som
CVE-2017-6421 A-36251986
QC-CR#1110563
EoP Moderado Driver de tela sensível ao toque MStar
CVE-2017-7364 A-36252179
QC-CR#1113926
EoP Moderado Driver de vídeo
CVE-2017-7368 A-33452365
QC-CR#1103085
EoP Moderado Driver de som
CVE-2017-7369 A-33751424
QC-CR#2009216 [ 2 ]
EoP Moderado Driver de som
CVE-2017-7370 A-34328139
QC-CR#2006159
EoP Moderado Driver de vídeo
CVE-2017-7372 A-36251497
QC-CR#1110068
EoP Moderado Driver de vídeo
CVE-2017-7373 A-36251984
QC-CR#1090244
EoP Moderado Driver de vídeo
CVE-2017-8233 A-34621613
QC-CR#2004036
EoP Moderado Driver da câmera
CVE-2017-8234 A-36252121
QC-CR#832920
EoP Moderado Driver da câmera
CVE-2017-8235 A-36252376
QC-CR#1083323
EoP Moderado Driver da câmera
CVE-2017-8236 A-35047217
QC-CR#2009606
EoP Moderado Driver IPA
CVE-2017-8237 A-36252377
QC-CR#1110522
EoP Moderado Driver de rede
CVE-2017-8242 A-34327981
QC-CR#2009231
EoP Moderado Driver do Secure Execution Environment Communicator
CVE-2017-8239 A-36251230
QC-CR#1091603
EU IRIA Moderado Driver da câmera
CVE-2017-8240 A-36251985
QC-CR#856379
EU IRIA Moderado Driver do controlador de pinos
CVE-2017-8241 A-34203184
QC-CR#1069175
EU IRIA Baixo motorista wi fi

Componentes Synaptics

A vulnerabilidade mais grave nesta seção pode permitir que um aplicativo malicioso local acesse dados fora de seus níveis de permissão.

CVE Referências Modelo Gravidade Componente
CVE-2017-0650 A-35472278 * EoP Baixo Driver da tela sensível ao toque

Componentes de código fechado da Qualcomm

Essas vulnerabilidades afetam os componentes da Qualcomm e são descritas com mais detalhes nos boletins de segurança do Qualcomm AMSS de 2014–2016. Eles estão incluídos neste boletim de segurança do Android para associar suas correções a um nível de patch de segurança do Android. Correções para essas vulnerabilidades estão disponíveis diretamente na Qualcomm.

CVE Referências Modelo Gravidade Componente
CVE-2014-9960 A-37280308 * N / D Crítico Componente de código fechado
CVE-2014-9961 A-37279724 * N / D Crítico Componente de código fechado
CVE-2014-9953 A-36714770 * N / D Crítico Componente de código fechado
CVE-2014-9967 A-37281466 * N / D Crítico Componente de código fechado
CVE-2015-9026 A-37277231 * N / D Crítico Componente de código fechado
CVE-2015-9027 A-37279124 * N / D Crítico Componente de código fechado
CVE-2015-9008 A-36384689 * N / D Crítico Componente de código fechado
CVE-2015-9009 A-36393600 * N / D Crítico Componente de código fechado
CVE-2015-9010 A-36393101 * N / D Crítico Componente de código fechado
CVE-2015-9011 A-36714882 * N / D Crítico Componente de código fechado
CVE-2015-9024 A-37265657 * N / D Crítico Componente de código fechado
CVE-2015-9012 A-36384691 * N / D Crítico Componente de código fechado
CVE-2015-9013 A-36393251 * N / D Crítico Componente de código fechado
CVE-2015-9014 A-36393750 * N / D Crítico Componente de código fechado
CVE-2015-9015 A-36714120 * N / D Crítico Componente de código fechado
CVE-2015-9029 A-37276981 * N / D Crítico Componente de código fechado
CVE-2016-10338 A-37277738 * N / D Crítico Componente de código fechado
CVE-2016-10336 A-37278436 * N / D Crítico Componente de código fechado
CVE-2016-10333 A-37280574 * N / D Crítico Componente de código fechado
CVE-2016-10341 A-37281667 * N / D Crítico Componente de código fechado
CVE-2016-10335 A-37282802 * N / D Crítico Componente de código fechado
CVE-2016-10340 A-37280614 * N / D Crítico Componente de código fechado
CVE-2016-10334 A-37280664 * N / D Crítico Componente de código fechado
CVE-2016-10339 A-37280575 * N / D Crítico Componente de código fechado
CVE-2016-10298 A-36393252 * N / D Crítico Componente de código fechado
CVE-2016-10299 A-32577244 * N / D Crítico Componente de código fechado
CVE-2014-9954 A-36388559 * N / D Alto Componente de código fechado
CVE-2014-9955 A-36384686 * N / D Alto Componente de código fechado
CVE-2014-9956 A-36389611 * N / D Alto Componente de código fechado
CVE-2014-9957 A-36387564 * N / D Alto Componente de código fechado
CVE-2014-9958 A-36384774 * N / D Alto Componente de código fechado
CVE-2014-9962 A-37275888 * N / D Alto Componente de código fechado
CVE-2014-9963 A-37276741 * N / D Alto Componente de código fechado
CVE-2014-9959 A-36383694 * N / D Alto Componente de código fechado
CVE-2014-9964 A-37280321 * N / D Alto Componente de código fechado
CVE-2014-9965 A-37278233 * N / D Alto Componente de código fechado
CVE-2014-9966 A-37282854 * N / D Alto Componente de código fechado
CVE-2015-9023 A-37276138 * N / D Alto Componente de código fechado
CVE-2015-9020 A-37276742 * N / D Alto Componente de código fechado
CVE-2015-9021 A-37276743 * N / D Alto Componente de código fechado
CVE-2015-9025 A-37276744 * N / D Alto Componente de código fechado
CVE-2015-9022 A-37280226 * N / D Alto Componente de código fechado
CVE-2015-9028 A-37277982 * N / D Alto Componente de código fechado
CVE-2015-9031 A-37275889 * N / D Alto Componente de código fechado
CVE-2015-9032 A-37279125 * N / D Alto Componente de código fechado
CVE-2015-9033 A-37276139 * N / D Alto Componente de código fechado
CVE-2015-9030 A-37282907 * N / D Alto Componente de código fechado
CVE-2016-10332 A-37282801 * N / D Alto Componente de código fechado
CVE-2016-10337 A-37280665 * N / D Alto Componente de código fechado
CVE-2016-10342 A-37281763 * N / D Alto Componente de código fechado

Atualizações de dispositivos do Google

Esta tabela contém o nível de patch de segurança na atualização remota (OTA) mais recente e imagens de firmware para dispositivos do Google. As imagens de firmware do dispositivo Google estão disponíveis no site do Google Developer .

dispositivo Google Nível de patch de segurança
Pixel / Pixel XL 05 de junho de 2017
Nexus 5X 05 de junho de 2017
Nexus 6 05 de junho de 2017
Nexus 6P 05 de junho de 2017
Nexus 9 05 de junho de 2017
Nexus Player 05 de junho de 2017
Pixel C 05 de junho de 2017

As atualizações de dispositivos do Google também contêm patches para essas vulnerabilidades de segurança, se aplicável:

CVE Referências Modelo Gravidade Versões AOSP atualizadas
CVE-2017-0639 A-35310991 EU IRIA Alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Reconhecimentos

Gostaríamos de agradecer a esses pesquisadores por suas contribuições:

CVEs Pesquisadores
CVE-2017-0643, CVE-2017-0641 Ecular Xu(徐健) da Trend Micro
CVE-2017-0645, CVE-2017-0639 En He ( @heeeeen4x ) e Bo Liu do MS509Team
CVE-2017-0649 Gengjia Chen ( @chengjia4574 ) e pjf do IceSword Lab, Qihoo 360 Technology Co. Ltd.
CVE-2017-0646 Godzheng (郑文选 - @VirtualSeekers ) do Tencent PC Manager
CVE-2017-0636 Jake Corina ( @JakeCorina ) da Shellphish Grill Team
CVE-2017-8233 Jianqiang Zhao ( @jianqiangzhao ) e pjf do IceSword Lab, Qihoo 360
CVE-2017-7368 Lubo Zhang ( zlbzlb815@163.com ), Yuan-Tsung Lo ( computernik@gmail.com ) e Xuxian Jiang da equipe C0RE
CVE-2017-8242 Nathan Crandall ( @natecray ) da equipe de segurança de produtos da Tesla
CVE-2017-0650 Omer Shwartz, Amir Cohen, Dr. Asaf Shabtai e Dr. Yossi Oren do Laboratório Cibernético da Universidade Ben Gurion
CVE-2017-0648 Roee Hay ( @roeehay ) da Aleph Research , HCL Technologies
CVE-2017-7369, CVE-2017-6249, CVE-2017-6247, CVE-2017-6248 sevenshen ( @lingtongshen ) da TrendMicro
CVE-2017-0642, CVE-2017-0637, CVE-2017-0638 Vasily Vasiliev
CVE-2017-0640 VEO ( @VYSEa ) da equipe de resposta a ameaças móveis , Trend Micro
CVE-2017-8236 Xiling Gong do Departamento de Plataforma de Segurança da Tencent
CVE-2017-0647 Yangkang ( @dnpushme ) e Liyadong da Qex Team, Qihoo 360
CVE-2017-7370 Yonggang Guo ( @guoygang ) do IceSword Lab, Qihoo 360 Technology Co. Ltd
CVE-2017-0651 Yuan-Tsung Lo ( computernik@gmail.com ) e Xuxian Jiang da equipe C0RE
CVE-2017-8241 Zubin Mitra do Google

Perguntas e respostas comuns

Esta seção responde a perguntas comuns que podem ocorrer após a leitura deste boletim.

1. Como determino se meu dispositivo está atualizado para resolver esses problemas?

Para saber como verificar o nível de patch de segurança de um dispositivo, leia as instruções na programação de atualização do Pixel e do Nexus .

  • Os níveis de patch de segurança de 2017-06-01 ou posterior abordam todos os problemas associados ao nível de patch de segurança 2017-06-01.
  • Os níveis de patch de segurança de 2017-06-05 ou posterior abordam todos os problemas associados ao nível de patch de segurança 2017-06-05 e todos os níveis de patch anteriores.

Os fabricantes de dispositivos que incluem essas atualizações devem definir o nível da string de patch para:

  • [ro.build.version.security_patch]:[2017-06-01]
  • [ro.build.version.security_patch]:[2017-06-05]

2. Por que este boletim tem dois níveis de patch de segurança?

Este boletim tem dois níveis de patch de segurança para que os parceiros Android tenham a flexibilidade de corrigir um subconjunto de vulnerabilidades semelhantes em todos os dispositivos Android mais rapidamente. Os parceiros Android são incentivados a corrigir todos os problemas neste boletim e usar o nível de patch de segurança mais recente.

  • Os dispositivos que usam o nível de patch de segurança de 01 de junho de 2017 devem incluir todos os problemas associados a esse nível de patch de segurança, bem como correções para todos os problemas relatados em boletins de segurança anteriores.
  • Os dispositivos que usam o nível de patch de segurança de 05 de junho de 2017 ou mais recente devem incluir todos os patches aplicáveis ​​neste (e nos anteriores) boletins de segurança.

Os parceiros são incentivados a agrupar as correções para todos os problemas que estão abordando em uma única atualização.

3. O que significam as entradas na coluna Tipo ?

As entradas na coluna Tipo da tabela de detalhes da vulnerabilidade fazem referência à classificação da vulnerabilidade de segurança.

Abreviação Definição
RCE Execução remota de código
EoP Elevação de privilégio
EU IRIA Divulgação de informação
DoS Negação de serviço
N / D Classificação não disponível

4. O que significam as entradas na coluna Referências ?

As entradas na coluna Referências da tabela de detalhes da vulnerabilidade podem conter um prefixo que identifica a organização à qual o valor de referência pertence.

Prefixo Referência
UMA- ID do bug do Android
CQ- Número de referência da Qualcomm
M- Número de referência da MediaTek
N- Número de referência da NVIDIA
B- Número de referência da Broadcom

5. O que significa um * ao lado do ID do bug do Android na coluna Referências ?

Os problemas que não estão disponíveis publicamente têm um * ao lado do ID do bug do Android na coluna Referências . A atualização para esse problema geralmente está contida nos drivers binários mais recentes para dispositivos Nexus disponíveis no site do Google Developer .

Versões

Versão Encontro Notas
1,0 5 de junho de 2017 Boletim publicado.
1.1 7 de junho de 2017 Boletim revisado para incluir links AOSP.
1.2 11 de julho de 2017 Boletim revisado para incluir CVE-2017-6249.
1.3 17 de agosto de 2017 Boletim revisado para atualizar os números de referência.