Bollettino di aggiornamento dei pixel: dicembre 2021

Pubblicato il 6 dicembre 2021 | Aggiornato il 20 gennaio 2021

Il Pixel Update Bulletin contiene dettagli sulle vulnerabilità della sicurezza e miglioramenti funzionali che interessano i dispositivi Pixel supportati (dispositivi Google). Per i dispositivi Google, i livelli di patch di sicurezza del 05-12-2021 o successivi risolvono tutti i problemi in questo bollettino e tutti i problemi nel bollettino sulla sicurezza Android di dicembre 2021. Per informazioni su come controllare il livello di patch di sicurezza di un dispositivo, consulta Controllare e aggiornare la versione di Android .

Tutti i dispositivi Google supportati riceveranno un aggiornamento al livello di patch 2021-12-05. Invitiamo tutti i clienti ad accettare questi aggiornamenti sui propri dispositivi.

Annunci

  • Oltre alle vulnerabilità di sicurezza descritte nel Bollettino sulla sicurezza di ndroid di dicembre 2021, i dispositivi Google contengono anche patch per le vulnerabilità di sicurezza descritte di seguito.

Patch di sicurezza

Le vulnerabilità sono raggruppate sotto la componente che interessano. C'è una descrizione del problema e una tabella con il CVE, i riferimenti associati, il tipo di vulnerabilità , la gravità e le versioni aggiornate di Android Open Source Project (AOSP) (ove applicabile). Quando disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID del bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, i riferimenti aggiuntivi sono collegati a numeri che seguono l'ID del bug.

Struttura

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2021-0981 A-191981182 EoP Moderare 12
CVE-2021-0984 A-192475653 EoP Moderare 12
CVE-2021-0985 A-190403923 EoP Moderare 12
CVE-2021-1019 A-195031401 EoP Moderare 12
CVE-2021-1024 A-191283525 EoP Moderare 12
CVE-2021-0978 A-192587406 ID Moderare 12
CVE-2021-0979 A-191772737 ID Moderare 12
CVE-2021-0982 A-192368508 ID Moderare 12
CVE-2021-0986 A-192247339 ID Moderare 12
CVE-2021-0988 A-191954233 [ 2 ] ID Moderare 12
CVE-2021-1009 A-189858128 ID Moderare 12
CVE-2021-1010 A-189857801 ID Moderare 12
CVE-2021-1011 A-188219307 ID Moderare 12
CVE-2021-1013 A-186404356 ID Moderare 12
CVE-2021-1030 A-194697001 ID Moderare 12
CVE-2021-1031 A-194697004 ID Moderare 12
CVE-2021-1032 A-184745603 ID Moderare 12
CVE-2021-0993 A-193849901 DoS Moderare 12

Quadro multimediale

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2021-1003 A-189857506 EoP Moderare 12
CVE-2021-1027 A-193033243 EoP Moderare 12
CVE-2021-1028 A-193034683 EoP Moderare 12
CVE-2021-1029 A-193034677 EoP Moderare 12
CVE-2021-0976 A-199680600 ID Moderare 12
CVE-2021-0998 A-193442575 ID Moderare 12
CVE-2021-1001 A-190435883 ID Moderare 12
CVE-2021-1002 A-194533433 ID Moderare 12
CVE-2021-1018 A-194110891 ID Moderare 12

Messaggistica

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2021-0973 A-197328178 ID Moderare 12

Sistema

CVE Riferimenti Tipo Gravità Versioni AOSP aggiornate
CVE-2021-0769 A-184676316 EoP Moderare 12
CVE-2021-0977 A-183487770 EoP Moderare 12
CVE-2021-0992 A-180104327 EoP Moderare 12
CVE-2021-0999 A-196858999 EoP Moderare 12
CVE-2021-1004 A-197749180 EoP Moderare 12
CVE-2021-1016 A-183610267 EoP Moderare 12
CVE-2021-1017 A-182583850 EoP Moderare 12
CVE-2021-1020 A-195111725 EoP Moderare 12
CVE-2021-1021 A-195031703 EoP Moderare 12
CVE-2021-0987 A-190619791 ID Moderare 12
CVE-2021-0989 A-194105812 ID Moderare 12
CVE-2021-0990 A-185591180 ID Moderare 12
CVE-2021-0991 A-181588752 ID Moderare 12
CVE-2021-0994 A-193801134 ID Moderare 12
CVE-2021-0995 A-197536547 ID Moderare 12
CVE-2021-0996 A-181346545 ID Moderare 12
CVE-2021-0997 A-191086488 ID Moderare 12
CVE-2021-1005 A-186530889 ID Moderare 12
CVE-2021-1006 A-183961974 ID Moderare 12
CVE-2021-1007 A-167759047 ID Moderare 12
CVE-2021-1012 A-195412179 ID Moderare 12
CVE-2021-1014 A-186776740 ID Moderare 12
CVE-2021-1015 A-186530496 ID Moderare 12
CVE-2021-1023 A-195963373 ID Moderare 12
CVE-2021-1025 A-193800652 ID Moderare 12
CVE-2021-1026 A-194798757 ID Moderare 12
CVE-2021-1034 A-193441322 ID Moderare 12
CVE-2021-1008 A-197327688 DoS Moderare 12
CVE-2021-1022 A-180420059 DoS Moderare 12

Componenti del kernel

CVE Riferimenti Tipo Gravità Componente
CVE-2020-25668 A-190228658
kernel a monte
EoP Moderare kernel
CVE-2021-23134 A-188883590
kernel a monte
EoP Moderare NFC
CVE-2021-33200 A-190011721
Kernel a monte [ 2 ] [ 3 ]
EoP Moderare kernel
CVE-2021-39656 A-174049066
kernel a monte
EoP Moderare kernel
CVE-2021-39636 A-120612905
Kernel a monte [ 2 ] [ 3 ] [ 4 ] [ 5 ]
ID Moderare kernel
CVE-2021-39648 A-160822094
kernel a monte
ID Moderare kernel
CVE-2021-39657 A-194696049
kernel a monte
ID Moderare kernel

Pixel

CVE Riferimenti Tipo Gravità Componente
CVE-2021-39639 A-198291476 * EoP Alto Boot loader
CVE-2021-39640 A-157294279 * EoP Alto USB
CVE-2021-39644 A-199809304 * EoP Alto Boot loader
CVE-2021-39645 A-199805112 * EoP Alto Boot loader
CVE-2021-1047 A-197966306 * ID Alto Titano M2
CVE-2021-39638 A-195607566 * EoP Moderare Telecamera
CVE-2021-39641 A-126949257 * EoP Moderare Boot loader
CVE-2021-39642 A-195731663 * EoP Moderare Telecamera
CVE-2021-39643 A-195573629 * EoP Moderare Titano M2
CVE-2021-39649 A-174049006 * EoP Moderare Audio
CVE-2021-39650 A-169763055 * EoP Moderare kernel
CVE-2021-39651 A-193438173 * EoP Moderare Biometrica
CVE-2021-39652 A-194499021 * EoP Moderare Tocco
CVE-2021-39653 A-193443223 * EoP Moderare Boot loader
CVE-2021-39655 A-192641593 * EoP Moderare kernel
CVE-2021-1046 A-195609074 * ID Moderare Telecamera
CVE-2021-39637 A-193579873 * ID Moderare Sistema
CVE-2021-39646 A-201537251 * ID Moderare Boot loader
CVE-2021-39647 A-198713939 * ID Moderare Boot loader

componenti Qualcomm

CVE Riferimenti Gravità Componente
CVE-2021-30298
A-190408641
QC-CR#2873209 [ 2 ]
Moderare kernel

Patch funzionali

Per i dettagli sulle nuove correzioni di bug e patch funzionali incluse in questa versione, fare riferimento al forum della community di Pixel .

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che possono verificarsi dopo la lettura di questo bollettino.

1. Come faccio a determinare se il mio dispositivo è aggiornato per risolvere questi problemi?

I livelli di patch di sicurezza del 05-12-2021 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza del 05-12-2021 e tutti i livelli di patch precedenti. Per informazioni su come controllare il livello di patch di sicurezza di un dispositivo, leggi le istruzioni sul programma di aggiornamento del dispositivo Google .

2. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice a distanza
EoP Elevazione del privilegio
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

3. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
controllo qualità- Numero di riferimento Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom
U- Numero di riferimento UNISOC

4. Cosa significa un * accanto all'ID del bug Android nella colonna Riferimenti ?

I problemi che non sono disponibili pubblicamente hanno un * accanto all'ID del bug Android nella colonna Riferimenti . L'aggiornamento per quel problema è generalmente contenuto nei driver binari più recenti per i dispositivi Pixel disponibili sul sito Google Developer .

5. Perché le vulnerabilità della sicurezza sono suddivise tra questo bollettino e i bollettini sulla sicurezza di Android?

Le vulnerabilità di sicurezza documentate nei Bollettini sulla sicurezza di Android sono necessarie per dichiarare il livello di patch di sicurezza più recente sui dispositivi Android. Ulteriori vulnerabilità di sicurezza, come quelle documentate in questo bollettino, non sono necessarie per dichiarare un livello di patch di sicurezza.

Versioni

Versione Data Appunti
1.0 6 dicembre 2021 Bollettino rilasciato
1.1 8 dicembre 2021 Bollettino rivisto per includere i collegamenti AOSP
1.2 20 gennaio 2021 Elenco dei problemi aggiornato