Android Güvenlik Bülteni—Haziran 2017

5 Haziran 2017'de yayınlandı | 17 Ağustos 2017'de güncellendi

Android Güvenlik Bülteni, Android cihazlarını etkileyen güvenlik açıklarının ayrıntılarını içerir. 05 Haziran 2017 veya sonraki güvenlik yaması seviyeleri, tüm bu sorunları giderir. Bir cihazın güvenlik yama düzeyini nasıl kontrol edeceğinizi öğrenmek için Pixel ve Nexus güncelleme planına bakın.

Ortaklar, bültende açıklanan sorunlar hakkında en az bir ay önce bilgilendirildi. Bu sorunlar için kaynak kodu yamaları Android Açık Kaynak Projesi (AOSP) deposunda yayınlanacak ve bu bültenden bağlantı verilecektir. Bu bülten ayrıca AOSP dışındaki yamalara bağlantılar içerir.

Bu sorunların en şiddetlisi, medya dosyası ve veri işleme sırasında özel hazırlanmış bir dosya kullanarak uzaktaki bir saldırganın bellek bozulmasına neden olmasına olanak tanıyan Media Framework'teki kritik bir güvenlik açığıdır. Önem derecesi değerlendirmesi , platform ve hizmet azaltmalarının geliştirme amacıyla kapatıldığı veya başarılı bir şekilde atlandığı varsayılarak, güvenlik açığından yararlanmanın muhtemelen etkilenen bir cihaz üzerindeki etkisine dayanır.

Yeni bildirilen bu sorunların aktif müşteri istismarı veya kötüye kullanımıyla ilgili herhangi bir rapor almadık. Android platformunun güvenliğini artıran Android güvenlik platformu korumaları ve Google Play Protect ile ilgili ayrıntılar için Android ve Google Play Protect azaltıcı etkenler bölümüne bakın.

Tüm müşterilerimizi cihazlarında bu güncellemeleri kabul etmeye teşvik ediyoruz.

Not: Google cihazları için en son kablosuz güncelleme (OTA) ve donanım yazılımı görüntüleri hakkında bilgi, Google cihaz güncellemeleri bölümünde mevcuttur.

Duyurular

  • Aylık güvenlik bültenini okumayı kolaylaştırmak için basitleştirdik. Bu güncellemenin bir parçası olarak, güvenlik açığı bilgileri, etkilenen bileşene göre sınıflandırılır, bir güvenlik düzeltme eki düzeyinde bileşen adına göre sıralanır ve Google cihazına özel bilgiler özel bir bölümde barındırılır.
  • Bu bülten, Android iş ortaklarına tüm Android cihazlarda benzer bir güvenlik açığı alt kümesini daha hızlı düzeltme esnekliği sağlamak için iki güvenlik düzeltme eki düzeyinde dizeye sahiptir. Ek bilgi için Genel sorular ve yanıtlara bakın:
    • 2017-06-01 : Kısmi güvenlik yaması düzeyi dizesi. Bu güvenlik düzeltme eki düzeyi dizesi, 2017-06-01 (ve önceki tüm güvenlik düzeltme eki düzeyi dizeleri) ile ilişkili tüm sorunların ele alındığını gösterir.
    • 2017-06-05 : Güvenlik yaması düzeyi dizesini tamamlayın. Bu güvenlik yaması düzeyi dizesi, 2017-06-01 ve 2017-06-05 (ve önceki tüm güvenlik yaması düzeyi dizeleri) ile ilişkili tüm sorunların ele alındığını gösterir.

Android ve Google Play Protect azaltıcı etkenler

Bu, Android güvenlik platformu ve Google Play Protect gibi hizmet korumaları tarafından sağlanan azaltmaların bir özetidir. Bu yetenekler, güvenlik açıklarından Android'de başarıyla yararlanma olasılığını azaltır.

  • Android platformunun daha yeni sürümlerinde yapılan geliştirmeler sayesinde Android'deki birçok sorundan yararlanma daha zor hale getirildi. Tüm kullanıcıları, mümkün olduğunda Android'in en son sürümüne güncellemeye teşvik ediyoruz.
  • Android güvenlik ekibi, Google Play Protect aracılığıyla kötüye kullanımı etkin bir şekilde izler ve kullanıcıları Zararlı Olabilecek Uygulamalar hakkında uyarır. Google Play Protect, Google Mobil Hizmetleri bulunan cihazlarda varsayılan olarak etkindir ve özellikle Google Play dışından uygulama yükleyen kullanıcılar için önemlidir.

2017-06-01 güvenlik yaması düzeyi—Güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2017-06-01 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sunuyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılmıştır. Sorunun açıklaması ve CVE, ilgili referanslar, güvenlik açığı türü , önem derecesi ve güncellenmiş AOSP sürümlerinin (varsa) bulunduğu bir tablo vardır. Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır.

Bluetooth

Bu bölümdeki en ciddi güvenlik açığı, yerel bir kötü amaçlı uygulamanın izin düzeylerinin dışındaki verilere erişmesine olanak verebilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2017-0645 A-35385327 EoP Ilıman 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0646 A-33899337 İD Ilıman 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

kütüphaneler

Bu bölümdeki en ciddi güvenlik açığı, uzaktaki bir saldırganın özel hazırlanmış bir dosya kullanarak ayrıcalıksız bir işlem bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2015-8871 A-35443562 * RCE Yüksek 5.0.2, 5.1.1, 6.0, 6.0.1
CVE-2016-8332 A-37761553 * RCE Yüksek 5.0.2, 5.1.1, 6.0, 6.0.1
CVE-2016-5131 A-36554209 RCE Yüksek 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016-4658 A-36554207 RCE Yüksek 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0663 A-37104170 RCE Yüksek 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-7376 A-36555370 RCE Yüksek 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-5056 A-36809819 RCE Ilıman 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-7375 A-36556310 RCE Ilıman 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0647 A-36392138 İD Ilıman 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2016-1839 A-36553781 DoS Ilıman 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Medya çerçevesi

Bu bölümdeki en ciddi güvenlik açığı, uzak bir saldırganın özel hazırlanmış bir dosya kullanarak medya dosyası ve veri işleme sırasında belleğin bozulmasına neden olabilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2017-0637 A-34064500 RCE kritik 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0391 A-32322258 DoS Yüksek 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0640 A-33129467 * DoS Yüksek 6.0, 6.0.1, 7.0, 7.1.1
CVE-2017-0641 A-34360591 DoS Yüksek 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0642 A-34819017 DoS Yüksek 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0643 A-35645051 * DoS Yüksek 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1
CVE-2017-0644 A-35472997 * DoS Yüksek 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1

Sistem Kullanıcı Arayüzü

Bu bölümdeki en ciddi güvenlik açığı, özel hazırlanmış bir dosya kullanan bir saldırganın ayrıcalıksız bir işlem bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2017-0638 A-36368305 RCE Yüksek 7.1.1, 7.1.2

2017-06-05 güvenlik yaması düzeyi—Güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2017-06-05 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sunuyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılmıştır ve CVE, ilişkili referanslar, güvenlik açığı türü , önem derecesi , bileşen (varsa) ve güncellenmiş AOSP sürümleri (varsa) gibi ayrıntıları içerir. Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır.

çekirdek bileşenleri

Bu bölümdeki en ciddi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tip önem Bileşen
CVE-2017-0648 A-36101220 * EoP Yüksek FIQ hata ayıklayıcı
CVE-2017-0651 A-35644815 * İD Düşük ION alt sistemi

kütüphaneler

Bu bölümdeki en ciddi güvenlik açığı, uzaktaki bir saldırganın özel hazırlanmış bir dosya kullanarak hassas bilgilere erişmesine olanak verebilir.

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2015-7995 A-36810065 * İD Ilıman 4.4.4

MediaTek bileşenleri

Bu bölümdeki en ciddi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tip önem Bileşen
CVE-2017-0636 A-35310230 *
M-ALPS03162263
EoP Yüksek Komut kuyruğu sürücüsü
CVE-2017-0649 A-34468195 *
M-ALPS03162283
EoP Ilıman Ses sürücüsü

NVIDIA bileşenleri

Bu bölümdeki en ciddi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tip önem Bileşen
CVE-2017-6247 A-34386301 *
N-CVE-2017-6247
EoP Yüksek Ses sürücüsü
CVE-2017-6248 A-34372667 *
N-CVE-2017-6248
EoP Ilıman Ses sürücüsü
CVE-2017-6249 A-34373711 *
N-CVE-2017-6249
EoP Ilıman Ses sürücüsü

Qualcomm bileşenleri

Bu bölümdeki en ciddi güvenlik açığı, yakın bir saldırganın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tip önem Bileşen
CVE-2017-7371 A-36250786
KK-CR#1101054
RCE kritik Bluetooth sürücüsü
CVE-2017-7365 A-32449913
QC-CR#1017009
EoP Yüksek önyükleyici
CVE-2017-7366 A-36252171
QC-CR#1036161 [ 2 ]
EoP Yüksek GPU sürücüsü
CVE-2017-7367 A-34514708
KK-CR#1008421
DoS Yüksek önyükleyici
CVE-2016-5861 A-36251375
KK-CR#1103510
EoP Ilıman video sürücüsü
CVE-2016-5864 A-36251231
KK-CR#1105441
EoP Ilıman Ses sürücüsü
CVE-2017-6421 A-36251986
QC-CR#1110563
EoP Ilıman MStar dokunmatik ekran sürücüsü
CVE-2017-7364 A-36252179
QC-CR#1113926
EoP Ilıman video sürücüsü
CVE-2017-7368 A-33452365
KK-CR#1103085
EoP Ilıman Ses sürücüsü
CVE-2017-7369 A-33751424
QC-CR#2009216 [ 2 ]
EoP Ilıman Ses sürücüsü
CVE-2017-7370 A-34328139
KK-CR#2006159
EoP Ilıman video sürücüsü
CVE-2017-7372 A-36251497
KK-CR#1110068
EoP Ilıman video sürücüsü
CVE-2017-7373 A-36251984
QC-CR#1090244
EoP Ilıman video sürücüsü
CVE-2017-8233 A-34621613
QC-CR#2004036
EoP Ilıman kamera sürücüsü
CVE-2017-8234 A-36252121
QC-CR#832920
EoP Ilıman kamera sürücüsü
CVE-2017-8235 A-36252376
QC-CR#1083323
EoP Ilıman kamera sürücüsü
CVE-2017-8236 A-35047217
QC-CR#2009606
EoP Ilıman IPA sürücüsü
CVE-2017-8237 A-36252377
QC-CR#1110522
EoP Ilıman ağ sürücüsü
CVE-2017-8242 A-34327981
KK-CR#2009231
EoP Ilıman Güvenli Yürütme Ortamı İletişimcisi sürücüsü
CVE-2017-8239 A-36251230
QC-CR#1091603
İD Ilıman kamera sürücüsü
CVE-2017-8240 A-36251985
QC-CR#856379
İD Ilıman Pin denetleyici sürücüsü
CVE-2017-8241 A-34203184
QC-CR#1069175
İD Düşük Wi-Fi sürücüsü

sinaptik bileşenleri

Bu bölümdeki en ciddi güvenlik açığı, yerel bir kötü amaçlı uygulamanın izin düzeylerinin dışındaki verilere erişmesine olanak verebilir.

CVE Referanslar Tip önem Bileşen
CVE-2017-0650 A-35472278 * EoP Düşük Dokunmatik ekran sürücüsü

Qualcomm kapalı kaynak bileşenleri

Bu güvenlik açıkları Qualcomm bileşenlerini etkiler ve 2014-2016 Qualcomm AMSS güvenlik bültenlerinde daha ayrıntılı olarak açıklanmıştır. Düzeltmelerini bir Android güvenlik düzeltme eki düzeyiyle ilişkilendirmek için bu Android güvenlik bültenine dahil edilmiştir. Bu güvenlik açıkları için düzeltmeler doğrudan Qualcomm'dan edinilebilir.

CVE Referanslar Tip önem Bileşen
CVE-2014-9960 A-37280308 * Yok kritik Kapalı kaynak bileşeni
CVE-2014-9961 A-37279724 * Yok kritik Kapalı kaynak bileşeni
CVE-2014-9953 A-36714770 * Yok kritik Kapalı kaynak bileşeni
CVE-2014-9967 A-37281466 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9026 A-37277231 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9027 A-37279124 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9008 A-36384689 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9009 A-36393600 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9010 A-36393101 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9011 A-36714882 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9024 A-37265657 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9012 A-36384691 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9013 A-36393251 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9014 A-36393750 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9015 A-36714120 * Yok kritik Kapalı kaynak bileşeni
CVE-2015-9029 A-37276981 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10338 A-37277738 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10336 A-37278436 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10333 A-37280574 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10341 A-37281667 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10335 A-37282802 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10340 A-37280614 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10334 A-37280664 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10339 A-37280575 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10298 A-36393252 * Yok kritik Kapalı kaynak bileşeni
CVE-2016-10299 A-32577244 * Yok kritik Kapalı kaynak bileşeni
CVE-2014-9954 A-36388559 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9955 A-36384686 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9956 A-36389611 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9957 A-36387564 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9958 A-36384774 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9962 A-37275888 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9963 A-37276741 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9959 A-36383694 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9964 A-37280321 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9965 A-37278233 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2014-9966 A-37282854 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9023 A-37276138 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9020 A-37276742 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9021 A-37276743 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9025 A-37276744 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9022 A-37280226 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9028 A-37277982 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9031 A-37275889 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9032 A-37279125 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9033 A-37276139 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2015-9030 A-37282907 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2016-10332 A-37282801 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2016-10337 A-37280665 * Yok Yüksek Kapalı kaynak bileşeni
CVE-2016-10342 A-37281763 * Yok Yüksek Kapalı kaynak bileşeni

Google cihaz güncellemeleri

Bu tablo, en son kablosuz güncellemedeki (OTA) güvenlik düzeltme eki düzeyini ve Google cihazları için ürün yazılımı görüntülerini içerir. Google cihazı donanım yazılımı görüntüleri, Google Developer sitesinde mevcuttur.

Google cihazı Güvenlik yaması düzeyi
Piksel / Piksel XL 05 Haziran 2017
Nexus 5X 05 Haziran 2017
Bağlantı Noktası 6 05 Haziran 2017
Nexus 6P 05 Haziran 2017
Bağlantı Noktası 9 05 Haziran 2017
Nexus Oyuncusu 05 Haziran 2017
Piksel C 05 Haziran 2017

Google cihaz güncellemeleri, varsa, bu güvenlik açıkları için de yamalar içerir:

CVE Referanslar Tip önem Güncellenmiş AOSP sürümleri
CVE-2017-0639 A-35310991 İD Yüksek 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Teşekkür

Bu araştırmacılara katkılarından dolayı teşekkür etmek isteriz:

CVE'ler araştırmacılar
CVE-2017-0643, CVE-2017-0641 Trend Micro'nun Eküler Xu(徐健)
CVE-2017-0645, CVE-2017-0639 En He ( @heeeeen4x ) ve MS509Team'den Bo Liu
CVE-2017-0649 Gengjia Chen ( @chengjia4574 ) ve IceSword Lab, Qihoo 360 Technology Co. Ltd.'den pjf
CVE-2017-0646 Tencent PC Manager'dan Godzheng (郑文选 - @VirtualSeekers )
CVE-2017-0636 Shellphish Grill Ekibinden Jake Corina ( @JakeCorina )
CVE-2017-8233 Jianqiang Zhao ( @jianqiangzhao ) ve IceSword Lab'den pjf , Qihoo 360
CVE-2017-7368 Lubo Zhang ( zlbzlb815@163.com ), Yuan-Tsung Lo ( computernik@gmail.com ) ve C0RE Ekibinden Xuxian Jiang
CVE-2017-8242 Tesla'nın Ürün Güvenliği Ekibinden Nathan Crandall ( @natecray )
CVE-2017-0650 Ben Gurion Üniversitesi Siber Laboratuvarı'ndan Omer Shwartz, Amir Cohen, Dr. Asaf Shabtai ve Dr. Yossi Oren
CVE-2017-0648 Aleph Research , HCL Technologies'den Roee Hay ( @roeehay )
CVE-2017-7369, CVE-2017-6249, CVE-2017-6247, CVE-2017-6248 TrendMicro'dan sevenshen ( @lingtongshen )
CVE-2017-0642, CVE-2017-0637, CVE-2017-0638 Vasili Vasilyev
CVE-2017-0640 Trend Micro Mobile Threat Response Team'in VEO'su ( @VYSEa )
CVE-2017-8236 Tencent Güvenlik Platformu Departmanından Xiling Gong
CVE-2017-0647 Qex Ekibinden Yangkang ( @dnpushme ) ve Liyadong, Qihoo 360
CVE-2017-7370 IceSword Lab, Qihoo 360 Technology Co. Ltd'den Yonggang Guo ( @guoygang )
CVE-2017-0651 Yuan-Tsung Lo ( computernik@gmail.com ) ve C0RE Ekibinden Xuxian Jiang
CVE-2017-8241 Google'dan Zubin Mithra

Sık sorulan sorular ve cevaplar

Bu bölüm, bu bülteni okuduktan sonra ortaya çıkabilecek genel soruları yanıtlamaktadır.

1. Cihazımın bu sorunları gidermek için güncellenip güncellenmediğini nasıl belirleyebilirim?

Bir cihazın güvenlik yama düzeyini nasıl kontrol edeceğinizi öğrenmek için Pixel ve Nexus güncelleme programındaki talimatları okuyun.

  • 2017-06-01 veya sonraki sürümlerin güvenlik yaması seviyeleri, 2017-06-01 güvenlik yaması düzeyiyle ilişkili tüm sorunları ele alır.
  • 2017-06-05 veya sonraki güvenlik yaması seviyeleri, 2017-06-05 güvenlik yaması seviyesi ve önceki tüm yama seviyeleri ile ilgili tüm sorunları ele alır.

Bu güncellemeleri içeren cihaz üreticileri, yama dizesi düzeyini şu şekilde ayarlamalıdır:

  • [ro.build.version.security_patch]:[2017-06-01]
  • [ro.build.version.security_patch]:[2017-06-05]

2. Bu bültende neden iki güvenlik düzeltme eki düzeyi var?

Bu bültende, Android iş ortaklarının tüm Android cihazlarda benzer olan bir dizi güvenlik açığını daha hızlı düzeltme esnekliğine sahip olması için iki güvenlik düzeltme eki düzeyi vardır. Android iş ortaklarının bu bültendeki tüm sorunları düzeltmeleri ve en son güvenlik düzeltme eki düzeyini kullanmaları önerilir.

  • 01 Haziran 2017 güvenlik düzeltme eki düzeyini kullanan cihazlar, söz konusu güvenlik düzeltme eki düzeyiyle ilişkili tüm sorunları ve önceki güvenlik bültenlerinde bildirilen tüm sorunların düzeltmelerini içermelidir.
  • 05 Haziran 2017 veya daha yeni güvenlik düzeltme eki düzeyini kullanan cihazlar, bu (ve önceki) güvenlik bültenlerinde geçerli tüm düzeltme eklerini içermelidir.

İş ortaklarının, ele aldıkları tüm sorunlara yönelik düzeltmeleri tek bir güncellemede toplamaları önerilir.

3. Tür sütunundaki girişler ne anlama geliyor?

Güvenlik açığı ayrıntıları tablosunun Tür sütunundaki girişler, güvenlik açığının sınıflandırmasına başvurur.

Kısaltma Tanım
RCE Uzaktan kod yürütme
EoP Ayrıcalığın yükseltilmesi
İD Bilgi ifşası
DoS hizmet reddi
Yok Sınıflandırma mevcut değil

4. Referanslar sütunundaki girişler ne anlama geliyor?

Güvenlik açığı ayrıntıları tablosunun Referanslar sütunu altındaki girişler, referans değerinin ait olduğu kuruluşu tanımlayan bir önek içerebilir.

Önek Referans
A- Android hata kimliği
KK- Qualcomm referans numarası
M- MediaTek referans numarası
N- NVIDIA referans numarası
B- Broadcom referans numarası

5. Referanslar sütunundaki Android hata kimliğinin yanında * işareti ne anlama gelir?

Herkese açık olmayan sorunların Referanslar sütununda Android hata kimliğinin yanında * işareti bulunur. Bu soruna ilişkin güncelleme genellikle, Google Developer sitesinde bulunan Nexus cihazlarının en son ikili sürücülerinde bulunur.

Sürümler

sürüm Tarih notlar
1.0 5 Haziran 2017 Bülten yayınlandı.
1.1 7 Haziran 2017 Bülten, AOSP bağlantılarını içerecek şekilde revize edildi.
1.2 11 Temmuz 2017 Bülten, CVE-2017-6249'u içerecek şekilde revize edildi.
1.3 17 Ağustos 2017 Bülten, referans numaralarını güncellemek için revize edildi.