Biuletyn zabezpieczeń Androida - styczeń 2017 r

Opublikowano 3 stycznia 2017 r. | Zaktualizowano 2 lutego 2017 r

Biuletyn zabezpieczeń systemu Android zawiera szczegółowe informacje o lukach w zabezpieczeniach dotyczących urządzeń z systemem Android. Wraz z biuletynem udostępniliśmy aktualizację zabezpieczeń do urządzeń Google za pośrednictwem aktualizacji bezprzewodowej (OTA). Obrazy oprogramowania sprzętowego urządzeń Google zostały również udostępnione w witrynie Google Developer . Poziomy poprawek zabezpieczeń z 5 stycznia 2017 r. Lub nowszych rozwiązują wszystkie te problemy. Zapoznaj się z harmonogramem aktualizacji Pixela i Nexusa, aby dowiedzieć się, jak sprawdzić poziom poprawek zabezpieczeń urządzenia.

Partnerzy zostali powiadomieni o problemach opisanych w biuletynie 5 grudnia 2016 r. Lub wcześniej. Poprawki kodu źródłowego dotyczące tych problemów zostały udostępnione w repozytorium Android Open Source Project (AOSP) i połączone z tym biuletynem. Ten biuletyn zawiera również łącza do poprawek poza AOSP.

Najpoważniejszym z tych problemów jest krytyczna luka w zabezpieczeniach, która może umożliwić zdalne wykonanie kodu na urządzeniu, którego dotyczy luka, różnymi metodami, takimi jak poczta e-mail, przeglądanie sieci Web i wiadomości MMS podczas przetwarzania plików multimedialnych. Ocena istotności opiera się na skutkach, jakie wykorzystanie luki mogłoby prawdopodobnie mieć na urządzeniu, którego dotyczy luka, przy założeniu, że platforma i ograniczenia związane z usługami są wyłączone do celów programistycznych lub po pomyślnym ominięciu.

Nie otrzymaliśmy żadnych zgłoszeń dotyczących aktywnego wykorzystywania klientów lub nadużywania tych nowo zgłoszonych problemów. Szczegółowe informacje na temat zabezpieczeń platformy Android i zabezpieczeń usług, takich jak SafetyNet , które zwiększają bezpieczeństwo platformy Android, można znaleźć w sekcji Środki ograniczające zagrożenie dla usług Android i Google .

Zachęcamy wszystkich klientów do zaakceptowania tych aktualizacji na swoich urządzeniach.

Ogłoszenia

  • Ten biuletyn zawiera dwa ciągi poziomów poprawek zabezpieczeń, aby zapewnić partnerom systemu Android elastyczność w szybszym naprawianiu podzbioru luk w zabezpieczeniach, które są podobne na wszystkich urządzeniach z systemem Android. Aby uzyskać dodatkowe informacje, zobacz Często zadawane pytania i odpowiedzi :
    • 2017-01-01 : Częściowy ciąg poziomu poprawek zabezpieczeń. Ten ciąg poziomu poprawek zabezpieczeń wskazuje, że rozwiązano wszystkie problemy związane z 01.01.2017 (i wszystkie poprzednie ciągi poziomów poprawek zabezpieczeń).
    • 2017-01-05 : Pełny ciąg znaków poziomu poprawek zabezpieczeń. Ten ciąg poziomu poprawek zabezpieczeń wskazuje, że rozwiązano wszystkie problemy związane z 01.01.2017 i 05.01.2017 (i wszystkie poprzednie ciągi poziomów poprawek zabezpieczeń).
  • Obsługiwane urządzenia Google otrzymają pojedynczą aktualizację OTA z poziomem poprawek zabezpieczeń z 5 stycznia 2017 r.

Podsumowanie luk w zabezpieczeniach

Poniższe tabele zawierają listę luk w zabezpieczeniach, identyfikator znanych luk i zagrożeń (CVE), oszacowaną wagę oraz informację, czy problem dotyczy urządzeń Google. Ocena istotności opiera się na skutkach, jakie wykorzystanie luki mogłoby prawdopodobnie mieć na urządzeniu, którego dotyczy luka, przy założeniu, że platforma i ograniczenia związane z usługami są wyłączone do celów programistycznych lub po pomyślnym ominięciu.

Ograniczenia związane z usługami Android i Google

To jest podsumowanie środków zaradczych zapewnianych przez platformę zabezpieczeń systemu Android i zabezpieczenia usług, takie jak SafetyNet. Te możliwości zmniejszają prawdopodobieństwo pomyślnego wykorzystania luk w zabezpieczeniach w systemie Android.

  • Wykorzystanie wielu problemów na Androidzie jest utrudnione przez ulepszenia w nowszych wersjach platformy Android. Zachęcamy wszystkich użytkowników do aktualizacji do najnowszej wersji Androida, jeśli to możliwe.
  • Zespół Android Security aktywnie monitoruje nadużycia za pomocą Verify Apps i SafetyNet , które mają na celu ostrzeganie użytkowników o potencjalnie szkodliwych aplikacjach . Weryfikacja aplikacji jest domyślnie włączona na urządzeniach z usługami Google Mobile Services i jest szczególnie ważna dla użytkowników, którzy instalują aplikacje spoza Google Play. Narzędzia do rootowania urządzeń są zabronione w Google Play, ale Weryfikuj aplikacje ostrzega użytkowników, gdy próbują zainstalować wykrytą aplikację do rootowania - bez względu na to, skąd ona pochodzi. Ponadto Verify Apps próbuje zidentyfikować i zablokować instalację znanych złośliwych aplikacji, które wykorzystują lukę w zwiększaniu uprawnień. Jeśli taka aplikacja została już zainstalowana, Verify Apps powiadomi użytkownika i spróbuje usunąć wykrytą aplikację.
  • W razie potrzeby aplikacje Google Hangouts i Messenger nie przekazują automatycznie multimediów do procesów takich jak Mediaserver.

Podziękowanie

Chcielibyśmy podziękować tym badaczom za ich wkład:

Chcielibyśmy również podziękować następującym badaczom za ich wkład w powstanie biuletynu:

  • Baozeng Ding, Chengming Yang, Peng Xiao, Ning You, Yang Dong, Chao Yang, Yi Zhang i Yang Song of Alibaba Mobile Security Group
  • Peter Pi ( @heisecode ) firmy Trend Micro
  • Zubin Mithra z Google

2017-01-01 Poziom poprawek zabezpieczeń - szczegółowe informacje o usterce

W poniższych sekcjach przedstawiamy szczegółowe informacje na temat każdej luki w zabezpieczeniach, która ma zastosowanie do poziomu poprawek 2017-01-01. Istnieje opis problemu, uzasadnienie wagi oraz tabela z CVE, powiązanymi odniesieniami, wagą, zaktualizowanymi urządzeniami Google, zaktualizowanymi wersjami AOSP (jeśli dotyczy) i zgłoszoną datą. Gdy będzie dostępna, połączymy publiczną zmianę, która dotyczyła problemu, z identyfikatorem błędu, takim jak lista zmian AOSP. Gdy wiele zmian dotyczy jednego błędu, dodatkowe odniesienia są połączone z numerami po identyfikatorze błędu.

Luka umożliwiająca zdalne wykonanie kodu w c-ares

Luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w c-ares może umożliwić osobie atakującej za pomocą specjalnie spreparowanego żądania wykonanie dowolnego kodu w kontekście nieuprzywilejowanego procesu. Ten problem został oceniony jako wysoki ze względu na możliwość zdalnego wykonania kodu w aplikacji korzystającej z tej biblioteki.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2016-5180 A-32205736 Wysoki Wszystko 7.0 29 września 2016 r

Luka umożliwiająca zdalne wykonanie kodu w Framesequence

Luka w zabezpieczeniach umożliwiająca zdalne wykonanie kodu w bibliotece Framesequence może umożliwić osobie atakującej za pomocą specjalnie spreparowanego pliku wykonanie dowolnego kodu w kontekście nieuprzywilejowanego procesu. Ten problem został oceniony jako wysoki ze względu na możliwość zdalnego wykonania kodu w aplikacji korzystającej z biblioteki Framesequence.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0382 A-32338390 Wysoki Wszystko 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21 października 2016 r

Luka w zabezpieczeniach umożliwiająca podniesienie uprawnień w interfejsach API Framework

Luka umożliwiająca podniesienie uprawnień w interfejsach API Framework może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście procesu uprzywilejowanego. Ten problem jest oceniany jako wysoki, ponieważ można go użyć do uzyskania lokalnego dostępu do podwyższonych możliwości, które normalnie nie są dostępne dla aplikacji innej firmy.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0383 A-31677614 Wysoki Wszystko 7.0, 7.1.1 21 września 2016 r

Luka w zabezpieczeniach umożliwiająca podniesienie uprawnień w Audioserver

Luka w zabezpieczeniach serwera Audioserver umożliwiająca podniesienie uprawnień może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście procesu uprzywilejowanego. Ten problem jest oceniany jako wysoki, ponieważ można go użyć do uzyskania lokalnego dostępu do podwyższonych możliwości, które normalnie nie są dostępne dla aplikacji innej firmy.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0384 A-32095626 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 11 października 2016 r
CVE-2017-0385 A-32585400 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 11 października 2016 r

Luka umożliwiająca podniesienie uprawnień w bibliotece libnl

Luka umożliwiająca podniesienie uprawnień w bibliotece libnl może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście procesu uprzywilejowanego. Ten problem jest oceniany jako wysoki, ponieważ można go użyć do uzyskania lokalnego dostępu do podwyższonych możliwości, które normalnie nie są dostępne dla aplikacji innej firmy.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0386 A-32255299 Wysoki Wszystko 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 18 października 2016 r

Luka umożliwiająca podniesienie uprawnień w serwerze Mediaserver

Luka umożliwiająca podniesienie uprawnień w serwerze Mediaserver może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście procesu uprzywilejowanego. Ten problem jest oceniany jako wysoki, ponieważ można go użyć do uzyskania lokalnego dostępu do podwyższonych możliwości, które normalnie nie są dostępne dla aplikacji innej firmy.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0387 A-32660278 Wysoki Wszystko 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 4 listopada 2016 r

Luka umożliwiająca ujawnienie informacji w zewnętrznym dostawcy pamięci masowej

Luka umożliwiająca ujawnienie informacji w zewnętrznym dostawcy pamięci masowej może umożliwić lokalnemu dodatkowemu użytkownikowi odczytanie danych z zewnętrznej karty pamięci SD włożonej przez głównego użytkownika. Ten problem został oceniony jako wysoki, ponieważ może być używany do uzyskiwania dostępu do danych bez pozwolenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0388 A-32523490 Wysoki Wszystko 6.0, 6.0.1, 7.0, 7.1.1 Wewnętrzne Google

Luka w zabezpieczeniach typu „odmowa usługi” w podstawowej sieci

Luka w zabezpieczeniach typu „odmowa usługi” w podstawowej sieci może umożliwić zdalnej osobie atakującej użycie specjalnie spreparowanego pakietu sieciowego w celu zawieszenia lub ponownego uruchomienia urządzenia. Ten problem został oceniony jako wysoki ze względu na możliwość zdalnej odmowy usługi.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0389 A-31850211 [ 2 ] [ 3 ] Wysoki Wszystko 6.0, 6.0.1, 7.0, 7.1.1 20 lipca 2016 r

Luka typu „odmowa usługi” w serwerze Mediaserver

Luka w zabezpieczeniach typu „odmowa usługi” w serwerze Mediaserver może umożliwić zdalnej osobie atakującej użycie specjalnie spreparowanego pliku w celu zawieszenia lub ponownego uruchomienia urządzenia. Ten problem został oceniony jako wysoki ze względu na możliwość zdalnej odmowy usługi.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0390 A-31647370 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 19 września 2016 r
CVE-2017-0391 A-32322258 Wysoki Wszystko 6.0, 6.0.1, 7.0, 7.1.1 20 października 2016 r
CVE-2017-0392 A-32577290 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 29 października 2016 r
CVE-2017-0393 A-30436808 Wysoki Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Wewnętrzne Google

Luka w zabezpieczeniach typu „odmowa usługi” w telefonii

Luka w zabezpieczeniach typu „odmowa usługi” w telefonii może umożliwić zdalnej osobie atakującej zawieszenie lub ponowne uruchomienie urządzenia. Ten problem został oceniony jako wysoki ze względu na możliwość zdalnej odmowy usługi.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0394 A-31752213 Wysoki Wszystko 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 23 września 2016 r

Luka umożliwiająca podniesienie uprawnień w Kontaktach

Luka umożliwiająca podniesienie uprawnień w Kontaktach może umożliwić lokalnej złośliwej aplikacji dyskretne tworzenie informacji kontaktowych. Ten problem jest oceniany jako umiarkowany, ponieważ jest to lokalne obejście wymagań dotyczących interakcji użytkownika (dostęp do funkcji, które normalnie wymagałyby zainicjowania przez użytkownika lub jego zgody).

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0395 A-32219099 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 15 października 2016 r

Luka umożliwiająca ujawnienie informacji w Mediaserver

Luka w zabezpieczeniach umożliwiająca ujawnienie informacji w Mediaserver może umożliwić lokalnej złośliwej aplikacji dostęp do danych poza jej poziomami uprawnień. Ten problem został oceniony jako umiarkowany, ponieważ może być używany do uzyskiwania dostępu do poufnych danych bez pozwolenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0381 A-31607432 Umiarkowany Wszystko 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 18 września 2016 r
CVE-2017-0396 A-31781965 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 27 września 2016 r
CVE-2017-0397 A-32377688 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21 października 2016 r

Luka umożliwiająca ujawnienie informacji w Audioserver

Luka umożliwiająca ujawnienie informacji w Audioserver może umożliwić lokalnej złośliwej aplikacji dostęp do danych poza jej poziomami uprawnień. Ten problem jest oceniany jako umiarkowany, ponieważ może być używany do uzyskiwania dostępu do poufnych danych bez pozwolenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Zaktualizowane wersje AOSP Data zgłoszenia
CVE-2017-0398 A-32438594 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 października 2016 r
CVE-2017-0398 A-32635664 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 października 2016 r
CVE-2017-0398 A-32624850 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 października 2016 r
CVE-2017-0399 A-32247948 [ 2 ] Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 18 października 2016 r
CVE-2017-0400 A-32584034 [ 2 ] Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 października 2016 r
CVE-2017-0401 A-32448258 Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 26 października 2016 r
CVE-2017-0402 A-32436341 [ 2 ] Umiarkowany Wszystko 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 października 2016 r

2017-01-05 Poziom poprawek zabezpieczeń - szczegółowe informacje o usterce

W poniższych sekcjach przedstawiamy szczegółowe informacje na temat każdej luki w zabezpieczeniach, która dotyczy poziomu poprawek 2017-01-05. Istnieje opis problemu, uzasadnienie wagi oraz tabela z CVE, powiązanymi odniesieniami, wagą, zaktualizowanymi urządzeniami Google, zaktualizowanymi wersjami AOSP (w stosownych przypadkach) i zgłoszoną datą. Gdy będzie dostępna, połączymy publiczną zmianę, która dotyczyła problemu, z identyfikatorem błędu, takim jak lista zmian AOSP. Gdy wiele zmian dotyczy jednego błędu, dodatkowe odniesienia są połączone z numerami po identyfikatorze błędu.

Luka umożliwiająca podniesienie uprawnień w podsystemie pamięci jądra

Luka w zabezpieczeniach podsystemu pamięci jądra umożliwiająca podniesienie uprawnień może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem został oceniony jako krytyczny ze względu na możliwość lokalnego trwałego naruszenia bezpieczeństwa urządzenia, co może wymagać ponownego flashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2015-3288 A-32460277
Jądro upstream
Krytyczny Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel C, Nexus Player, Pixel, Pixel XL 9 lipca 2015 r

Luka w zabezpieczeniach umożliwiająca podniesienie uprawnień w programie ładującym Qualcomm

Luka umożliwiająca podniesienie uprawnień w programie ładującym Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem został oceniony jako krytyczny ze względu na możliwość lokalnego trwałego naruszenia bezpieczeństwa urządzenia, co może wymagać ponownego flashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8422 A-31471220
QC-CR # 979426
Krytyczny Nexus 6, Nexus 6P, Pixel, Pixel XL 22 lipca 2016 r
CVE-2016-8423 A-31399736
QC-CR # 1000546
Krytyczny Nexus 6P, Pixel, Pixel XL 24 sierpnia 2016

Luka umożliwiająca podniesienie uprawnień w systemie plików jądra

Luka w zabezpieczeniach systemu plików jądra umożliwiająca podniesienie uprawnień może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem został oceniony jako krytyczny ze względu na możliwość lokalnego trwałego naruszenia bezpieczeństwa urządzenia, co może wymagać ponownego flashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2015-5706 A-32289301
Jądro upstream
Krytyczny Żaden* 1 sierpnia 2016

* Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.0 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Luka umożliwiająca podniesienie uprawnień w sterowniku GPU NVIDIA

Luka w zabezpieczeniach sterownika GPU NVIDIA umożliwiająca podniesienie uprawnień może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem został oceniony jako krytyczny ze względu na możliwość lokalnego trwałego naruszenia bezpieczeństwa urządzenia, co może wymagać ponownego flashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8424 A-31606947 *
N-CVE-2016-8424
Krytyczny Nexus 9 17 września 2016 r
CVE-2016-8425 A-31797770 *
N-CVE-2016-8425
Krytyczny Nexus 9 28 września 2016 r
CVE-2016-8426 A-31799206 *
N-CVE-2016-8426
Krytyczny Nexus 9 28 września 2016 r
CVE-2016-8482 A-31799863 *
N-CVE-2016-8482
Krytyczny Nexus 9 28 września 2016 r
CVE-2016-8427 A-31799885 *
N-CVE-2016-8427
Krytyczny Nexus 9 28 września 2016 r
CVE-2016-8428 A-31993456 *
N-CVE-2016-8428
Krytyczny Nexus 9 6 października 2016 r
CVE-2016-8429 A-32160775 *
N-CVE-2016-8429
Krytyczny Nexus 9 13 października 2016 r
CVE-2016-8430 A-32225180 *
N-CVE-2016-8430
Krytyczny Nexus 9 17 października 2016 r
CVE-2016-8431 A-32402179 *
N-CVE-2016-8431
Krytyczny Pixel C 25 października 2016 r
CVE-2016-8432 A-32447738 *
N-CVE-2016-8432
Krytyczny Pixel C 26 października 2016 r

* Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Luka umożliwiająca podniesienie uprawnień w sterowniku MediaTek

Luka umożliwiająca podniesienie uprawnień w sterowniku MediaTek może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem został oceniony jako krytyczny ze względu na możliwość lokalnego trwałego naruszenia bezpieczeństwa urządzenia, co może wymagać ponownego flashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8433 A-31750190 *
MT-ALPS02974192
Krytyczny Żaden** 24 września 2016 r

* Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.0 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Luka umożliwiająca podniesienie uprawnień w sterowniku GPU Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku GPU Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem został oceniony jako krytyczny ze względu na możliwość lokalnego trwałego naruszenia bezpieczeństwa urządzenia, co może wymagać ponownego flashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8434 A-32125137
QC-CR # 1081855
Krytyczny Nexus 5X, Nexus 6, Nexus 6P, Android One 12 października 2016 r

Luka umożliwiająca podniesienie uprawnień w sterowniku GPU NVIDIA

Luka w zabezpieczeniach sterownika GPU NVIDIA umożliwiająca podniesienie uprawnień może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem został oceniony jako krytyczny ze względu na możliwość lokalnego trwałego naruszenia bezpieczeństwa urządzenia, co może wymagać ponownego flashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8435 A-32700935 *
N-CVE-2016-8435
Krytyczny Pixel C 7 listopada 2016 r

* Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Luka umożliwiająca podniesienie uprawnień w sterowniku wideo Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku wideo Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem został oceniony jako krytyczny ze względu na możliwość lokalnego trwałego naruszenia bezpieczeństwa urządzenia, co może wymagać ponownego flashowania systemu operacyjnego w celu naprawy urządzenia.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8436 A-32450261
QC-CR # 1007860
Krytyczny Żaden* 13 października 2016 r

* Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.0 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Luki w komponentach Qualcomm

Następujące luki w zabezpieczeniach dotyczą składników Qualcomm i zostały szczegółowo opisane w biuletynach zabezpieczeń Qualcomm AMSS z listopada 2015, sierpnia 2016, września 2016 i października 2016.

CVE Bibliografia Surowość* Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8438 A-31624565 ** Krytyczny Żaden*** Qualcomm wewnętrzny
CVE-2016-8442 A-31625910 ** Krytyczny Żaden*** Qualcomm wewnętrzny
CVE-2016-8443 A-32576499 ** Krytyczny Żaden*** Qualcomm wewnętrzny
CVE-2016-8437 A-31623057 ** Wysoki Żaden*** Qualcomm wewnętrzny
CVE-2016-8439 A-31625204 ** Wysoki Żaden*** Qualcomm wewnętrzny
CVE-2016-8440 A-31625306 ** Wysoki Żaden*** Qualcomm wewnętrzny
CVE-2016-8441 A-31625904 ** Wysoki Żaden*** Qualcomm wewnętrzny
CVE-2016-8398 A-31548486 ** Wysoki Nexus 5X, Nexus 6, Nexus 6P, Android One Qualcomm wewnętrzny
CVE-2016-8459 A-32577972 ** Wysoki Żaden*** Qualcomm wewnętrzny
CVE-2016-5080 A-31115235 ** Umiarkowany Nexus 5X Qualcomm wewnętrzny

* Ocena ważności tych luk została określona przez dostawcę.

** Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

*** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.0 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Podatność na podniesienie uprawnień w kamerze Qualcomm

Luka umożliwiająca podniesienie uprawnień w kamerze Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8412 A-31225246
QC-CR # 1071891
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 26 sierpnia 2016
CVE-2016-8444 A-31243641 *
QC-CR # 1074310
Wysoki Nexus 5X, Nexus 6, Nexus 6P 26 sierpnia 2016

* Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Luka w zabezpieczeniach umożliwiająca podniesienie uprawnień w składnikach MediaTek

Luka umożliwiająca podniesienie uprawnień w składnikach MediaTek, w tym sterowniku termicznym i sterowniku wideo, może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8445 A-31747590 *
MT-ALPS02968983
Wysoki Żaden** 25 września 2016 r
CVE-2016-8446 A-31747749 *
MT-ALPS02968909
Wysoki Żaden** 25 września 2016 r
CVE-2016-8447 A-31749463 *
MT-ALPS02968886
Wysoki Żaden** 25 września 2016 r
CVE-2016-8448 A-31791148 *
MT-ALPS02982181
Wysoki Żaden** 28 września 2016 r

* Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.0 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Luka w zabezpieczeniach umożliwiająca podniesienie uprawnień w sterowniku Qualcomm Wi-Fi

Luka umożliwiająca podniesienie uprawnień w sterowniku Qualcomm Wi-Fi może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8415 A-31750554
QC-CR # 1079596
Wysoki Nexus 5X, Pixel, Pixel XL 26 września 2016 r

Luka umożliwiająca podniesienie uprawnień w sterowniku GPU NVIDIA

Luka w zabezpieczeniach sterownika GPU NVIDIA umożliwiająca podniesienie uprawnień może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8449 A-31798848 *
N-CVE-2016-8449
Wysoki Nexus 9 28 września 2016 r

* Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Luka umożliwiająca podniesienie uprawnień w sterowniku dźwięku Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku dźwięku Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8450 A-32450563
QC-CR # 880388
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Android One 13 października 2016 r

Podniesienie poziomu uprawnień w sterowniku ekranu dotykowego Synaptics

Luka umożliwiająca podniesienie uprawnień w sterowniku ekranu dotykowego Synaptics może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8451 A-32178033 * Wysoki Żaden** 13 października 2016 r

* Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

** Ta luka nie dotyczy obsługiwanych urządzeń Google z systemem Android 7.0 lub nowszym, na których zainstalowano wszystkie dostępne aktualizacje.

Luka w zabezpieczeniach podsystemu zabezpieczeń jądra umożliwiająca podniesienie uprawnień

Luka umożliwiająca podniesienie uprawnień w podsystemie zabezpieczeń jądra może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-7042 A-32178986
Jądro upstream
Wysoki Pixel C 14 października 2016 r

Luka umożliwiająca podniesienie uprawnień w podsystemie wydajności jądra

Luka umożliwiająca podniesienie uprawnień w podsystemie wydajności jądra może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0403 A-32402548 * Wysoki Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL 25 października 2016 r

* Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Podatność na podniesienie uprawnień w podsystemie dźwiękowym jądra

Luka umożliwiająca podniesienie uprawnień w podsystemie dźwiękowym jądra może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2017-0404 A-32510733 * Wysoki Nexus 5X, Nexus 6P, Nexus 9, Pixel C, Nexus Player, Pixel, Pixel XL 27 października 2016 r

* Łatka dotycząca tego problemu nie jest publicznie dostępna. Aktualizacja jest zawarta w najnowszych sterownikach binarnych dla urządzeń Nexus dostępnych w witrynie Google Developer .

Luka w zabezpieczeniach umożliwiająca podniesienie uprawnień w sterowniku Qualcomm Wi-Fi

Luka umożliwiająca podniesienie uprawnień w sterowniku Qualcomm Wi-Fi może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8452 A-32506396
QC-CR # 1050323
Wysoki Nexus 5X, Android One, Pixel, Pixel XL 28 października 2016 r

Luka w zabezpieczeniach umożliwiająca podniesienie uprawnień w sterowniku radiowym Qualcomm

Luka umożliwiająca podniesienie uprawnień w sterowniku radia Qualcomm może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-5345 A-32639452
QC-CR # 1079713
Wysoki Android One 3 listopada 2016 r

Luka umożliwiająca podniesienie uprawnień w podsystemie profilowania jądra

Luka umożliwiająca podniesienie uprawnień w podsystemie profilowania jądra może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-9754 A-32659848
Jądro upstream
Wysoki Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player 4 listopada 2016 r

Luka umożliwiająca podniesienie uprawnień w sterowniku Broadcom Wi-Fi

Luka umożliwiająca podniesienie uprawnień w sterowniku Broadcom Wi-Fi może umożliwić lokalnej złośliwej aplikacji wykonanie dowolnego kodu w kontekście jądra. Ten problem jest oceniany jako wysoki, ponieważ najpierw wymaga złamania uprzywilejowanego procesu.

CVE Bibliografia Surowość Zaktualizowane urządzenia Google Data zgłoszenia
CVE-2016-8453 A-24739315 *
B-RB # 73392
Wysoki Nexus 6 Wewnętrzne Google
CVE-2016-8454 A-32174590*
B-RB#107142
High Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 14, 2016
CVE-2016-8455 A-32219121*
B-RB#106311
High Nexus 6P Oct 15, 2016
CVE-2016-8456 A-32219255*
B-RB#105580
High Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 15, 2016
CVE-2016-8457 A-32219453*
B-RB#106116
High Nexus 6, Nexus 6P, Nexus 9, Pixel C Oct 15, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Synaptics touchscreen driver

An elevation of privilege vulnerability in the Synaptics touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8458 A-31968442* High Nexus 5X, Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in NVIDIA video driver

An information disclosure vulnerability in the NVIDIA video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-8460 A-31668540*
N-CVE-2016-8460
High Nexus 9 Sep 21, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in bootloader

An information disclosure vulnerability in the bootloader could enable a local attacker to access data outside of its permission level. This issue is rated as High because it could be used to access sensitive data.

CVE References Severity Updated Google devices Date reported
CVE-2016-8461 A-32369621* High Nexus 9, Pixel, Pixel XL Oct 21, 2016
CVE-2016-8462 A-32510383* High Pixel, Pixel XL Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Denial of service vulnerability in Qualcomm FUSE file system

A denial of service vulnerability in the Qualcomm FUSE file system could enable a remote attacker to use a specially crafted file to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-8463 A-30786860
QC-CR#586855
High None* Jan 03, 2014

* Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Denial of service vulnerability in bootloader

A denial of service vulnerability in the bootloader could enable an attacker to cause a local permanent denial of service, which may require reflashing the operating system to repair the device. This issue is rated as High due to the possibility of local permanent denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-8467 A-30308784* High Nexus 6, Nexus 6P Jun 29, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Broadcom Wi-Fi driver

An elevation of privilege vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8464 A-29000183*
B-RB#106314
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player May 26, 2016
CVE-2016-8466 A-31822524*
B-RB#105268
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Sep 28, 2016
CVE-2016-8465 A-32474971*
B-RB#106053
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Binder

An elevation of privilege vulnerability in Binder could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8468 A-32394425* Moderate Pixel C, Pixel, Pixel XL Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in NVIDIA camera driver

An information disclosure vulnerability in the camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8469 A-31351206*
N-CVE-2016-8469
Moderate Nexus 9 Sep 7, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in MediaTek driver

An information disclosure vulnerability in the MediaTek driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8470 A-31528889*
MT-ALPS02961395
Moderate None** Sep 15, 2016
CVE-2016-8471 A-31528890*
MT-ALPS02961380
Moderate None** Sep 15, 2016
CVE-2016-8472 A-31531758*
MT-ALPS02961384
Moderate None** Sep 15, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in STMicroelectronics driver

An information disclosure vulnerability in the STMicroelectronics driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8473 A-31795790* Moderate Nexus 5X, Nexus 6P Sep 28, 2016
CVE-2016-8474 A-31799972* Moderate Nexus 5X, Nexus 6P Sep 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm audio post processor

An information disclosure vulnerability in the Qualcomm audio post processor could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it could be used to access sensitive data without permission.

CVE References Severity Updated Google devices Updated AOSP versions Date reported
CVE-2017-0399 A-32588756 [ 2 ] Moderate All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 18, 2016
CVE-2017-0400 A-32438598 [ 2 ] Moderate All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 25, 2016
CVE-2017-0401 A-32588016 Moderate All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 26, 2016
CVE-2017-0402 A-32588352 [ 2 ] Moderate All 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Oct 25, 2016

Information disclosure vulnerability in HTC input driver

An information disclosure vulnerability in the HTC input driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8475 A-32591129* Moderate Pixel, Pixel XL Oct 30, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Denial of service vulnerability in kernel file system

A denial of service vulnerability in the kernel file system could enable a local malicious application to cause a device hang or reboot. This issue is rated as Moderate because it is a temporary denial of service that requires a factory reset to fix.

CVE References Severity Updated Google devices Date reported
CVE-2014-9420 A-32477499
Upstream kernel
Moderate Pixel C Dec 25, 2014

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-01-01 or later address all issues associated with the 2017-01-01 security patch level.
  • Security patch levels of 2017-01-05 or later address all issues associated with the 2017-01-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-01-01]
  • [ro.build.version.security_patch]:[2017-01-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the January 1, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of January 5, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-01-01 and 2017-01-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running the latest available version of Android are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • January 03, 2017: Bulletin published.
  • January 04, 2017: Bulletin revised to include AOSP links.
  • January 05, 2017: Clarified AOSP version number from 7.1 to 7.1.1.
  • January 12, 2017: Removed duplicate entry for CVE-2016-8467.
  • January 24, 2017: Updated description and severity for CVE-2017-0381.
  • February 2, 2017: Updated CVE-2017-0389 with additional patch link.